-   Slackware (
-   -   pdfunite broken? (

business_kid 02-16-2013 08:20 AM

pdfunite broken?
Anyone got any good out of pdfunite in Slackware-14.0? I can't get it to accept any filenames. It seems to be for use with pdfseparate, for making booklets out of pdfs in page order.

It refuses all filenames, and I have tried all permutations I can think of.

allend 02-16-2013 08:43 AM

Just did a quick test and it worked for me. I was unaware of this command, so thanks for pointing it out. I can make use of this.

fskmh 02-16-2013 08:50 AM

I just picked two arbitrary PDFs and combined them with

pdfunite a.pdf b.pdf c.pdf
where c.pdf is the destfile and it works here.


grep pdfunite /var/log/packages/*

(Running current as of 15 Feb and I don't think poppler has been upgraded since the release of 14.0.)

business_kid 02-17-2013 12:06 PM

Weird. It's working for me now. I think it was too many suspend/resumes, or maybe some bitchiness from the printer itself (going into cycles of downloading firmware endlessly).

On the way through, I noticed Adobe Acrobloat does have a booklet printing option. psbook does similarly and processes pdfs also. There is also psbook. With a 4 page pdf, I was doing this


bash-4.2$ pdfseparate file.pdf test%d.pdf 
bash-4.2$ ls test*
test1.pdf  test2.pdf  test3.pdf  test4.pdf
bash-4.2$ pdfunite test4.pdf test1.pdf front.pdf
bash-4.2$ pdfunite test2.pdf test3.pdf rear.pdf
bash-4.2$ lp -o media=a4 -o landscape -o number-up=2 front.pdf
bash-4.2$ lp -o media=a4 -o landscape -o number-up=2 rear.pdf

But I was getting stuck on the pdfunite stage. Thx again

All times are GMT -5. The time now is 03:16 PM.