LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-01-2008, 09:03 PM   #1
imtedkaczynski
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Rep: Reputation: Disabled
Partition table problem. fdis is lying to me, shows the wrong mount point I believe


EDIT - Sorry just realized theres an installation issues spot, if this could be moved that'd be great, sorry for the hassle though =/

Okay so I've been dual booting Ubuntu and Win xp until a few weeks ago when I decided (I honestly don't know why) to "upgrade" to vista. Not only that but I decided to put slackware back into my life after I recently decided to try out the newest ubuntu versions.

So here is my dilemma. I run the set-up(okay I ran it about 6 times and it tried installing to my CD drive, my fault, i found it interesting it told me everything installed though never got an error until lilo) and after being confused for a while I realize that /dev/hda is my cd drive. I ran fdisk -l and it told me the harddrive I want the slack install on is /dev/hdd. where my windows drive is /dev/sda. So I format my drive, and all that good stuff, after a few errors from things like lilo couldn't be installed to "wrote to partition table but could not read table, reboot to read partition table" or something close to that. So I try the Ubuntu cd and as I suspected, my drive is /dev/sdb. I confirmed this again with successfully installing fedora core 9 (now 10's out damn it).

So how can I got about fixing this? I would like to not lose vista (well windows, I'll downgrade to xp if it'll really make things a lot simpler, my printer isn't supported, and I find itune the only decent iphone app).

Update - I partioned /dev/hdd (although every other distro shows it as /dev/sdb) set up my swap and root partions. One problem I'm still having is getting lilo to work. so I isolated the drive (removed the windows drive from my computer to see if I can't get the install to work without the dual booting hassle first.) What is the best place to install lilo, I have tried the MBR and superblock with no luck. I don't know how to configure it manually, but I'd be willing to learn. Is there anyway for me to boot up without installing lilo? I never get the option for a boot disk, and I don't own a thumb drive, am I missing something somewhere, or did this option get removed in 12.1?

Last edited by imtedkaczynski; 12-01-2008 at 10:07 PM. Reason: I'm an ass
 
Old 12-02-2008, 01:58 AM   #2
zeno0771
Member
 
Registered: Jun 2006
Location: Northern IL
Distribution: Arch64
Posts: 106

Rep: Reputation: 19
I ran into a similar problem with dual booting XP and Zenwalk on a HTPC...seems Slack-based distros don't necessarily name drives differently so much as they name them in a different order. Argued with this particular machine for a week with this same problem...this is made worse if you have a mix of SATA and IDE drives, by the way.

The thing to remember is that Slack puts LILO on the MBR of the first bootable drive that it finds. This, of course, may very well be the wrong drive as far as you're concerned; LILO will end up on MBR of the Windows drive and won't be able to find the otherwise-perfectly-good Slack install because the order in which they were named is different.

Determine which physical drive Slack considers the first in line, then:

- If it's SATA, make sure it's going to SATA port 0; if it's IDE make sure it's on the right plug and has the right jumper settings.
- In BIOS, make sure the drive boot order is set the way it needs to be (especially if you have mixed SATA/IDE because some BIOSes and/or Linux distributions will look at the SATA drives first, others the IDE drives). The point to all of this is to get the BIOS and the Slack install to agree on which drive comes first in the boot order.
- Then--yeah, I know, but I gotta say it anyway--make sure the right drive is marked as bootable in cfdisk. Install, let it find the Windows install & add it to LILO, and go with the MBR LILO install.

I've always preferred GRUB to LILO, but it appears Slack and its derivatives are planning on keeping it around for the forseeable future.
 
Old 12-02-2008, 02:02 AM   #3
htnakirs
Member
 
Registered: Mar 2007
Posts: 239

Rep: Reputation: 34
Tried Grub, instead of LILO?
 
Old 12-02-2008, 02:07 AM   #4
imtedkaczynski
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: Disabled
My jumper should be slave correct? or is it better set as cs, or even master? I got my install to work with the single drive in. everything worked fine, I didn't try lilo though, should have. I'll have to try out your suggestions tomorrow, as I was trying to get my mouse working and destroyed my xorg.conf. so x doesn't want to start hah. I have a back-up but I haven't got around to restoring it yet. Have the windows drive in backing everything up to the external incase my system goes catatonic and I just re-install everything.

My problem with grub is I can never get the kernel command to work, I haven't used slack for a few years though, I know a bit mroe in the terminals now (atleast with ubuntu =/ ). Even hitting TAB it just stays blank. what would I type in if my instal is mounted at /dev/hdd#? I tried a few things but the only real inf I could find on boting with grub used vmlinuz, and I used the default kernel when I installed. I booted up with the install cd finally, and got everything but my mouse working (razer diamond back, I haven't had luck finding a reliable driver yet)

I believe my boot order is correct in the BIOS, but I'll recheck. Thanks for the info =)

Last edited by imtedkaczynski; 12-02-2008 at 02:10 AM.
 
Old 12-02-2008, 03:04 AM   #5
niels.horn
Senior Member
 
Registered: Mar 2007
Location: Rio de Janeiro - Brazil
Distribution: Slackware64-current
Posts: 1,004

Rep: Reputation: 91
With kernel versions before 2.6.27 (Slackware 12.1-stable comes with 2.6.24.5) on *some* systems SATA disks would show up as hd* instead of sd*. I had this problem on a Dell laptop.
The newer kernels show SATA disks correctly as sd* on these systems.

You can try forcing to recognize the drive as SATA by using the hdd=noprobe boot parameter.
You might have to add several parameters, like "hda==noprobe hdb=noprobe hdc=noprobe" ... etc.
 
Old 12-05-2008, 03:34 AM   #6
zeno0771
Member
 
Registered: Jun 2006
Location: Northern IL
Distribution: Arch64
Posts: 106

Rep: Reputation: 19
Quote:
Originally Posted by imtedkaczynski View Post
My jumper should be slave correct? or is it better set as cs, or even master? I got my install to work with the single drive in. everything worked fine, I didn't try lilo though, should have. I'll have to try out your suggestions tomorrow, as I was trying to get my mouse working and destroyed my xorg.conf. so x doesn't want to start hah. I have a back-up but I haven't got around to restoring it yet. Have the windows drive in backing everything up to the external incase my system goes catatonic and I just re-install everything.

My problem with grub is I can never get the kernel command to work, I haven't used slack for a few years though, I know a bit mroe in the terminals now (atleast with ubuntu =/ ). Even hitting TAB it just stays blank. what would I type in if my instal is mounted at /dev/hdd#? I tried a few things but the only real inf I could find on boting with grub used vmlinuz, and I used the default kernel when I installed. I booted up with the install cd finally, and got everything but my mouse working (razer diamond back, I haven't had luck finding a reliable driver yet)

I believe my boot order is correct in the BIOS, but I'll recheck. Thanks for the info =)
Assuming both hard drives are on the same IDE cable, set cable select on both drives, but you still have to make sure the drive with your bootloader is the first one on the cable. Doesn't hurt to have your drives on the primary and optical(s) on the secondary; on some boards it makes a difference, others not so much. In all likelihood, if you put your Slack drive first and Win drive second, with both on the primary cable, you should be good to go

First, you tell GRUB where the root partition is. Then you tell it where the kernel image (vmlinuz) is, then you tell it where the initramdisk file is (initrd), then you tell it to boot.
It goes "command [/path/to/whatever]" like this:
Code:
GRUB> root (hdx,y) /*where 'x' is the drive and 'y' is the partition*/
GRUB> kernel /boot/vmlinuz-2.6.2x.x-blahblah
GRUB> initrd /boot/initrd-2.6.2x.x-blahblah /*or initrd.splash*/
GRUB> boot
Remember when you're telling GRUB where the root drive/partition is in the first line, it starts counting at zero, not 1, i.e. the second partition on the first drive would be (hd0,1), not (hd1,2).

Last edited by zeno0771; 12-05-2008 at 03:37 AM.
 
Old 12-05-2008, 10:41 AM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,928

Rep: Reputation: 612Reputation: 612Reputation: 612Reputation: 612Reputation: 612Reputation: 612
On very large drives >80MB, you usually have to use cs for the jumpers -else the drives cannot be detected properly by the BIOS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ghost and wrong partition table Doeners Linux - Hardware 1 03-07-2006 03:20 AM
Invalid Partition Table on /dev/sda - Wrong Signature 0 ulasergin Fedora - Installation 1 06-30-2005 12:59 AM
Wrong partition table info Maik Linux - General 5 01-19-2005 01:42 PM
Wrong partition table Aqeloutro Fedora - Installation 2 05-20-2004 08:47 PM
root partition shows wrong total size Dergro Linux - General 12 10-08-2003 12:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration