LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-30-2011, 05:36 PM   #1
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 294

Rep: Reputation: 39
Pagodabox terminal client (written in ruby) - cannot make it work on Slackware


Hi Slackers,

My host is Pagodabox and they have this command line client (a ruby gem) and that it doesn't work on Slackware.

Here is my post in Pagodabox site: http://help.pagodabox.com/customer/p...king-gli-error

Code:
Ruby version: ruby 1.9.1p431 (2011-02-18 revision 30908) [i486-linux]
Gem version: 1.3.1
Linux: Slackware Linux 13.37, 32 bit
And this is what I got when running the Pagodabox executable.

Code:
lysender@darkstar:~$ pagoda
/home/lysender/.gem/ruby/1.9.1/gems/gli-1.3.5/lib/gli.rb:531:in 'verify_unused_in_option': a has already been specified as a flag in global options (ArgumentError)
  from /home/lysender/.gem/ruby/1.9.1/gems/gli-1.3.5/lib/gli.rb:523:in 'block in verify_unused'
  from /home/lysender/.gem/ruby/1.9.1/gems/gli-1.3.5/lib/gli.rb:522:in 'each'
  from /home/lysender/.gem/ruby/1.9.1/gems/gli-1.3.5/lib/gli.rb:522:in 'verify_unused'
  from /home/lysender/.gem/ruby/1.9.1/gems/gli-1.3.5/lib/gli.rb:122:in 'flag'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli/commands/clone.rb:7:in 'block in <top (required)>'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli/override.rb:14:in 'instance_eval'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli/override.rb:14:in 'command'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli/commands/clone.rb:3:in '<top (required)>'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli/commands.rb:1:in 'require'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli/commands.rb:1:in '<top (required)>'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli.rb:2:in 'require'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/lib/pagoda/cli.rb:2:in '<top (required)>'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/bin/pagoda:33:in 'require'
  from /home/lysender/.gem/ruby/1.9.1/gems/pagoda-0.5.0/bin/pagoda:33:in '<top (required)>'
  from /usr/bin/pagoda:19:in 'load'
  from /usr/bin/pagoda:19:in '<main>'
lysender@darkstar:~$
The only thing I need on this terminal client is the command that allows me to tunnel MySQL to my local machine since that is the only way they provided for accessing Pagodabox MySQL servers. I managed to temporarily install phpMyAdmin but of course it will not be ideal anymore when my application grows.

Are you familiar with the above gli error?

Thanks
 
Old 12-02-2011, 03:25 AM   #2
vulcan59
Member
 
Registered: Sep 2007
Location: UK
Distribution: Slackware 14.2 & Current
Posts: 96

Rep: Reputation: 30
Hi.

I have had a couple of problems with Ruby applications since upgrading to 13.37 and those error messages look familiar. I found that the applications needed to be updated to work with Ruby 1.9.1. In both cases they worked ok with Ruby 1.8.7. I am not a Ruby expert but I understand there were some changes between 1.8.7 and 1.9.1 which tightened up or changed some of the syntax. In my cases the applications got fixed so they worked on both versions of Ruby. I can only suggest reporting this to the maintainers of the application or trying to install Ruby 1.8.7 on your system. Search on Google and you will find various articles and discussions about this.
 
1 members found this post helpful.
Old 12-02-2011, 09:52 PM   #3
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 294

Original Poster
Rep: Reputation: 39
So is it the gli program or the pagodabox client?

Anyway, I will try to downgrade ruby on my Slackware box and see if it works.

Thanks
 
Old 12-02-2011, 11:10 PM   #4
Uzuki
LQ Newbie
 
Registered: Jun 2010
Location: Indonesia
Distribution: Slackware, RedHat
Posts: 27

Rep: Reputation: 4
Ruby applications is a little tricky to deploy. I've had the same problem with ruby-1.9.1 in slackware-13.37 as well when I tried to install redmine. I had to install ruby-1.8.7 to make it work. No need to uninstall ruby-1.9.1, just use RVM (Ruby Version Manager) to change the environment between ruby 1.8.7 and 1.9.1. Just google for RVM
 
1 members found this post helpful.
Old 12-03-2011, 03:38 AM   #5
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 294

Original Poster
Rep: Reputation: 39
I tried RVM and it works. I just re-installed the gem after switching to 1.8.7.

Many thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any issues installing Ruby Gems and Ruby on Rails in Slackware? Lufbery Slackware 8 02-09-2011 07:22 PM
Ruby does not work with tcl/tk in Slackware current AGer Slackware 6 12-08-2009 06:19 AM
Needed help in web development where libraries are written in Ruby!!! wrapster Programming 2 12-08-2008 10:52 PM
Make Linux Act As A Thin Client Terminal Server! blackfish Linux - Server 2 04-11-2007 09:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration