-   Slackware (
-   -   Package updates (

Kairon 09-30-2006 12:58 PM

Package updates
I downloaded and installed a few updates from, including gtk+2-2.8.20-i486-1.tgz, pango-1.12.4-i486-1.tgz, libglade-2.5.1-i486-1.tgz, and cairo-1.0.4-i486-1.tgz. I also found python gtk+ bindings in .rpm and installed those using rpm2tgz. Now when I try to start gvim I get an error:


bash-3.00# gvim
gvim: symbol lookup error: /usr/lib/ undefined symbol: g_object_compat_control

I also installed a few other updates, including cairo, libglade, pango and python-gtk bindings.
Does anyone have any ideas?

Maybe that symbol was actually supposed to be g_object_compact_control and someone just had a typo =P

gilead 09-30-2006 01:34 PM

It looks like you've installed updates from current (gtk+2-2.8.20-i486-1 is the version from current) instead of from 10.2 (gtk+2-2.6.10-i486-1 is the version from 10.2 at If that's the case, you should uninstall those versions and install the version for the release you're running.

Kairon 09-30-2006 01:46 PM

Okay, I reverted back to gtk+2-2.6.10-i486-1.tgz, and uninstalled 2.8.20. Now there's a different error:


gvim: symbol lookup error: /usr/lib/ undefined symbol: g_intern_static string
I found another thread on this, and the author solved the problem by reverting from pango-1.12.4-i486-1.tgz to pango-1.8.2-i486-1.tgz. I tried that and now I get yet another error:


gvim: error while loading shared libraries: cannot open shared object file: No such file or directory
doh! Slackware 10.2 doesn't seem to come with the cairo packages, but uninstalling cairo-1.0.4-i486-1.tgz doesn't seem to fix the error, nor does reinstalling the cairo package again afterwards.

gilead 09-30-2006 02:08 PM is in the -current version of pango, but not the 10.2 version. Which version of gvim are you running? Could that also be from -current?

Kairon 09-30-2006 02:15 PM

Hey, that was it! I had vim-gvim installed from slackware -current. Unloading vim-gvim and reinstalling xvim from slackware 10.2 did the trick. Thanks for helping me! I take it that it's a risky business to run with packages from slackware-current, so maybe I'll just stick to 10.2 until 11.0 comes out.

Alien Bob 09-30-2006 03:47 PM


Originally Posted by Kairon
it's a risky business to run with packages from slackware-current, so maybe I'll just stick to 10.2 until 11.0 comes out.

No, running slackware-current is not very risky.
Mixing packages from slackware-current with your Slackware 10.2 system is more than risky - it is a sure road to non-working programs, as you already experienced.


All times are GMT -5. The time now is 08:03 AM.