-   Slackware (
-   -   ORBit2 Slackbuild fails when building 32 bit package on current multilib (

damgar 04-10-2010 11:57 AM

ORBit2 Slackbuild fails when building 32 bit package on current multilib
I am trying to build ORBit2 as a dependency for GConf and then google-chrome. This is a multilib system and I want 32 bit chrome. Both my 64 bit and compat32 packages are all current as of today per I have edited the Slackbuild as follows:

VERSION=${VERSION:-2.14.18}  ### edited for VERSION
ARCH=${ARCH:-x86_64}  ### edited for ARCH


if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
  LIBDIRSUFFIX=""  ### edited per Eric's instructions

The build fails each time with:

/usr/lib64/gcc/x86_64-slackware-linux/4.4.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/lib64/gcc/x86_64-slackware-linux/4.4.3/../../../ when searching for -lIDL-2
/usr/lib64/gcc/x86_64-slackware-linux/4.4.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/lib64/ when searching for -lIDL-2
/usr/lib64/gcc/x86_64-slackware-linux/4.4.3/../../../../x86_64-slackware-linux/bin/ld: cannot find -lIDL-2
collect2: ld returned 1 exit status
make[3]: *** [orbit-idl-2] Error 1
make[3]: Leaving directory `/tmp/SBo/ORBit2-2.14.18/src/idl-compiler'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/SBo/ORBit2-2.14.18/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/ORBit2-2.14.18'
make: *** [all] Error 2

I am using the newest version of ORBit2 as the above indicates, but this is just to see if the newer package would build. The X.X.17 version failed with the same output.
I have run:

. /etc/profile.d/
I've had no problems building this package with current in a pure 64 bit environment.

dugan 04-10-2010 12:06 PM


. /etc/profile.d/
That usually doesn't work for me either.

This is how I would build a 32-bit packages for my 64-bit multilib system:
  1. build the package on a 32-bit system
  2. move it to the 64-bit system
  3. run convertpkg-compat32 on the package if it's a library
  4. install the package

It works every time. I run 64-bit Slackware, and I have 32-bit Slackware in a VirtualBox virtual machine.

The -LIDL-2 error is exactly what I got when I tried to build a 32-bit Firefox package from source on my 64-bit system. Building it on my 32-bit system worked.

gnashley 04-10-2010 03:07 PM

Does using this work?:
SLKCFLAGS="-m32 -O2"

ponce 04-10-2010 03:23 PM

just guessing, haven't tried it myself, but I think you need to install a libidl-compat32 package as a dependency for building ORBit2.
from a root prompt

cd /tmp
convertpkg-compat32 -i libidl-0.8.10-i486-1.txz
installpkg libidl-compat32-0.8.10-x86_64-1.txz

if you need a ready made ORBit2 package to convert I have built one for i686.

damgar 04-10-2010 03:26 PM


Originally Posted by gnashley (Post 3931144)
Does using this work?:
SLKCFLAGS="-m32 -O2"

No it didn't..............but it got me experimenting and


  SLKCFLAGS="-O2 -mtune=i686"
DID WORK. I just copied the SLKCFLAGS from the arch that I was trying to build for. That's good to know. I have been using my slack13 system to build packages for the multilib system, although frankly I was doing just as well using Salix repositories. In that regard.

I guess I should start a new thread for the last bit of 32 bit google-chrome on multiltib PITAness which is that I can't access of all things due to ssl failure. I've managed to get the internal flash going.

All times are GMT -5. The time now is 03:19 PM.