LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-05-2018, 04:20 AM   #1
dreadbit
LQ Newbie
 
Registered: Aug 2016
Posts: 21

Rep: Reputation: Disabled
opentegra module ABI version (23) does not match the servers's version 24


Hello, this is the aftermath of yesterdays "slackpkg update ; slackpkg update-all".
What am I doing wrong?

-current on Toshiba AC100
 
Old 10-05-2018, 04:43 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,524

Rep: Reputation: Disabled
I suppose you are using slackwarearm-current (and, like it seems, you haven't updated your installation in some months), so this question should be better suited on the "slackware - arm" subforum...

first, you should update your system using
Code:
slackpkg update
slackpkg install-new
slackpkg upgrade-all
slackpkg clean-system
(being careful not to remove third party packages you have installed with the last step, but eventually rebuild them as-needed)

then, regarding xf86-video-opentegra, maybe it was last rebuilt before the upgrade to xorg-server-1.20.x and the ABI doesn't match, but I don't know if it hasn't rebuilt on purpose, maybe because it's not compatible...
either you rebuild it over the new xorg-server version on you can try with the IgnoreABI option: create a /etc/X11/xorg.conf.d/10-ignoreabi.conf with this content
Code:
Section "ServerFlags"
  Option "IgnoreABI" "1"
EndSection
and try to start X again (note that this is not guaranteed to work).

Last edited by ponce; 10-05-2018 at 04:46 AM.
 
1 members found this post helpful.
Old 10-05-2018, 05:07 AM   #3
dreadbit
LQ Newbie
 
Registered: Aug 2016
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
I suppose you are using slackwarearm-current (and, like it seems, you haven't updated your installation in some months), so this question should be better suited on the "slackware - arm" subforum...
Oh sorry - I did not notice that forum.

IgnoreABI gave me Segmentation Fault.

Quote:
then, regarding xf86-video-opentegra, maybe it was last rebuilt before the upgrade to xorg-server-1.20.x and the ABI doesn't match, but I don't know if it hasn't rebuilt on purpose, maybe because it's not compatible...
As for xf86-video-opentegra, I see a patch xf86-video-opentegra_0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch.xz in the Slackware sources; I do not understand what it is for, but it is about ABI-23 according to it's name, may be it is deprecated now?
 
Old 10-05-2018, 05:13 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,524

Rep: Reputation: Disabled
Quote:
Originally Posted by dreadbit View Post
Oh sorry - I did not notice that forum.

IgnoreABI gave me Segmentation Fault.


As for xf86-video-opentegra, I see a patch xf86-video-opentegra_0001-Adapt-Block-WakeupHandler-signature-for-ABI-23.patch.xz in the Slackware sources; I do not understand what it is for, but it is about ABI-23 according to it's name, may be it is deprecated now?
I'm not sure, I just had a look at fedora's sources and it seems they still used it on their last rebuild over xorg-server-1.20

https://src.fedoraproject.org/cgit/r...opentegra.spec

consider also that the last activity on the driver is more than four years ago

https://cgit.freedesktop.org/xorg/dr...deo-opentegra/
 
Old 10-05-2018, 01:14 PM   #5
dreadbit
LQ Newbie
 
Registered: Aug 2016
Posts: 21

Original Poster
Rep: Reputation: Disabled
Ok, that is what I've done. I'm writing this mostly to myself when I have to reinstall the system ;-)


Remove and blacklist opentegra

Check if xorgproto is installed

Check kernel is compiled with
CONFIG_DRM_TEGRA_STAGING=y

Install libdrm to /usr/local/
From https://github.com/grate-driver/libdrm (last update 2018 Jul )
With ./configure --enable-tegra-experimental-api --prefix=/usr/local/

Install opentegra (last update 2018 Sep!)
From https://github.com/grate-driver/xf86-video-opentegra
With plain ./configure (may be tune DRM_CFLAGS and DRM_LIBS to point to /usr/local/)

Symlink /usr/local/lib/x11/modules/drivers/* to /usr/lib

And... Looks like it works - at least, for the first try and at least somehow.
 
Old 10-05-2018, 02:03 PM   #6
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 739

Rep: Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562Reputation: 562
Quote:
Originally Posted by dreadbit View Post
Ok, that is what I've done. I'm writing this mostly to myself when I have to reinstall the system ;-)


Remove and blacklist opentegra

[..]

Check kernel is compiled with
CONFIG_DRM_TEGRA_STAGING=y

Install libdrm to /usr/local/
From https://github.com/grate-driver/libdrm (last update 2018 Jul )
With ./configure --enable-tegra-experimental-api --prefix=/usr/local/

Install opentegra (last update 2018 Sep!)
From https://github.com/grate-driver/xf86-video-opentegra
With plain ./configure (may be tune DRM_CFLAGS and DRM_LIBS to point to /usr/local/)

Symlink /usr/local/lib/x11/modules/drivers/* to /usr/lib

The armv7 Kernel package already has that configuration option, and libdrm has been configured with that configuration switch a long time.

Thanks for the report for opentegra - it had bitrot and didn't compile during the last update but slipped by unnoticed. The update batch is making its way out now.

If anybody knows how to actually check whether these modules load (perhaps automating loading them into X11), please let me know so I can add it to the port-specific X11 drivers build script.
 
Old 10-05-2018, 02:17 PM   #7
dreadbit
LQ Newbie
 
Registered: Aug 2016
Posts: 21

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by drmozes View Post
The armv7 Kernel package already has that configuration option, and libdrm has been configured with that configuration switch a long time.
Well, really, my kernel is custom, and worked without CONFIG_DRM_TEGRA_STAGING till yesterday's upgrade-all with the old driver.
As for libdrm, I've tried to compile opentegra against libdrm which came with the system - but it could not find some symbols, and they were much about --enable-tegra-experimental-api.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] module ABI major version (14) doesn't match the server's version (15) dr.s Slackware 2 08-10-2014 12:45 PM
Installed GCC version doesn't match the version the kernel was compiled with AlucardZero Linux - Software 2 02-07-2008 11:24 AM
ABI version mismatch with server version rjpilla Ubuntu 1 10-03-2006 11:03 PM
redhat fedora gcc version (compiled for 2.4.20) doesn't match kernel version 2.4.22 start1000 Linux - Software 0 03-16-2004 09:17 PM
Xfree Error (EE) module ABI minor version (7) is newer than the server's version (6) jimdaworm Slackware 0 10-17-2003 06:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration