LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-10-2011, 02:04 AM   #1
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Rep: Reputation: 3
OpenOffice Problem, Slackware 13.1


Hi! I recently installed Slackware64 13.1 on my desktop machine.
I just tried to install OpenOffice (well, I did install it), using

OOo_3.2.1_Linux_x86-64_install-rpm-wJRE_en-US.tar.gz

and the instructions in

http://www.techonia.com/how-to-insta...slackware-13-1

Integrated it into my desktop environment as described.....
When I tried to open a .dot file, it would not, and I received an
error message from Dolphin, as in the attachment. I tried starting
Writer from the Application Launcher, and nothing happened. I
re-booted, no change in any way.

I tried to trace down a permission problem, after I located the
Writer, actually swriter:
Here are the directories and permissions:
/opt/openoffice.org3/program/swriter
4 drwxr-xr-x 4 root root 4096 2011-01-10 00:50 opt
4 drwxr-xr-x 6 786 261 4096 2011-01-10 00:50 openoffice.org3
4 drwxr-xr-x 3 786 261 4096 2011-01-10 00:50 program
4 -r-xr-xr-x 1 786 261 63 2010-05-20 06:11 swriter

Within the directory /opt/openoffice.org3/program/,
I could open Writer, as ./swriter, and open a .doc file, etc.
So there's something I'm not understanding about these permissions.
I am in the world group, aren't I? and I do have execute permission?

Any clarification greatly appreciated.
Ferrel
Attached Thumbnails
Click image for larger version

Name:	openofficewriterproblem.png
Views:	18
Size:	21.8 KB
ID:	5809  
 
Old 01-10-2011, 02:42 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,985

Rep: Reputation: 1234Reputation: 1234Reputation: 1234Reputation: 1234Reputation: 1234Reputation: 1234Reputation: 1234Reputation: 1234Reputation: 1234
use Robby's package or SlackBuild script for OpenOffice.org
That should work
 
Old 01-10-2011, 03:09 AM   #3
ferrel
Member
 
Registered: Feb 2007
Location: Pasadena, Texas
Distribution: Slackware 14.0
Posts: 137

Original Poster
Rep: Reputation: 3
Open Office Problem Slackware 13.1

Okay, I did that...everything's working now. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Openoffice willnot save to nfs share - Slackware 13.1 - Openoffice 3.2.0 nickboarder27 Slackware 2 06-05-2010 03:03 AM
Slackware 12.1 and OpenOffice.org 2.4.0 problem slackuser999 Slackware 3 06-09-2008 04:37 PM
Slackware 12.0 openoffice install problem/fix genix Slackware 21 12-13-2007 12:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration