LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-10-2003, 03:25 PM   #1
exalted
LQ Newbie
 
Registered: Nov 2003
Location: Modesto, CA
Posts: 11

Rep: Reputation: 0
Oops, boot problem


I was trying to get Slack 9.1 to let me access my windows partitions as a user and I must of screwed something up royally because when I rebooted I got the following message. What did I do?

remounting root device with read- write enabled
mount : only root can do that
attempt to mount root device as read-write failed!
this is going to cause serious problems

it then goes on to give me instructions on how to fix it if i'm using umdos (which I'm not)

it also tells me I can fix it using a boot disk with the following command in it

LILO: mount root=/dev/hda1 rw

problem is, I don't have a floppy drive. I could find one if I get desperate enough but I hope I don't have to. I've used Knoppix to get in and play with my fstab and mtab settings but nothing has fixed it. Is this just a config error or something bigger?

I'm posting my fstab and mtab settings below

fstab
-------
/dev/hda6 / ext3 defaults 0 0
/dev/hda7 /home ext3 defaults 1 2
/dev/hdb5 /mnt/audio vfat defaults,noauto,user 0 0
/dev/hdh5 /mnt/crap vfat defaults,noauto,user 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/hdb1 /mnt/winxp ntfs defaults,noauto,user 0 0
/dev/hda1 /mnt/files ntfs defaults,noauto,user 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

mtab
------
/dev/hda6 / ext3 rw 0 0

please help, I'm very sad, I had just configured KDE very nicely.
 
Old 11-10-2003, 04:02 PM   #2
JonW
LQ Newbie
 
Registered: Nov 2003
Location: UK
Distribution: Debian 8.0
Posts: 14

Rep: Reputation: 0
Not sure if it will solve the problem, but AFAIK, root partitions should always a pass number of 1. Try changing the line for hda6 in your fstab to:

/dev/hda6 / ext3 defaults 1 1
 
Old 11-10-2003, 08:12 PM   #3
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
LILO: mount root=/dev/hda1 rw

It looks like it thinks /dev/hda1 is your root partition. Did you do anything to lilo.conf?

Once you boot can you mount the other partitions manually:
mount /home
mount /mnt/audio
mount /mnt/crap
mount /mnt/winxp
mount /mnt/files

<edit> Also this one looks a little irregular:
/dev/hdh5 /mnt/crap vfat defaults,noauto,user 0 0

Last edited by /bin/bash; 11-10-2003 at 08:15 PM.
 
Old 11-11-2003, 12:08 AM   #4
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Custom slackware64-current
Posts: 280

Rep: Reputation: 74
According to the fstab that you posted, /dev/hda1 is an ntfs partition. This should be mounted ro. AFAIK only there is only limited (read danagerous) support for writing to ntfs partitions. If you want a user to be able to mount it, add umask=022 to your mount options.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost /boot contents. Oops! khader69 Linux - Newbie 2 04-26-2005 06:06 AM
OOPS! overwrote MBR, GRUB wont boot :( slacker9876 Linux - Newbie 4 04-16-2004 06:04 PM
hdparm oops...can't boot now :( Axion Linux - Software 5 03-29-2004 07:50 PM
oops - screwed up inittab, can't boot kaise Linux - General 3 03-13-2003 10:15 PM
Kernel oops on boot imbert Linux - Software 1 03-10-2003 02:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration