LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   OnlyShowIn and NotShowIn Directives Do Not Work in XFCE (http://www.linuxquestions.org/questions/showthread.php?t=688157)

Woodsman 12-03-2008 08:50 PM

OnlyShowIn and NotShowIn Directives Do Not Work in XFCE
 
Long ago in a galaxy far away I noticed that the OnlyShowIn and NotShowIn desktop file directives did not work in Xfce. Specifically, the ~/Desktop/Home.desktop and ~/Desktop/trash.desktop icons display on the Xfce desktop. With the OnlyShowIn directive set to KDE or the NotShowIn set to XFCE, these icons should not display. They do.

My solution long ago was simply to disable desktop icons in Xfce. Recently I decided to enable the desktop icons. Same problem.

I tested this in Xfce 4.4.3 in Current. I tested in Zenwalk 5.2 in a virtual machine. Same results with both desktops.

The OnlyShowIn and NotShowIn desktop directives function correctly in KDE.

Any ideas how to fix this other than some kind of shell script hack? Why don't these directives work correctly in Xfce? Have they ever worked correctly?

Thanks again.

titopoquito 12-05-2008 06:55 AM

I too stumbled upon this misbehaviour lately and found no way to change it. I hope for xfce 4.6 though which is announced for late december - in the changelog it reads like the bug is known and solved. Can't test it though, didn't manage to compile it by myself.

http://www.xfce.org/documentation/changelogs/4.5.91

AFAIR Robby Workman wrote that he followed current xfce development and build it, so he is probably the one to ask if it works with the xfce development snapshots.

keefaz 12-05-2008 08:38 AM

Do you add a ";" at the end of the config line ?, like
~/Desktop/Home.desktop
Code:

[Desktop Entry]
...
NotShowIn=XFCE;
...

[edit]
Ok forget it, looks like a bug indeed
http://bugzilla.xfce.org/show_bug.cgi?id=4022

titopoquito 12-05-2008 09:36 AM

Quote:

Originally Posted by keefaz (Post 3365398)
Do you add a ";" at the end of the config line ?,

Yep, didn't change anything. Like you wrote, looks like a real bug. The changes won't get backported to xfce 4.4.x, so updating to the new 4.6 branch once it is stable should be THE remedy.

rworkman 12-05-2008 12:50 PM

If you want to confirm that it's fixed, http://xfce46.rlworkman.net/ for -current :-)
If you want to go back to 4.4.x after testing, be sure to back up your $HOME/.config and $HOME/.local directories so that you can restore them afterward.

Woodsman 12-05-2008 02:47 PM

Thanks all for the replies. :) I too tried with and without the semicolon to no avail. Nice to hear at least that the problem is officially listed as a bug.

Robby, I have two Current environments, one physical and one virtual. I can test your 4.6 package, hopefully soon --- I'm still attending my punch list for various issues in Current. I will at least confirm whether this particular bug is resolved.

titopoquito 12-05-2008 07:35 PM

Many thanks Robby for your build scripts and packages. I just build the xfce release candidate on Slackware 12.1 (with VirtualBox) and indeed the bug is solved. :)

One caveat: "OnlyShowIn" seems to work even if the trailing ";" is missing. "NotShowIn" on the other hand seems to require the ";" as it is specified in the freedesktop.org standards. That's a little bit confusing, even Xfce4 itself creates "malformed" desktop files without the semicolons.

Woodsman 12-06-2008 01:54 AM

Confirmed: the bug is fixed in this release.

Seems there are incompatibilities, however, with the configuration files. I uninstalled 4.4.3 and then installed 4.6 in my testing partitions. When I started the desktop in 4.6 there was no conky and the theme icons were hosed. Then again, I did not browse any README files for updating notes. I only wanted to see whether the bug was fixed. I restored my config files from backups.


All times are GMT -5. The time now is 02:29 AM.