-   Slackware (
-   -   Only one virtual terminal? (

kule 07-13-2004 06:47 AM

Only one virtual terminal?
I have Slack 10 and I configured it boot into runlevel 4 (X), but now I only have one virtual terminal on CTRL+ALT+F6. Ho can I make other terminals to work.

fluppi 07-13-2004 06:59 AM

You can define them as root in the /etc/inittab, look for tty1 to tty6.

djbanaan 07-13-2004 07:03 AM

To be a bit more precise:

Change the following lines in /etc/inittab


c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux



c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

kule 07-13-2004 10:55 AM

Thx, everything every terminal works now.

kule 07-13-2004 04:57 PM

The problem is solved, but what do those 12345 represent; why is the terminal working when there is 12345 and not when 1235.

netmask 07-13-2004 05:18 PM

They are the init levels.

If you look at your old config, tty6 has the number 4 in it and you start in level 4. That's why he added the other 4's.

CartersAdvocate 07-14-2004 12:28 AM


c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c1 = console 1
12345 = the runlevels to start this process in (they didn't have 4 in them which is why they didn't start)
respawn = restart this process whenever it is terminated
/sbin/agetty 38400 tty1 linux = the full path and any options of the process to run

kule 07-14-2004 06:06 PM

Thanks guys, for the answer. I like to learn about linux, but not if I don't undestand what I'm doing.

All times are GMT -5. The time now is 12:38 PM.