LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-30-2005, 10:45 AM   #1
Influx
LQ Newbie
 
Registered: Sep 2005
Location: Canada
Distribution: Slackware 10.2
Posts: 27

Rep: Reputation: 15
Question Only a couple screensavers work at random...


I couldn't find any other threads on this topic, and I also tried googling with no luck.

Only some of my screensavers work (and now most of those don't work either)

I think the problem started when I installed dropline gnome (then uninstalled, then reinstalled again). I don't know what else to write about it, so ask questions and I'll answer

Thanks
 
Old 11-30-2005, 12:01 PM   #2
Garlictoast
Member
 
Registered: Aug 2003
Location: USA
Distribution: several Mandrakes
Posts: 34

Rep: Reputation: 15
I don't know about Slackware. I play a little with Mandrake. You should have a package manager that lets you look up screensaver packages. There's probably more than one set of screensavers available. Your manager may separate the files into what's installed and what's not installed, so you'd have to search both categories to see what you have. A generic Unix set of screensavers is called Xscreensavers, and there may be some for KDE or your distribution---I don't know exactly where they come from. But if you look up "screen" to get screensavers (and other packages with that text) listed, you can uninstall and re-install screensavers and that ought to make them available in your menus.

In my installation, Xscreensaver doesn't start automatically with the window manager. But you can find the path/programname to start Xscreensaver and add it to your autostart folder if you use KDE. It's a hidden folder under your /home/username folder. I think Konqueror may have a facility to add a program to the autostart folder. I'll try to post again with details.
 
Old 11-30-2005, 12:13 PM   #3
Influx
LQ Newbie
 
Registered: Sep 2005
Location: Canada
Distribution: Slackware 10.2
Posts: 27

Original Poster
Rep: Reputation: 15
Under my package manager, i type in screen and the only one that comes up is xscreensaver. I tried reinstalling that with the same slackware package and still no luck.
 
Old 11-30-2005, 01:08 PM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,390

Rep: Reputation: Disabled
Question: what video drivers do you use? It could be that the screen savers that aren't working are OpenGL savers, and maybe you aren't using the right vid driver.

If I remember rightly, dropline changes some settings. Maybe you should have a look at what driver is listed in the device section of xorg.conf.

Also you can use command xscreensaver-demo to bring up screensaver options and preview some to see which are working or not.
 
Old 11-30-2005, 01:10 PM   #5
Garlictoast
Member
 
Registered: Aug 2003
Location: USA
Distribution: several Mandrakes
Posts: 34

Rep: Reputation: 15
Xscreensaver has a bunch of enjoyable ones. But it doesn't start automatically. You have to add it to the autostart folder of your window manager. I'm running Windows now so I can't check on it. But you should have access to the KDE window manager and Konqueror. In your /usr folders (/usr/bin or /usr/sbin, I would guess), you should find xscreensaver. Highlight it with Konqueror and then check the menues for something about autostarting. Otherwise, you should be able to start it from your user menu. If you run it with the right commandline argument, you'll get the configuration menu for xscreensaver. Otherwise, there's a button on the startup screen that you have to click promptly to configure it. Here's to the Bouncing Cows screensaver.
 
Old 12-01-2005, 01:35 AM   #6
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Do you get any error messages about permissions? Try adding yourself to the video group (in /etc/group) or change the permissions of /dev/nvidia* (assuming you have an nvidia graphics card). If the latter you have to do this on every boot (through udev if you're using it, for example).
 
Old 12-01-2005, 08:55 AM   #7
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Which screensavers are working properly? Are there any error messages? It may be useful to add yourself to the "video" group, as suggested above.
 
Old 12-01-2005, 11:43 AM   #8
Poetics
Senior Member
 
Registered: Jun 2003
Location: California
Distribution: Slackware
Posts: 1,181

Rep: Reputation: 49
Random off-topic question -- Influx, are you the same great Influx from NHP?
 
Old 12-01-2005, 08:43 PM   #9
Influx
LQ Newbie
 
Registered: Sep 2005
Location: Canada
Distribution: Slackware 10.2
Posts: 27

Original Poster
Rep: Reputation: 15
xscreensaver-demo got it working, but what I don't understand is why nothing works when i use the control center's screensaver dialog, nothing works. I don't like the feel of gnomes xscreensaver-demo. I added the user to video as well (no change). I have the nvidia graphics driver installed properly. There is no error messages, just blank screens in the preview, and nothing happens if i hit the preview button to test it full screen.
 
Old 12-02-2005, 09:45 AM   #10
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
You prefer KDE's control center interface to xscreensaver? Personally I can't stand it - for one thing, you can't select which screensavers you want active and which are disabled. Gnome uses the one provided by the author of xscreensaver, and I find has much more options. Besides, how often do you change the screensaver settings? Best use the one that works.
 
Old 12-02-2005, 09:56 AM   #11
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,390

Rep: Reputation: Disabled
If you get blank screens on preview there must be a problem with your vid drivers I would have think
Is the glx module loading properly in xorg.conf? Should be simlar to:


Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "glx"
Load "xtrap"
Load "type1"
Load "freetype"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Screensavers No Longer Work After KDE 3.3 Upgrade robpom Linux - Software 2 08-25-2004 12:10 PM
Why do my screensavers not work in KDE 3.2 DevilsBrigade Mandriva 4 01-28-2004 10:46 AM
KDE 3.1 screensavers don't work - RedHat 9 achaudhary Linux - Software 6 01-10-2004 09:24 PM
Random doesn't seem to work anywhere? Pcghost General 10 06-10-2003 11:33 PM
power save doesn't work after couple of days? ubien Linux - General 5 12-08-2002 09:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration