-   Slackware (
-   -   On KDE log-in screen mouse pointer and keyboard input not acknowledged. (

Emor 10-10-2010 11:34 AM

On KDE log-in screen mouse pointer and keyboard input not acknowledged.
Hey, 'name's Emor. I just recently installed Slackware onto a virtual machine(I'm planning on buying a new disc drive and 1 TB HDD with-in the next couple of months and plan on Slackware being my primary OS[right now Mac OS X 10.6 is]), and everything went great.
I then went onto edit the /etc/inittab file in emacs and changed the run-level to 4. I don't know why it's decided that I'd want to boot into KDE when XFCE is installed and in the configuration I selected XFCE but it's not really relevant(I have a WM guide thing open in another tab and will probably be able to change it).
The problem is, as the vague title may suggest, is that it basically freezes when I'm at the log-in screen. The input field for the username is highlighted and blinking, and the cursor it self is visible in the centre of the screen, but it simply doesn't pick up on any input from my keyboard or mouse.
I tried booting up the install CD and logging in as root, mounting sda4(which is the root partition) and editing said file but sudo isn't installed(to my knowledge) on the install disc and when I do the command,

emacs /mnt/hdd/etc/inittab
I'm just told permission is denied.
So I don't really know what to do at this point. It'd be okay if I had the command line but I don't.
I'm a bit of a newbie, I read the first 100 pages of the slackware tutorial book but after that thought it'd be a bit redundant, I've googled about my problem and there's been no results, and skim read through all of the book in hope to see if there's a solution, so please don't flame me.
Thank you for any help :).
EDIT: I don't think it's relevant really since in the command line it recognised input from my trackpad when highlighting text, etc. but in the installation I selected PS/2 input 'cause I wasn't sure whether a trackpad would be PS/2 or USB. In the install it said most laptops and desktops fell under this(I thought serial ports were obsolete but it's the latest install and I'm an idiot with computers so meh).

mf93 10-10-2010 02:32 PM

you need to install the latest sudo--use whatever package manager is supplied with slackware to install/upgrade it...also you should be able to get back to a terminal by pressing ctrl+alt+f1 at the login window---otherwise boot into recovery mode.

Emor 10-10-2010 06:38 PM

Thank you for the reply :).
The problem is though that neither of these solutions(to my, limited, knowledge) could work.
At the log-in screen I can't go back to the console/shell because it doesn't acknowledge any input from my keyboard, which includes hotkeys.
And for the package installer, afaik you can't install packages onto install DVDs and even if you could I doubt I'd be able to configure the internet, prior to installing the actual OS(which obviously I don't want to do), on the install DVD.
EMZ >_<

T3slider 10-10-2010 08:26 PM

I am not sure why the keyboard isn't working in KDM (I don't use it, and know very little about it) -- but if you boot with the install CD and mount your partition, you should be able to edit your inittab file -- sudo is completely irrelevant when you're logged in as root. I don't believe emacs is available on the install CD, so unless you chroot into your installation you'd be better off using vi or nano to modify inittab from the install CD, since I believe both are available. Otherwise you would have to issue

# chroot /mnt/hdd
# emacs /etc/inittab
# exit

mf93 10-11-2010 12:35 AM

the exact same problem was mentioned here-
and the problem was resolved with the latest installation of sudo--- boot into the rescue shell and disable kdm, then go into the actual OS and install sudo and re-enable kdm at boot

T3slider 10-11-2010 12:47 AM

Unless the OP is very late in posting or is using a very out-of-date mirror to upgrade packages, I doubt that is the problem...the problematic sudo package shouldn't even exist on any remotely current mirror. The output of

# ls -ld /var
would give the definitive answer (or `ls -ld /mnt/hdd/var`, assuming you boot from the install CD and mount your root partition at /mnt/hdd). Regardless, when modifying inittab as root from the install CD, even if the permissions were incorrect on /var (which was the problem introduced with the flawed sudo package), it would still work -- sudo itself isn't doing anything and /var (or more specifically /mnt/hdd/var) doesn't need to be touched to edit the inittab file.

aocab 10-11-2010 02:51 PM

Wasn't there a similar problem a while back where the keyboard/mouse
stopped working (for some people) at the kdm login screen after
some updates in current (before 13.1)?

I know on my other machine (with an old legacy nvidia card)
I have to use an xorg.conf and after updating my keyboard/mouse
stopped working at the kdm login screen.

The fix for me was to comment out all the InputDevice
sections in xorg.conf and let hald autodetect the keyboard/mouse.

Just a thought...

Emor 10-11-2010 06:57 PM

Honestly, I don't know what exactly I did really.
T3Slider was correct and I managed to get command line access.
And from thereon I just edited so many files I can't be sure what exactly did it.
Though I think it might have been me typing this:
/usr/sbin/hald --daemon=yes
I did a lot of Googling too.
Thanks guys :).
I don't know if I should label the thread as solved because I doubt anyone in the future will find this of any use, but for the short-term I'll just mark it that anyway :P.

mf93 10-11-2010 11:25 PM

disabling hald will definitely stop the functioning of mouse and keyboard: that happened to me when i first installed freeBSD. that is definitely the solution to your problem.

All times are GMT -5. The time now is 06:45 PM.