-   Slackware (
-   -   Old installation of GRUB prevents me from using LILO and booting into Slackware! (

EThitop 12-08-2004 07:19 AM

Old installation of GRUB prevents me from using LILO and booting into Slackware!
Ok, I have a friend who installed Fedora Core 3.. Fedora Core's boot loader is GRUB. I believe Fedora Core installed the boot loader in the MBR (Master Boot Record). He has since then reformatted the hdd and now he has 2 partitions. HDA1 is the swap drive, and HDA2 is where he has Slackware installed, and HDA2 has the boot flag. Everything installed fine, Slackware's boot loader is LILO. Now when he boots his computer GRUB still comes up, and he can't do anything from there. How can I clear the MBR?

cythrawll 12-08-2004 07:39 AM

I hate to say this: but the easiest way is to get a ms boot disk and run this command: fdisk /mbr

ok guys don't hurt me (hides)

other wise you can use a dd in linux (boot disk or knoppix etc) command like so:

dd if=/dev/zero of=/dev/hda bs=446 count=1

you'll prolly have to recreate and reinstall your partitions after that though


p.s., it might be a good idea to backup the mbr first on a floppy disk just in case:

dd if=/dev/hda of=/floppy/MBR bs=512 count=1

rotvogel 12-08-2004 07:40 AM

Boot from some bootdisk (slackware install cd, add root=/dev/hda2 ro as a kernel boot option) and edit /etc/lilo.conf to install lilo in the MBR. There will be a line in it boot=/dev/hd<something> probably /dev/hda2 . Change that to boot=/dev/hda , save the file and rerun lilo. That should do the trick :)

EThitop 12-08-2004 08:06 AM

Thanks for such a quick reply!!! I will look into this and try it tonight... I'll let you all know how it goes! :D

mark alan 12-12-2004 10:28 AM

Hey guys,

Thanks for the help getting my MBR strait. Now that that's fixed, I have another problem:

I can get to the darkstar prompt (I forgot to name my domain) and when I type in startx this is what I get:

IO error


(EE) vf860pen Serical: cannot open input device /dev/mouse
(EE) mouse1: cannot open input device
(EE) reinit failed for input device "mouse 1)
        No core pointer

Fatal Server Error:
Failed to initialize core devices

I went into xorgconfig to set the settings for the monitor, vid card & mouse/keyboard. I got the monitor set as well as the vid card and keyboard, but my mouse seems to be the problem.

I have a logitech wireless mouse/keyboard. The only numbers I can get from the mouse are:

"m/n: M-RP67" on the back of the mouse. The mouse/keyboard is a usb connect and I did enable "hotshot" or something like that in the initial setup for Slackware.

In xorgconfig I tried automatic (opt 1) as well as PS/2 and Microsoft. I think Microsoft prompted me with a question of is this a Logitech, if so it's recommened to enable another feature. I did that, but each time I come out of xorgconfig, I keep getting the same error.

I also edited the string: /dev/mouse to /dev/input/mice to no avail.

Any hints or clues to this other than junking the keyboard/mouse for a "name brand"?


Mark :scratch:

mdarby 12-12-2004 10:31 AM

try editing xorg.conf to use /dev/psaux as the mouse device.

mark alan 12-12-2004 12:07 PM

Quick reply! Thanks!

I will give that a try when I get home.

All times are GMT -5. The time now is 11:28 PM.