-   Slackware (
-   -   Odd USB Mouse Problem (

ZombieChan 12-02-2002 12:09 PM

Odd USB Mouse Problem
I was hoping someone can give me a hand.

I'm using a Logitech USB Mouse. I have UHCI USB support compiled into my kernel. (I'm using a VIA board.)

If I run a dmesg, I can see that my mouse is detected as input0.

but... if I cat /dev/input/mice. I fail to find the device.

So, I rm /dev/input/mice and redid it as per the devices.txt in /usr/src/linux/Documents. mknod /dev/input/mice c 13 63.

To no avail, though, I can't get my mouse to work.

Can anyone offer any ideas or suggestions on how to fix this? I've been able to use a usb mouse before, but I'm new to slackware. Last time, I set it up on Debian just fine.

You help is greatly appreciated.

LNXman 12-02-2002 01:07 PM

Do you have the hid module loaded? Read your /usr/src/linux/Documentation/input/input.txt file (especially section 3.2.2 regarding mice) for more info.


ZombieChan 12-03-2002 12:48 AM

Hid was compiled into the kernel. As was device input. I ended up going back through and redoing those parts of the kernel to just act as modules. After I modprobed hid, input, and mousedevice everything worked just fine. A friend of mine helped with making it run those commands at boot. So, Problem solved!

Thanks for your help!

All times are GMT -5. The time now is 05:41 AM.