LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-15-2013, 11:35 AM   #1
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,962

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Odd punctuation behaviour S-14.0


My box running slackware 14 has this odd issue in X (Not console).
Typing these keys gives the following output
Apostrophe (nothing): Apostrophe Apostrophe Apostrophe space '
Shift_2 (nothing): Shift_2 Shift_2: Shift_2 space "

When I type a word like 'doesn't' it can end up 'doesńt' which is lame.

All this is a major pain in the butt, and I would like to get back to standard behaviour as I have to use normal PCs as well. Running on a GB or IE setup and keyboard here, en_IE $LANG & $LC_ALL settings btw.

In X, I have XkbLayout as 'gb' and XkbVariant as 'intl'

Any suggestions for a fix Welcome
 
Old 11-16-2013, 08:08 AM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 2,873

Rep: Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700Reputation: 700
Whatcha got in /etc/profile.d/lang.sh?

Maybe try shutting down X and in the console edit /etc/profile.d/lang.sh changing the LANG and LC_COLLATE to
Code:
export LANG=en_US.UTF-8
and
Code:
export LC_COLLATE=C
log out, log back in (so the stuff in /etc/profile.d runs) and see what you get; for example,
Code:
locale 
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Then change the LANG to en_IE.utf8, log out, log back in and run locale again (everything should change from en_US.UTF-8 to en_IE.UTF-8).

The UTF8 settings may make some things goofy in console but should not affect X (other than you'll get the European accent characters). If you've got entries set other than in /etc/profile.d/lang.sh, you might want to remove them as what's in lang.sh sets system-wide and you probably want to work with it rather than any "local" settings (in a .bashrc or whatever).

Try the UTF8 settings, they ought to work for you. About the only thing I can recall that argues about UTF8 is xpdf that yammers at you about display fonts and other stuff but still displays the PDF file (kinda weird).

[FORGOT]
About the keyboard settings... are you sure you've got the correct layout for it? If it works properly in console, it should work properly with X running too; have you fiddled with keyboard settings in KDE or Xfce or whatever window manager you're using?
[/FORGOT]

Hope this helps some.

Last edited by tronayne; 11-16-2013 at 08:34 AM.
 
2 members found this post helpful.
Old 11-17-2013, 09:05 AM   #3
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,962

Original Poster
Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Thanks for the reply!
That all worked as you'd expect, and returned normal behaviour. My keyboarsd most definitely is not en_US, so that makes a mess if I leave it. Key differences in my lang.sh were

LANG en_IE --> en_IE.UTF8
LC+ALL
LOCALE
both now unset. All the characters causing offense ('~" & friends) are now behaving properly. It all functions without the step through en_US.UTF8. All my LFS experience was before the time when they got Unicode sorted.You kinda stop learning after that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gmp: odd behaviour. stf92 Slackware 4 11-13-2013 01:47 PM
Odd behaviour of tty richard64 Fedora 1 10-20-2006 06:20 AM
spamassassin odd behaviour fedora_user Linux - Software 8 04-12-2006 05:22 PM
odd behaviour of wvdial NNP Linux - General 4 08-05-2005 02:58 PM
Odd behaviour on desktop... user00265 Slackware 19 02-26-2005 06:06 PM


All times are GMT -5. The time now is 03:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration