-   Slackware (
-   -   Odd login-crash for Normal User (

electronique 02-13-2005 04:44 PM

Odd login-crash for Normal User
I recently experienced something rather odd when logged into my Slackware Current system, I had just used slapt-get to upgrade slapt-get (I don't think this is causing the issue because only slapt-get was upgraded) but when I tried to run firefox it gave me some weird error along the lines of: item /applications/firefox-1.0/firefox is corrupt. Also when I clicked on the K menu in KDE it gave a weird error about XML. I can't post the exact errors because I rebooted to try and see if that would fix the issue, but nothing happened... I can't login: this is the error I get


Welcome to Linux 2.6.9 (tty1)

SlackTop login: user
Password: *********
Last login: Sun Feb 13 22:40:56 +0000 2005 on :0.
No mail.
-bash: /etc/profile: Permission denied

any ideas what might be causing this?

keefaz 02-13-2005 04:51 PM

From your "screenshot" I can see you are logged but for some reason bash don't want to
source /etc/profile, weird...

could you post
ls -l /etc/profile

electronique 02-13-2005 05:01 PM

logging in as root works fine and startx (kde) work great as root. (that's what I am logged in as right now) ls -l /etc/profile as root lists:


root@SlackTop:~# ls -l /etc/profile
-rw-r--r--  1 root root 2410 2004-05-20 18:52 /etc/profile

did you want as a normal user?

keefaz 02-13-2005 05:05 PM

No it's good.
So when you say "I can't loggin" you mean "I can't login into X server as regular user", right ?

Does the problem appears with other window managers, eg before startx, do :
xwmconfig, choose a wm, then startx

electronique 02-13-2005 05:07 PM

no I can't login as that user at all, I normally stat ar runlevel:4 with graphical login, if I try and login there nothing happens, the login screen just reappears. when I use runlevel 3 to login I get the error above.

keefaz 02-13-2005 05:10 PM

I would login as root, then check if all is correct in /etc/passwd for the user, then I would
check the permissions for his home directory in /home (with ls -l) and eventually :
chmod -R user:users /home/user
(of course where user is the username, users is the user default group)

electronique 02-13-2005 05:51 PM

still no ideas, deleted user account, re-added... nothing, everythig seems right in /etc/profile

keefaz 02-13-2005 05:57 PM

And his home directory in /home ? Do you use useradd or adduser to add an user ?

electronique 02-13-2005 06:00 PM

user add. deleted /home/user directory. also added new account and smae thing happens, only functioning account is root I'm guessing a problem with bash

edit: tried using zsh shell as well, nothing happened.

electronique 02-14-2005 05:31 PM

still no other ideas? I might migrate my laptop to Arch Linux to try it out, or use the Slack 10.1 cd's to redo my install after backing up my data and all that fun stuff. I don't really want to have to do that... but oh well.

keefaz 02-14-2005 05:42 PM

Just an idea, what happen when you create an user, then telinit 3, then login as this user, then type this command : startx

electronique 02-15-2005 12:01 AM


Welcome to linux 2.6.9 (tty1)

SlackTop login: tux
Last login: Sun Feb 13 23:59:51 +0000 2005 on :0.
No mail.
 -bash: /etc/profile: Permission denied
 -bash:-3.00$ startx
 -bash: startx: command not found

same thing

or if I add a new user:


Welcome to linux 2.6.9 (tty1)

SlackTop login: root
Linux 2.6.9.
Last login: Sun Feb 14 23:49:59 -0600 2005 on :0.
You have new mail.
root@SlackTop:~# useradd slacker
root@SlackTop:~# passwd slacker
Changing password for slacker
Enter the new password (minimum of 5, maximum of 127 characters)
Please use a combination of upper and lower case letters and numbers.
New password:
Re-enter new password:
Password changed.
root@SlackTop:~# exit

Welcome to linux 2.6.9 (tty1)

SlackTop login: slacker
No directory, logging in with HOME=/
No mail.
 -sh: /etc/profile: Permission denied

I'm a little baffled, never seen this before. any help would be appreciated.

keefaz 02-15-2005 04:38 AM

Try create a user with useradd, not adduser (it will create the home directory)

Then when you have :

source /etc/profile


electronique 02-15-2005 03:11 PM

if you note the txt above, I did use 'useradd'

All times are GMT -5. The time now is 03:39 PM.