-   Slackware (
-   -   nvidia gt440 on current (

justwantin 06-26-2012 10:57 PM

nvidia gt440 on current
Last week I had to upgrade mobo and cpu. The onboard intel graphics were not as good as I was used to with the nvidia card on the previous setup so I purchsed and installed a geforce gt440 card which would not be rcognised in either slack or salix 13.37. I tried current as of 15/06 and no joy there.

I all three instances the audio on the card was recognisec but not the video

01:00.0 VGA Compatable controller: nVidia Corporation Device 0de0 (rev a1)
01:00.1 Audio Device: nVidia Corporation GF108 High Definition Audio Controller (rev a1)

In the interim I have installed porteus-1.2-rc2 (kernel 3.3.4) to a hdd and have also been able to install the prop. nvidia driver.

01:00.0 VGA compatible controller: nVidia Corporation GF108 [GeForce GT 440] (rev a1)
01:00.1 Audio device: nVidia Corporation GF108 High Definition Audio Controller (rev a1)

Out of curiosity I tried mageia 2 live cd (kernel 3.3.6) and both video and audio chips were properly id'd.

Today I installed current 25/06 and I still had the same results with nvidia audio recognised but not the video. However with this current install the nouveau module is loaded and I have video at a reasonable quality.

I'm not sure where the problem lies. I tried using kcconf to compare the porteus and slack config files but I'm not really sure what I'm looking at and for. I'd be pleased to hear any suggestions as to what direction I should take to sort this out.

TobiSGD 06-26-2012 11:16 PM

If the nouveau driver is loaded and the card is working it is recognized by the kernel. It seems to me that your pciid database (used by lspci) is not up to date. Run

as root and try if lspci recognizes the card after that.

justwantin 06-27-2012 12:02 AM

TobiSGD, your a darn nice guy and I don't care what anybody says about you!

That did the trick. Is this something everyone should kbow about? I've been using linux 11 years, slack or some form of slack for 10 years and I've never had to do that before. Maybe I was in the men's room when they talked about it. Is update-pciids something that's supposed to happen without my knowing about it? at install? at first boot? or does Slackware ship with the pciids tucked away somewhere safe and if so is this batch out of date and if so has someone called headquarters to tell someone about it?

After X late nights X-2 early mornings, a couple kernel compiles, numerous lumps on my head from beating it against wall and one update-pciids I have now landed where I swore I'd never go 5 years ago, current country, I can't go back now, not unless I get my old mobo and cpu back from my daughters boyfriend. Fat chance that is. aaaaaaaaaaaargh!

TobiSGD 06-27-2012 12:09 AM

I almost never had to do this manually (last and only time was when I installed the Radeon HD6870 in my main machine with Slackware 13.37), I don't know how often this is updated in Slackware, but I would assume that it is done automatically when the pciutils package is re-built, so I am rather surprised that an older card like the GT440 is not recognized out of the box in -current.
But anyways, good that it works now.

All times are GMT -5. The time now is 05:18 AM.