-   Slackware (
-   -   Nvidia driver slackware14.1 (

captain_sensible 02-11-2014 11:06 AM

Nvidia driver slackware14.1
I just installed Slackware14.1 , installed wicd , sbopkg and I few other things, tried seamonkey got onto internet Ok, then tried firefox and system crashed. Then got not unmounted cleanly, I stuck with ext2 so ran e2fsck -v -y /dev/sda2

Not a good start. There was text on reboot about noveau- i have Nvidia geForce. Decided I would have a go at installing Nvidia driver.

I botched it, but although I had installed
xf86-video-nouveau-blacklist-noarch-1.txz to my surprise I got my xwindow back up. In my menu I have an entry for nvidia settings, but says -looks like your not using Nvidia.From what I can understand Noveau driver should not load, if i blacklisted it, and Nvidia took a dive ,so why is my xwindow working?

Looking in /etc/X11 I have xorg.conf.backup(inside says created by nvidia) and also xorg.conf-vesa

So is my xwindow using xorg.conf-vesa and is a vesa module being used?

genss 02-11-2014 11:12 AM

check /var/log/Xorg.0.log

there are also errors logged there if they happened

bdw (EE) means error

jtsn 02-11-2014 11:31 AM


nouveau.modeset=0 vga=normal
to your kernel command line. Check the output of

lsmod | grep nouveau
lsmod | grep nvidia

and run

to create a working xorg.conf.

captain_sensible 02-11-2014 02:50 PM

in var/log

56.107] (EE) Failed to load module "fbdev" (module does not exist, 0)
56.107] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 56.107] (--) using VT number 7

[ 56.113] (EE) [drm] KMS not enabled
[ 56.113] (EE) [drm] KMS not enabled
[ 56.113] (WW) Falling back to old probe method for modesetting
[ 56.113] (EE) open /dev/dri/card0: No such file or directory

(II) Loading sub module "vbe"
[ 56.113] (II) LoadModule: "vbe"
[ 56.114] (II) Loading /usr/lib/xorg/modules/
[ 56.164] (II) Module vbe: vendor="X.Org Foundation"
[ 56.164] compiled for 1.14.3, module version = 1.1.0
[ 56.164] ABI class: X.Org Video Driver, version 14.1
[ 56.164] (II) Loading sub module "int10"
[ 56.164] (II) LoadModule: "int10"
[ 56.164] (II) Loading /usr/lib/xorg/modules/
[ 56.175] (II) Module int10: vendor="X.Org Foundation"
[ 56.175] compiled for 1.14.3, module version = 1.0.0
[ 56.175] ABI class: X.Org Video Driver, version 14.1
[ 56.175] (II) VESA(0): initializing int10

after the above section end no errors

no output for
lsmod | grep nouveau
lsmod | grep nvidia

I tried nvidia-xconfig - no joy, then in desperation I used :

nvidia-xconfig --restore-original-backup

I think i did a mash up on the two methods of nvidia install slackbuilds and running nvidia proprietary driver.Out of interest if I wanted nouveau back would i uninstall the blacklist xf86-video-nouveau-blacklist-noarch-1.txz and need to load using modprobe?

To be honest everything is working fine with present system -but it would be nice to know what happened and what to do to get back to a working system. All I know it runs along the lines of getting a /etc/X11/xorg.conf.backup to xorg.conf .If you messed up on installing
nvidia what approach would you use to get system back to as it was ? back step and remove packages #xorgconfig is now depreciated so can not use that .

I got back with trial and eoor to be honest

In /etc/modprobe.d there is :

in the above file it has:
#generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

jtsn 02-11-2014 06:05 PM

1. Run nvidia-uninstaller.
2. Uninstall nvidia-* SBo packages.
3. Reinstall xorg packages by running

slackpkg reinstall xorg-server mesa
If you want nouveau back, install xorg-video-nouveau again. Otherwise run NVIDIA-Linux-*.run again and let it create a xorg.conf for you.

captain_sensible 02-12-2014 05:17 AM

Thanks very much, with the above information it boosted my confidence and gave it another go.

Looks like I had the wrong Nvidia for my geForce. I ran the correct one using this:

sh ./ --kernel-name=3.10.17-smp

It ran got rid of the other nvidia install 331.20 and I now have
Nvidia installed. Its probably worse than vesa but maybe there are some other benefits to it somewhere -
just found one benefit (i'm assuming);previously no matter how hard i tried I could not get sound capture e.g nobody could hear me with skype, now I have sound capture!

All times are GMT -5. The time now is 06:02 PM.