LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-16-2015, 10:51 PM   #1
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Rep: Reputation: 0
Nvidia Driver // Grub2 // No Virtual Console


Thank you for taking the time to read this post. I recently migrated back to Slackware 14.1-Current. The new installation automatically loaded the Nouveau drivers, however, I prefer the Nvidia drivers.

Upon installing the proprietary Nvidia drivers, I immediately ran into a problem. I've followed the documentation here.

After installing the xf86-video-nouveau-blacklist package from the DVD and restarting, I'm greeted with Grub2 in text mode (nothing unusual there). I selected the default menu entry and it appears as if the kernel is going to load, however the virtual console is never loaded. While to computer continues to boot and eventually finishes with a login prompt, all I ever see is the Grub2 message "Loading Linux 3.18.11 ..." I know the startup finished because I can blindly login as root and issue a reboot.

I then boot from the DVD and chroot into the installation. In the dmesg log I noticed

Code:
[    0.000000] Console: colour dummy device 80x25
[    0.000000] console [tty0] enabled
as well as

Code:
[   44.163786] nvidia: module license 'NVIDIA' taints kernel.
[   44.163800] Disabling lock debugging due to kernel taint
[   44.173757] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   44.174250] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0
[   44.174263] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  352.30  Tue Jul 21 18:53:45 PDT 2015
I've checked the BIOS and ensured that the display is set to "discrete" but still a no-go. The only time I achieve a virtual console is when the display in the BIOS is set to "integrated" graphics.

Just for kicks I added "set gfxpayload=1024x768" at the beginning of the Grub config and "nomodeset" to the kernel parameters --no such luck.

Any troubleshooting efforts or guidance would be greatly appreciated. Thank you.

Last edited by arpanetguru; 08-16-2015 at 10:52 PM.
 
Old 08-16-2015, 11:18 PM   #2
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,397
Blog Entries: 15

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
It's kinda hard to pinpoint. But some question to start?

First off, did you use the SlackBuild method to installing the Nvidia driver, or did you use the actual Nvidia installer?

Secondly, did you change anything in /etc/inittab?

Thirdly, did you have any issues with the Nouveau?

Fourth, did you try switching consoles with Alt+F(2~6) to see if a prompt was available?

Lastly, can you post the output of the lspci utility?
 
Old 08-16-2015, 11:59 PM   #3
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Original Poster
Rep: Reputation: 0
Thanks for the quick reply.

Quote:
First off, did you use the SlackBuild method to installing the Nvidia driver, or did you use the actual Nvidia installer?
No. In this particular case I did not use the SlackBuild. I have always had a good experience with the drivers from Nvidia.

Quote:
Secondly, did you change anything in /etc/inittab?
No. I haven't changed anything in the inittab.

Quote:
Thirdly, did you have any issues with the Nouveau?
No issues, per se. I have always noticed better performace with the proprietary driver.

Quote:
Fourth, did you try switching consoles with Alt+F(2~6) to see if a prompt was available?
I did try switching consoles, no such luck.

Quote:
Lastly, can you post the output of the lspci utility?
Code:
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [NVS 5400M] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 21f6
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f2000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at f0000000 (64-bit, prefetchable) [size=32M]
	Region 5: I/O ports at 5000 [size=128]
	Expansion ROM at f3080000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
			ClockPM+ Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Not Supported, TimeoutDis+, LTR-, OBFF Not Supported
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
		LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
			 EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
	Capabilities: [b4] Vendor Specific Information: Len=14 <?>
	Capabilities: [100 v1] Virtual Channel
		Caps:	LPEVC=0 RefClk=100ns PATEntryBits=1
		Arb:	Fixed- WRR32- WRR64- WRR128-
		Ctrl:	ArbSelect=Fixed
		Status:	InProgress-
		VC0:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
			Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
			Ctrl:	Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
			Status:	NegoPending- InProgress-
	Capabilities: [128 v1] Power Budgeting <?>
	Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia
Also, here is the lsmod output.

Code:
nvidiafb               38503  0
vgastate                8729  1 nvidiafb
fb_ddc                  1357  1 nvidiafb
i2c_algo_bit            5472  1 nvidiafb
nvidia               8538034  0
drm                   250660  2 nvidia
i2c_core               37840  9 drm,i2c_i801,i2c_dev,i2c_algo_bit,fb_ddc,nvidia,v4l2_common,videodev,nvidiafb
I should note that after reviewing the lspci output I tried adding the nvidiafb module, as it wasn't loaded. I did also try adding the nvidiafb module to the initrd, no luck.
 
Old 08-17-2015, 12:43 AM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,153
Blog Entries: 3

Rep: Reputation: 339Reputation: 339Reputation: 339Reputation: 339
The "xf86-video-nouveau-blacklist " Those Docs should be updated. the Nvidia builder installer will do that for you now.
Going to current you will find you should uninstall the nvidia kernel first if not. It is not to late. If you install it the slackware way as you pointed out. The uninstall really helps. Now this should not be there.
Code:
nvidiafb               38503  0
vgastate                8729  1 nvidiafb
fb_ddc                  1357  1 nvidiafb
i2c_algo_bit            5472  1 nvidiafb
nvidia               8538034  0
drm                   250660  2 nvidia
i2c_core               37840  9 drm,i2c_i801,i2c_dev,i2c_algo_bit,fb_ddc,nvidia,v4l2_common,videodev,nvidiafb
Because that is blacklisted by default in slackware.
If you installed current and then the nouveau driver is loaded then just run the installer.
When it fails it will ask you if it is ok to right to the /etc/modprobe.d/and create a Nvidia-nouveau-blacklist.
if going from 14.1 to current you will have the libvdpau and a default install. this will cause issues that's another story.
Now below is ok that is the normal kernel warning.
Code:
[   44.163786] nvidia: module license 'NVIDIA' taints kernel.
[   44.163800] Disabling lock debugging due to kernel taint
[   44.173757] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   44.174250] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0
[   44.174263] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  352.30  Tue Jul 21 18:53:45 PDT 2015
I really do not know what your monitor is.
edit your /bot/grub/grub.cfg is correct if you followed this. http://docs.slackware.com/howtos:sla..._first_install
then you should be fine. if you have Grub2-efi
then look at this http://docs.slackware.com/howtos:sla...based_hardware
I think you may want to look at your grub.cfg and see if it is correct with your "blkid"
as far as no console mmmmm
that part is handle by the top of your grub.cfg.
Quote:
I know the startup finished because I can blindly login as root and issue a reboot.
No you do not even need to login to reboot just press ctrl>alt.delete. yes you can login as root
and type startx. or type init 4 and then go to a gui login.
some things are so simple it is hard to learn the linux way you will get it.
If the new Grub2 has a slackware virtual console at start up then thank you for bringing this up.
If you want to boot right to gui then change your /etc/initab to runlevel 4
 
Old 08-17-2015, 12:43 AM   #5
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.2 Slackware 14.2, Slackware{32,64}-current
Posts: 781
Blog Entries: 3

Rep: Reputation: 272Reputation: 272Reputation: 272
I don't use grub, but you can try not loading a (pseudo)graphical VESA framebuffer on boot. For example, in LILO, I sometimes need to set vga=normal to see anything. Also, if you have an integrated Intel GPU, make sure you blacklist that as well. Sometimes "disabling" in BIOS is not a real "disable." Check lsmod for any intelhd etc modules.

Since you are on a laptop, plug another monitor into the HDMI/DVI/dispay port/VGA what have you. Your LCD might be blank because it is not the primary display. Nvidia is whacky that way.

Finally, once you log in, did you just try to "startx"? Often X.org will fire up all available displays. You will also then have a /var/log/Xorg.0.log to check you further clues.
 
Old 08-17-2015, 02:06 AM   #6
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Original Poster
Rep: Reputation: 0
Quote:
I really do not know what your monitor is.
At this point the monitor I have doesn't matter. I'm not evening getting a virtual console once grub hands-off the framebuffer.

Quote:
No you do not even need to login to reboot just press ctrl>alt.delete. yes you can login as root
and type startx. or type init 4 and then go to a gui login.
You may have misunderstood. I know that a ctrl-alt-delete will reboot the computer. What I meant was that I can blindly enter my username and password, then issue a '/sbin/reboot'
 
Old 08-17-2015, 02:39 AM   #7
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,397
Blog Entries: 15

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Grub isn't good in some cases. Are you using a system with a UEFI or a BIOS?

In actuality, the Nvidia driver and kernel SlackBuilds are better to use than the traditional installer. It's cleaner, and care is taken to build utilities and place them in the correct directories, all the utilities are still installed too. Any time you use a distribution that uses a packaging system, use the packages that are provided.

Also because this is Nvidia, check the GPU support on the Nvidia website to make sure that the driver you downloaded will support the hardware.

As for Grub... This kinda relates to the UEFI or BIOS question, but have you looked into configuring /etc/defaults/grub to accurately tune your kernel at boot? Often this file goes a bit overlooked on Slackware.

Also have you ever tried setting up syslinux or lilo/elilo to boot the system rather than Grub?

Last edited by ReaperX7; 08-17-2015 at 02:48 AM.
 
Old 08-17-2015, 02:46 AM   #8
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Original Poster
Rep: Reputation: 0
Quote:
Grub isn't good in some cases. Are you using a system with a UEFI or a BIOS?
Yes, it is a UEFI system. I've already suceeded in getting grub to work with UEFI. And grub will boot the initrd/kernel just fine when the display setting in the BIOS is in "integrated" graphics mode. It actually boots the system just fine in "discrete" mode as well, with the exception of giving me a virtual console(showing me that it's booting). I can troubleshoot x once I have a virtual console.
 
Old 08-17-2015, 03:28 AM   #9
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,397
Blog Entries: 15

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
You're using the generic kernel with the initrd? Did you try using the huge kernel to see if it might help first?
 
Old 08-17-2015, 07:27 AM   #10
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware has beern Main OpSys for decades while testing others to keep up
Posts: 1,430

Rep: Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349Reputation: 1349
Just for the record, in the case of graphics drivers (specifically nVidia) I, too, prefer to use the nvidia binary directly (and also manually blacklist nouveau) and partly because I boot to runlevel 3, use lilo and avoid initrd, my system is easy to troubleshoot and rarely needs it. This is little more than a wild guess but since it seems as if all is working correctly with the single exception of console display (I'm not clear if OP can startx or not and check nvidia-settings) I'm betting on either grub or initrd being the problem by lacking an entry (or having a conflicting setting) that disallows console rendering.

My first check, were it mine, would be to search "grub2 doesn't show console" to seek similar problems and fixes others have reported. My reasoning is anecdotal but involves how grub2 is and has been the default choice for people who boot directly to X or even desktop. Most distros these days use grub2 and by default boot to X and have to be forced (sometimes at considerable hassle as they don't even use runlevel 3) to boot to console. I am unbelievably grateful Slackware doesn't present such obstacles by assuming it knows better than I what I want.

In any case, best wishes OP. I commiserate.
 
Old 08-17-2015, 09:31 PM   #11
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Original Poster
Rep: Reputation: 0
Quote:
You're using the generic kernel with the initrd? Did you try using the huge kernel to see if it might help first?
Yes, I am using the generic kernel with the initrd. I tried with the huge kernel as well. No luck.

I've also tried using the SlackBuild for the Nvidia driver, but to no avail. Exact same issue. I'm almost at a loss. I don't understand why other distributions using grub as the bootloader have no issue with the framebuffer and the Nvidia driver.

Any more suggestions?
 
Old 08-17-2015, 09:33 PM   #12
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,397
Blog Entries: 15

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Have you edited anything in /etc/defaults/grub?
 
Old 08-17-2015, 09:36 PM   #13
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Original Poster
Rep: Reputation: 0
No. I haven't made any changes to the /etc/default/grub with the exception of the trial and error changes from editing the menu entry directly at boot.
 
Old 08-17-2015, 11:08 PM   #14
arpanetguru
Member
 
Registered: Nov 2005
Location: USA
Distribution: Slackware Linux
Posts: 96

Original Poster
Rep: Reputation: 0
Duplicate posted. Deleted.
 
Old 08-18-2015, 03:44 AM   #15
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,397
Blog Entries: 15

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Try using the unedited grub.cfg. If you need to make changes, use /etc/defaults/grub to set the parameters of Grub to do so.
 
  


Reply

Tags
framebuffer, grub2, nouveau, nvidia, virtual console


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub2/console-setup commands for console mode 132 x 43 without framebuffer LQ123 Debian 0 10-22-2013 09:44 AM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 06:51 AM
Corrupt Console/Framebuffer with Nvidia Driver jinksys SUSE / openSUSE 0 12-17-2005 07:51 PM
NVIDIA driver 5336 FB console simbolo Linux - Hardware 0 02-26-2004 11:02 AM
NVIDIA driver 5336 FB console simbolo Linux - Software 0 02-24-2004 08:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration