LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-03-2010, 12:47 AM   #46
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 849

Original Poster
Rep: Reputation: 109Reputation: 109

Interestingly enough, last week, I build 2.6.33 on a Slackware 12.2 box. Just like my current box, I had the same problems building the nvidia driver. However, this was on a legacy hardware (nvidia-96). I'm also wondering if there is a difference between 32-bit and 64-bit.
 
Old 03-03-2010, 08:36 AM   #47
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (4.1.0) UEFI enabled
Posts: 379

Rep: Reputation: 79
Patch

Glad the patch helped some
Sorry it did not help all

as an aside
the nouveau driver requires xserver-1.7
it will grab your framebuffer even though it doesn't work
I am not running current but 13.0 uses xserver-1.6.3
john
 
Old 03-03-2010, 09:30 AM   #48
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,881

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
Thanks to all the tips in this thread I now have my nVidia GeForce 7300 LE running with the patched 190.53 driver installed using the nVidia installer on 32 bit -current using the generic kernel with an initrd. I also needed to blacklist nouveau.

VirtualBox 3.1.2 is also working after using the symlink so that the Slackbuild script could recompile the kernel module.

A big thanks to all contributors!

PS- The nouveau driver worked OK when I did startx without any xorg.conf, but when leaving X I was left with a corrupted display that I could only recover from by rebooting. Also, when using the nouveau driver, xrandr did not report the presence of my second monitor.

Last edited by allend; 03-03-2010 at 09:41 AM.
 
Old 03-03-2010, 12:42 PM   #49
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
PS- The nouveau driver worked OK when I did startx without any xorg.conf, but when leaving X I was left with a corrupted display that I could only recover from by rebooting. Also, when using the nouveau driver, xrandr did not report the presence of my second monitor.
AFAIK the current nouveau source is incompatible & doesnt work with the drm included in the 2.6.33.x kernels.
You have to compile a seperate nouveau drm source tree.
I dont know why Pat included it in the kernel at this point and personally i consider it a bug.
 
Old 03-03-2010, 02:19 PM   #50
GazL
Senior Member
 
Registered: May 2008
Posts: 3,652

Rep: Reputation: 1132Reputation: 1132Reputation: 1132Reputation: 1132Reputation: 1132Reputation: 1132Reputation: 1132Reputation: 1132Reputation: 1132
Did the upgrade in current64 this afternoon.

startx results in a corrupted screen. ctrl-alt-f1 will return me to the console but doesn't restore the screen. Typing blind I was able to issue commands though, which at least allowed me to shutdown cleanly. I've tried both the nv and svga based xorg.conf files I had been using previously, both with and without blacklisting the nouveau module.

Without a Xorg.conf file I do get a working screen, but only at 1024x768 which is no use to me as it makes everything blurry

Running xorgsetup also produces the corrupted screen when it does the hardware probe, which means I can't complete the dialog and generate a new xorg.conf

This is using a Nvidia GT140 card.

Haven't tried the proprietary driver yet.


update:

I found by specifying vga=0 at boot solves the screen corruption and inability to swap back to a console, so it looks framebuffer related.

Using the nv driver results in nothing other than the cursor being drawn on a black screen. The cursor does change shape when you move it about over different elements of the desktop that would be there if you could see them.

I've managed to get it working with the VESA driver now at a decent resolution, I just need to find a way to up the refresh-rate now.

Last edited by GazL; 03-03-2010 at 04:14 PM.
 
Old 03-03-2010, 02:23 PM   #51
rwyarbrough
LQ Newbie
 
Registered: Oct 2003
Location: Mesquite, Texas
Distribution: Slackware
Posts: 8

Rep: Reputation: 1
One Solution

I tried various things, but in my case I followed these steps to get things to work (fixed the Invalid module format issue)

cp /boot/config-huge-2.6.33 /usr/src/linux-2.6.33/.config && cd /usr/src/linux-2.6.33 && make && make modules_install && cp arch/x86_64/boot/bzImage /boot/vmlinuz && lilo && echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf && telinit 6

I then downloaded and installed the latest certified (and NVIDIA recommended) NVIDIA driver released 3/3/2010 (195.36.08) from the NVIDIA site. This release doesn't need to be patched apparently because it worked fine.

http://www.nvidia.com/object/linux_d...195.36.08.html

and all works well so far...

Note: I tried the latest driver first without rebuilding the modules and the invalid module format issue was still present.

Last edited by rwyarbrough; 03-03-2010 at 02:29 PM.
 
2 members found this post helpful.
Old 03-03-2010, 04:14 PM   #52
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Linux Mint 17.1
Posts: 1,424

Rep: Reputation: 137Reputation: 137
Quote:
I tried various things, but in my case I followed these steps to get things to work (fixed the Invalid module format issue)

cp /boot/config-huge-2.6.33 /usr/src/linux-2.6.33/.config && cd /usr/src/linux-2.6.33 && make && make modules_install && cp arch/x86_64/boot/bzImage /boot/vmlinuz && lilo && echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf && telinit 6

I then downloaded and installed the latest certified (and NVIDIA recommended) NVIDIA driver released 3/3/2010 (195.36.08) from the NVIDIA site. This release doesn't need to be patched apparently because it worked fine.

http://www.nvidia.com/object/linux_d...195.36.08.html

and all works well so far...
I followed this route as well and I have a working nvidia desktop again.

samac
 
Old 03-03-2010, 08:15 PM   #53
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,602

Rep: Reputation: 209Reputation: 209Reputation: 209
Running slackware64-current with a nvidia 650se chipset had same problems, rwyarbrough method worked for me also.
 
Old 03-03-2010, 09:15 PM   #54
kemsiro
Member
 
Registered: Sep 2007
Location: Vietnam
Distribution: Slackware
Posts: 38

Rep: Reputation: 15
I downloaded the Nvidia driver version 195.36.08 and then installed it properly.
However, when I run #startx to init the X server, I could not startx the X, the message say that "could not load module nvidia"
I don't know how to show all the message outputted by the "startx" command. Could you tell me how to "catch" those messages?
And, what's wrong with my computer?
I'm using slack13, Asus K40IN laptop. Nvidia Geforce G102M
Last time, before I upgrade my kernel to 2.6.33 everything is fined: after I install the nvidia driver, I can start KDE.
 
Old 03-03-2010, 09:28 PM   #55
smoooth103
Member
 
Registered: Aug 2009
Location: NC, USA
Distribution: Slackware (64 bit)
Posts: 241

Rep: Reputation: 60
I was able to get -current working with NVIDIA doing these step. (general steps not specific)

1. Use the /boot/config-huge-2.6.33-smp to recompile the 2.6.33 kernel (/usr/src/linux/make && make modules_install)
2. Blacklist the "nouveau" in /etc/modprobe.d/blacklist (kernel would panic without this)
3. Download new ./NVIDIA.sh version 190.53 and apply the patch (patch is copied in previous post)
NVIDIA-Linux-x86-190.53-pkg2.run --apply-patch nvidia-190.53-2.6.33.patch.txt

The NVIDIA-190.53.sh would not properly install the driver on my machine without the patch applied.
 
Old 03-04-2010, 02:08 AM   #56
kemsiro
Member
 
Registered: Sep 2007
Location: Vietnam
Distribution: Slackware
Posts: 38

Rep: Reputation: 15
Thanks samac and smoooth103 for your precious instruction. Now I'm here with my new kernel system + KDE.

Could you please answer me some newbie questions?
- Why can you catch those error messages when you run startx? I tried: startx > error.txt but it did not work.

"
WARNING: Error inserting agpgart (/lib/modules/2.6.33/kernel/drivers/char/agp/agpgart.ko): Invalid module format
FATAL: Error inserting nvidia (/lib/modules/2.6.33/kernel/drivers/video/nvidia.ko): Invalid module format
smoooth "

- I guessed my error is because of "nouveau" driver do not work with xserver < 1.7, and the nouveau only work with kernel mode setting. Why can you figure this error? And why a recompiling the kernel and then blacklist nouveau can fix this problems? (The kernel has been rebuilt already before the nouveau was blacklist, why isn't it late to blacklist it?)
 
Old 03-04-2010, 09:13 AM   #57
poplin
LQ Newbie
 
Registered: Jun 2003
Distribution: Slackware, Slackware64, Slackware-current
Posts: 4

Rep: Reputation: 0
Post My 2 cents contribution...

In this way I got 2.6.33 and nvidia drivers working (very similar to smoooth103 by the way):

1. Boot huge and recompile kernel (I had to make it since I have > 4Gb and I don't want to use slack64 + multilib (*)) using config-generic-smp-2.6.33-smp as template.

2. Blacklist nouveau.

3. Use nvidia 195.36.08. No patches needed, I just edited the corresponding slackbuilds to obtain nvidia-driver-195.36.08-i486-1_SBo (comment out the line #rm vdpau/libvdpau.so.$VERSION vdpau/libvdpau_trace.so.$VERSION) and nvidia-kernel-195.36.08_2.6.33_smp-i486-1_SBo. Let me know if you want the sbo files.



(*) by the way, does someone know if including PAE in the 32-bit kernel degrades its performance?. If not, why is not included by default in the distributed kernel. Or am I supposed to stick to slack64 + multilibe if have more than 4 Gb?

Last edited by poplin; 03-04-2010 at 09:20 AM.
 
Old 03-04-2010, 10:32 AM   #58
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 5,376

Rep: Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495
How-to use the nouveau driver with a 2.6.33 kernel and X11R7.5 running Slackware-current

1. Read this page.
2. Follow instructions beginning at step 3, as xorg7.5 and kernel 2.6.33 (which includes the kernel module among "staging drivers") are included in -current since March 1, 2010.

To avoid the framebuffer problem:
1. blacklist nouveau in /etc/moprobe.d/blacklist.conf
2. include "/sbin/modprobe/ nouveau" in /etc/rc.d/rc.local -- and have this file executable, of course.

@sakho : don't complain about Pat because nouveau is in 2.6.33 tree, as it's Linus' fault ... But then, bear in mind that it's in "staging drivers" for a reason.

May be you could ask for an upgrade of libdrm in -current instead, though I didn't try the package libdrm-2.4.18-x86_64-1.txz included in the last batch of changes as I run -stable for now; may be it works as well as the one in the git tree ? Not sure at all about that though. [EDIT]BTW libdrm-2.4-19 has been released yesterday[/EDIT]

And of course it would be nice to see xf86-video-nouveau in -current as well -- unfortunately it's not available in X11R7.5 release

PS Most of this was explained already in former threads -- only a reminder.

Last edited by Didier Spaier; 03-05-2010 at 03:25 AM. Reason: Clarification
 
Old 03-04-2010, 03:24 PM   #59
rwyarbrough
LQ Newbie
 
Registered: Oct 2003
Location: Mesquite, Texas
Distribution: Slackware
Posts: 8

Rep: Reputation: 1
Quote:
Originally Posted by kemsiro View Post
I downloaded the Nvidia driver version 195.36.08 and then installed it properly.
However, when I run #startx to init the X server, I could not startx the X, the message say that "could not load module nvidia"
I don't know how to show all the message outputted by the "startx" command. Could you tell me how to "catch" those messages?
And, what's wrong with my computer?
I'm using slack13, Asus K40IN laptop. Nvidia Geforce G102M
Last time, before I upgrade my kernel to 2.6.33 everything is fined: after I install the nvidia driver, I can start KDE.
kemsiro,

The issue is related to the kernel modules. They need to be recompiled in order to eliminate the nvidia module not loading due to a fatal error. It is something specific to kernel version 2.6.33.

The error messages can be found in the /var/log/Xorg.0.log. Since you can also see the message "could not load module nvidia" from the startx output, you could then try to manually load the nvidia module using modprobe nvidia which would give you the error message output. Pretty sure that it will be two lines stating that the module format is invalid.

Hope that helps.
 
Old 03-04-2010, 11:47 PM   #60
kemsiro
Member
 
Registered: Sep 2007
Location: Vietnam
Distribution: Slackware
Posts: 38

Rep: Reputation: 15
Quote:
Originally Posted by rwyarbrough View Post
kemsiro,

The issue is related to the kernel modules. They need to be recompiled in order to eliminate the nvidia module not loading due to a fatal error. It is something specific to kernel version 2.6.33.

The error messages can be found in the /var/log/Xorg.0.log. Since you can also see the message "could not load module nvidia" from the startx output, you could then try to manually load the nvidia module using modprobe nvidia which would give you the error message output. Pretty sure that it will be two lines stating that the module format is invalid.

Hope that helps.
Yes, the messages are exactly as you said.
Thank you very much for showing me the place that hold the error log.

However, I still wonder the order of those steps.
From the steps I followed, I figure out that the order is that at first I need to compile the kernel source, then install it (by replacing the /boot/vmlinuz & run lilo), then blacklist the nouveau?

Why shouldn't it be: "blacklist the nouveau module before recompiling & installing the kernel"? This order is more logical to prevent nouveau from recompiling to the kernel?

Sorry if my question is a newbie question. I am really a newbie .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
(EE) NVIDIA(0): Failed to initialize the NVIDIA Kernel module latino Linux - Hardware 5 06-03-2008 03:55 AM
(EE) NVIDIA(0): Failed to initialize the nvidia kernel module necbrownie Slackware 18 06-16-2006 02:20 AM
nvidia 6106, kernel 2.6.7, slackware 10, failure to load nvidia.ko Tarball_Phreak Linux - Hardware 3 08-04-2004 03:16 PM
kernel 2.6.3--bk8 and NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia zdenkod Linux - Hardware 2 03-09-2004 05:38 AM
(EE) NVIDIA (0) Failed to initialize the NVIDIA kernel module Isjhe Mandriva 14 09-25-2003 09:29 PM


All times are GMT -5. The time now is 07:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration