-   Slackware (
-   -   NVIDIA and ACPI Boot issues (

NewtonIX 07-10-2013 01:07 AM

NVIDIA and ACPI Boot issues
2 Attachment(s)
I have been using slack for my servers for over a decade now and a couple months ago I decided to use it as my desktop for the first time.
Everything is perfect except I have to set acpi=off kernel option in order for it to boot.

I would like to enable acpi so my machine will actually shutdown

Attached is a screenfetch with some basic info, I am running 14.0, everything is updated and I am running nvidia 325.08 (beta) drivers, I have also tried their latest stable release with no difference.

I also included a terrible photo of my boot screen with acpi on (it was taken with an ipad). I caught a message about Nvidia Tainting the kernel before the video went haywire as shown at one point, hence the reason I think its a video card/Driver issue that is causing it. I have also tried using vga=normal and it doesn't botch the screen as shown but it will eventually just lockup and it is at different points in the boot process so it is no real indication as to why its locking up.

Just to re-iterate, with acpi=off it boots just fine and I know acpi is supported by my board. I have even tried to two different acpi bios settings and no difference.

I know my way around Slack, at least until i go to init 4 lol
So dont be shy, if im making some noob mistake let me know

Here is my lilo.conf currently ( w/o the acpi=off )


# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/sda
compact        # faster, but won't work on all systems.
# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255
# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Append any additional kernel parameters:
append=" vt.default_utf8=0 raid=noautodetect rootfstype=ext4"
timeout = 80
# VESA framebuffer console @ 1024x768x64k
vga = 842
# Normal VGA console
#vga = normal
# Ask for video mode at boot (time out to normal in 30s)
# vga = ask
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0    # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda3
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
  label = WindBlowz
  table = /dev/sda
# Windows bootable partition config ends

allend 07-10-2013 03:07 AM

Have you tried debugging the ACPI problem?

elesmod 07-10-2013 08:12 AM

I have a Gigabyte motherboard that refuses to boot many distributions unless I pass acpi=off. After some searching I've found another option that I can pass instead of the acpi one. Now I use

and suspending my machine works fine. I'm not really sure what that option does, but I haven't noticed any drawbacks.

NewtonIX 07-10-2013 01:20 PM

Thanks I have tried all kinds of work arounds and options but havent tried either of those
I will give them both a run tonight

kingbeowulf 07-10-2013 02:38 PM

Same issue with nouveau? Did you BLACKLIST nouveau? (see /extra) Just loading Nvidia does not unload nouveau - esp. on huge kernel. vga=normal is recommended since Nvidia requires a text mode kernel, not vesafb etc.

Also, try using the generic kernel via an initrd. That might point to which module is the root cause. Check /var/log/dmesg, /var/log/messages/ and /var/log/syslog Remember, will all your cores, it might "look" like the error occurs in different places in the boot process....

Other append="" parameters to try:

noapm (should be deprecated but you never know)

and others in the link allend posted above.

number22 07-10-2013 04:49 PM

try nopat kernel flag and always blacklist nouveau if you use nvidia proprietary driver.

NewtonIX 07-11-2013 01:17 AM

I sat down and prepared myself for a long session of reboots to try all these kernel flags but decided to first blacklist nouveau since it aparently needs to be either way.
Sure enough after blacklisting that module it booted with not issues with acpi on

Thank you everyone for you help

All times are GMT -5. The time now is 08:44 AM.