-   Slackware (
-   -   Nvidia 9746 Drivers - startx freezes machine when using nvidia module (

Astro 01-02-2007 09:06 PM

Nvidia 9746 Drivers - startx freezes machine when using nvidia module
Hey all,

Coming back to slackware after a long while away... need some help setting up X. I just did a fresh install of Slack 11 and installed the 9746 Nvidia drivers. I have a GeForce FX5200 and two Viewsonic VP171b's which can do 1280x1024.

The goal is to set up Xinerama I believe and use the second monitor as an extended desktop such as in windows.

I unplugged the second monitor from the video card so the DVI one is plugged in... and ran xorgsetup and let it pick all the values for the single monitor including using the "nv" driver. Startx works fine and I can load KDE.

When I switch to "nvidia" for the driver and run startx the screen goes blank and the machine seems to lock up. (I came to this conclusion after attempting to get the two monitors set up and having it lock up in the same way so I though I'd simplify things and just try one monitor... and got the same problem)

Theres nothing useful in the Xorg log file, everything seems to start fine and theres no errors other than not being able to find the font path element for CID and FPE "path here" refcount is 2 should be 1 thing.

Not sure where to go from here if I can't even get the X working with 1 single monitor and the nvidia module. Any ideas? I had this working before with this card.. so I think the card itself is ok, works in windows just fine.

As far as I know the info I wrote down last time about this monitor to get it to work was as follows... 31.5-82 Horizontal (1280x1024@76Hz) (40-150 Vsync)

mattydee 01-02-2007 10:57 PM

Maybe you could try to use the drivers from Nvidia. I'm running a 6600gt and had problems at first, but when I ran the setup script from Nvidia, everything worked great. It even detected my native resolution automatically.

You can use the links browser to get to the forceware site from the command line or use the "vesa" driver to use an x-based browser to navigate there.


Sorry, I just noticed that you wrote that you did in fact download the forceware drivers... is this right?

Astro 01-03-2007 12:29 AM


Originally Posted by mattydee
Sorry, I just noticed that you wrote that you did in fact download the forceware drivers... is this right?

Yes I did download the latest, which is 9746 from the downloads section and installed it. That seems to be where the problem lies...maybe I could try an older version and see how that goes.

krussell 01-03-2007 05:45 AM

Hello Astro :-)
I have done this with FX5200 and nvidia driver. you have to edit the /etc/xorg/xorg.conf file according to the instructions for dual monitor in nvidia help file (/usr/doc/Nvidia...)
Theoritically, first you have to fix what will be displayed in the second monitor (Left, Right, Clone), the regular is Clone. Then you have to do the refresh rate for the second monitor. I did it and it worked like a charm ONLY IN SLACKWARE.

mattydee 01-03-2007 02:26 PM

Ok, maybe I'm not understanding something.

First, this problem is loosely related to this one:

Second, I get the sense that you edited the xorg.conf file file manually to change it from "vesa" to "nvidia". If this is correct (and this is where I maybe missing something), I'm curious to know why people are doing this. Running the installer provided by nvidia takes care of everything and writes an xorg.conf for you while backing up your existing one. Sure, you could tweak a little afterwards to suit your needs, but you shouldn't have to change something as elementary as the driver setting, as again, the installation script should have done this for you.

Astro 01-09-2007 08:14 PM

RIght i shouldnt have to change anything afterwards, but it won't work. For some reason with the "nvidia" driver it locks up.

Astro 01-09-2007 09:16 PM

Ok I did some more messing around with this tonight... and had no luck. I did some scenarios. First off I uninstalled the Nvidia drivers I had and ran xorgsetup, let it autoconfig everything and ran startx. It ran fine. I logged out and copied the xorg.conf and the Xorg.0.log files for reference...I did this in every scenario.
Stock xorg.conf
Stock Xorg.0.log

First I installed the Nvidia 1.0-9746 drivers. Let it autoconfig the xorg.conf file, and ran startx. it went to a blank screen, and I ended up having to reboot. It didn't even create a new Xorg.0.log file.
1.0-9746 xorg.conf

Next I uninstalled those drivers and installed the 1.0-9631 drivers. startx revealed a blank screen for a split second then both monitors shut off completely. Had to reboot.
1.0-9631 xorg.conf
1.0-9631 Xorg.0.log

Uninstalled those and installed the 1.0-9629 drivers... this had the same results as the 9746 drivers... blank screen...
1.0-9629 xorg.conf
1.0-9629 Xorg.0.log

So the only thing that is different from the stock base Xorg.conf is the "nv" or "nvidia" and the stock one has a "BusID "PCI:1:0:0"" for the nvidia card and the nvidia ones don't. Any thoughts?

Astro 01-09-2007 09:26 PM

Also, adding the BusID "PCI:1:0:0" to the xorg configs that the nvidia installed made did not affect it.:mad:

tcomputerchip 01-13-2007 07:51 PM

I am experiencing the same issue's well, similar.

My drivers work (I have tried them several times).

What I mean is, when I compile the driver for the first time, it works.
% sh
% startx

I see the nvidia logo, things are fine.
I reboot, things are fine.

I shutdown the machine (complete poweroff)
I turn the machine back on.
I get a blank screen.
I then login as root (Ctrl+alt+F5)
Then % init 3
I edit my xorg.conf to have the "nv" driver, than I startx, to get my session back, but this is the generic drivers.

So doing some digging proves that the nvidia.ko files and other nvidia drivers get overwritten on startup.

% uname -r
%/sbin/lsmod |grep nvidia
nvidia              4561684  12
i2c_core              25793  3 i2c_ec,nvidia,i2c_i801

The driver is loaded, just its now the wrong one.

I did notice:

% rpm -qa xorg*nv*

Removing that packdege is bad, as its part of the xorg-x11, and will render x11 useless.
I would prefer its gone.

I dont want to use the RPM's, as they have proven to not be stable with Maya/Shake/Houdini software. And the venders don't support them if you have them installed, they only support the drivers that are recommended on the site.

Last note: Editing the xorg.conf to "nvidia" is known, I known how to do this part, in fact I have built several drivers on several version of fedora 1 - 4. All working fine, FC5 seems to have this new problem I can't resolve.

Any idea's???

willysr 01-13-2007 08:16 PM

Last night i tried to upgrade to 9746 and i have no problem loading startx from text mode, but when i log off, it's not coming back to the text mode again, but rather displaying some blur screen like in one of KDE's screensaver.

Finally i decided to downgrade again to 9631 and it worked

tcomputerchip 01-13-2007 08:22 PM

yes, that driver works great (9631), I would stay on that as its been the most stable for the installs i have done.

willysr 01-13-2007 08:36 PM

agree on that. This is the most stable version i had.
(lucky me that i haven't delete this version after i upgrade to 9746)

Strange thing is, there's no entry in about 9746 issue, except when being used in Xorg 7.2.

Anybody founds one?

Astro 01-13-2007 08:46 PM

Still no luck on my end. I sure would like to get this working but I can't figure anything out... usually I'm not that bad with this kind of stuff but I can't figure this one out.

tcomputerchip 01-13-2007 10:07 PM

have you tried removing the driver, then rebooting, then reinstalling the driver (dont reboot) then startx

use the % sh NVIDIA-[YOUR VERSION].sh --uninstall
search for the driver, make sure its not in your kernel folder, if it still is remove it.

also, remember to remove:
rm -f /dev/nvidia*

I have seen notes that this maybe related to libgl not being available in the correct folder for X11, I have tried the workaround with no luck, even on the driver I am using.

By the way, make sure you are not downloading IA64 if you machine is not 64-bit, I dont believe the 9000 numbers are IA32, I think they have the 32-bit drivers but I have yet to get them to work on 32-bit machines. (9000 numbers that is)

The 8776 version is the latest (as of last week, could have changed) for IA32.

9631 version works well for Geforce cards, and 8776 seems to work well with Quadro.

sreraku 01-17-2007 09:01 PM

nvidia driver 9746
I sent the mail as below to nvidia and waiting on those people to see whats happening. I have 2 trivial questions.
1)For core2duo, should I use x86-64 or IA32 driver pkg?
2)what should be my xorg configuration if I have s-video connected to tv along with monitor?

I am waiting for someone to really help me get out of this mess. Help is hightly appreciated.

> Hi,
> I installed per Jared's instruction on his homepage
> myth on FC5. I installed nvidia-graphics driver 9746
> and when I did init 5, it tried to get the x going but
> suddenly my viewsonic lcd monitor comes out and says
> out of range. My kernel is 2.6.18-1.2257.fc5smp. I am
> using a core2duo E6300 cpu with GEForce 7600GS
> graphics card. Appreciate any help in getting this
> resolved.

> Thanks,
> Ps: Attached is the xorg output that i captured when I
> ran startx at verbose 5

All times are GMT -5. The time now is 01:57 AM.