LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-15-2019, 03:56 PM   #1
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 43

Rep: Reputation: Disabled
Nvidia 390.87 on 4.4.172 possible?


Hello,

I have an older Asus G73S laptop that has an Nvidia GTX 460M. It's been working fine with the Nvidia 390.87 drivers on Slackware64 14.2 when running the 4.4.157 kernel. However, installation fails when upgrading to the 4.4.172 kernel.

I see that this is a known problem as the 4.4.172 kernel made API changes as stated in these threads, https://www.linuxquestions.org/quest...ia-4175647404/, and https://www.linuxquestions.org/quest...de-4175652495/. It seems that there's been some luck with getting the newer Nvidia drivers to install on systems running the 4.4.172 kernel. However, Nvidia has ended support for the GTX 460M, and the 390.87 driver is the last version that supports it.

I am wondering, has anyone discovered a workaround that works to install this version of the driver on Slackware64 14.2 running the 4.4.172 kernel? The nouveau driver just doesn't really cut it for my needs.

Any help is appreciated. Thanks!

Last edited by The_Dark_Passenger; 05-16-2019 at 01:53 AM.
 
Old 05-16-2019, 12:29 AM   #2
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.2 Slackware 14.2, Slackware{32,64}-current
Posts: 886
Blog Entries: 9

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
The latest legacy driver for you GPU series is 390.116. I think the build failures where fixed/backported for kernel 4.4.172 if I understand the release notes correctly.
https://www.nvidia.com/Download/driv...x/142563/en-us
 
1 members found this post helpful.
Old 05-16-2019, 01:53 AM   #3
The_Dark_Passenger
Member
 
Registered: Apr 2018
Distribution: Slackware64 14.2 & -Current
Posts: 43

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by kingbeowulf View Post
The latest legacy driver for you GPU series is 390.116. I think the build failures where fixed/backported for kernel 4.4.172 if I understand the release notes correctly.
https://www.nvidia.com/Download/driv...x/142563/en-us
Thank you so much kingbeowulf! I wasn't aware this release existed. I was just now able to update to it and am running the 4.4.172 kernel! Thanks again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver 390.87 install fails after update to Linux 4.4.172 ProzacR Slackware 1 02-01-2019 03:46 PM
LXer: Nvidia 390.77 Linux Graphics Driver Improves Compatibility with Latest Kernels LXer Syndicated Linux News 0 07-18-2018 07:03 AM
Installing cuda toolkit 9.1 with nvidia 390 driver on ubuntu 17.10 ethereal1m Linux - Software 0 03-04-2018 02:45 PM
Annoyances with nvidia 390.25 / tearing issues coralfang Linux - Software 6 02-03-2018 12:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration