LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-22-2004, 09:10 AM   #1
nIMBVS
LQ Newbie
 
Registered: Sep 2003
Location: Romania
Distribution: Linux Mint
Posts: 29

Rep: Reputation: 21
NTP won't work, whatever I do


My ntpd on my Slackware machine doesn't syncronize with a time server.

I set up the /etc/ntp.conf file like so:
Code:
server  ntp.cesnet.cz
server ntp.rdsis.ro
logfile /var/log/ntp.log
server  127.127.1.0     # local clock
fudge   127.127.1.0 stratum 10
driftfile /etc/ntp/drift
restrict default noquery notrust nomodify
restrict 127.0.0.1
And the ntpd starts fine. But when i do "ntpq -p" the string in the "refid" column is always ".RSTR." and the jitter is always 4000.00. I read in the manual that ".RSTR." means "Access denied due to local policy. No further messages will be sent to the server. " but I don't understand one bit what it means. I don't understand what local policy means. I didn't set any firewall...

I have to mention that using ntpdate -u ntp.cesnet.cz works just fine.

Last edited by nIMBVS; 09-22-2004 at 09:15 AM.
 
Old 09-22-2004, 07:18 PM   #2
brenton
Member
 
Registered: Mar 2004
Location: Sydney, Australia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
ntp.cesnet.cz is a Stratum 1 server. "Access denied due to local policy" means they are blocking you from connecting. If you read on that site it says "Access Policy: open to servers providing synchronization to ten or more hosts, others by arrangement".

Basically, you shouldn't be connecting to a stratum 1 server. Stratum 1 servers are directly connected to a clock.

Stratum 2 servers connect to stratum 1 (usually aranged beforehand).

End users should use an open access server. Put one of these URLs into ntp.conf.
 
Old 09-23-2004, 02:36 AM   #3
nIMBVS
LQ Newbie
 
Registered: Sep 2003
Location: Romania
Distribution: Linux Mint
Posts: 29

Original Poster
Rep: Reputation: 21
I solved it by removing the line "restrict default noquery notrust nomodify" from ntp.conf. I don't understand why it doesn't work on my machine because on other RedHats which I have in my network it works fine with that line in the configuration file.
 
Old 09-23-2004, 02:42 AM   #4
brenton
Member
 
Registered: Mar 2004
Location: Sydney, Australia
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
Well even if it works you shouldn't be using a stratum 1 server. That server is there to provide other servers with the time, which provide other servers, which you can connect to. If you keep using it your IP will be blocked. There's probably only a difference of a <50 milliseconds anyway.

Change your server to europe.pool.ntp.org
 
Old 10-11-2004, 02:32 PM   #5
jkidd
LQ Newbie
 
Registered: Apr 2002
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
Removing only the "notrust" flag should let you syncronize your clock and keep you (somewhat) secure.
 
Old 02-16-2005, 11:58 AM   #6
edafe
Member
 
Registered: Feb 2005
Posts: 44

Rep: Reputation: 15
Please have a look at:

http://www.edafe.org/slackware/index.html#ntp

Regards,
Edafe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ntp darkkan Debian 3 09-09-2005 12:11 PM
help with NTP stevenhasty Slackware 6 02-16-2005 12:04 PM
ntp race Debian 5 12-16-2004 12:43 PM
NTP cannot work with timeserver, NTP-d can jerryvapps Linux - Networking 0 08-04-2004 03:04 PM
NTP cannot use server, NTP -d can jerryvapps Linux - Newbie 0 07-28-2004 03:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration