LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-01-2014, 10:44 AM   #31
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31

Reinstalled slackware-14.1 last night, and did slackpkg upgrade-all.
Put your .conf file in ( I use the mv command )and did ntpq -pn twice, waiting 8 minutes.
Got this: # ntpq -pn
remote refid st t when poll reach delay offset jitter
==============================================================================
*127.127.1.0 .LOCL. 10 l 33 64 377 0.000 0.000 0.000
206.186.121.125 .INIT. 16 u - 64 0 0.000 0.000 0.000
142.137.247.109 .INIT. 16 u - 64 0 0.000 0.000 0.000
208.80.96.70 .INIT. 16 u - 64 0 0.000 0.000 0.000
bash-4.2#

I did not do
grep UTC * 2>/dev/null
adjtime:UTC
hardwareclock:UTC


so used

because I know not how or where.
So I used timeconfig to set hardware clock to UTC (which I still think of as GMT).
Then
# /etc/rc.d/rc.ntpd restart
Stopping NTP daemon...
Starting NTP daemon: /usr/sbin/ntpd -g
bash-4.2#
and 8 minutes later
# ntpq -pn
remote refid st t when poll reach delay offset jitter
==============================================================================
*127.127.1.0 .LOCL. 10 l 18 64 377 0.000 0.000 0.000
198.27.65.66 .INIT. 16 u - 128 0 0.000 0.000 0.000
206.108.0.131 .INIT. 16 u - 128 0 0.000 0.000 0.000
205.204.93.138 .INIT. 16 u - 128 0 0.000 0.000 0.000
bash-4.2#
 
Old 05-01-2014, 11:16 AM   #32
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
# nmap -p123 -sU 0.ca.pool.ntp.org 1.ca.pool.ntp.org

Starting Nmap 6.40 ( http://nmap.org ) at 2014-05-01 11:13 EDT
Nmap scan report for 0.ca.pool.ntp.org (129.128.5.211)
Host is up (0.0018s latency).
Other addresses for 0.ca.pool.ntp.org (not scanned): 199.182.221.110 208.80.96.96 72.51.27.50
rDNS record for 129.128.5.211: time2.srv.ualberta.ca
PORT STATE SERVICE
123/udp open|filtered ntp

Nmap scan report for 1.ca.pool.ntp.org (208.80.96.70)
Host is up (0.0012s latency).
Other addresses for 1.ca.pool.ntp.org (not scanned): 67.215.197.151 199.182.221.110 206.108.0.132
rDNS record for 208.80.96.70: ellen.linuxgeneration.org
PORT STATE SERVICE
123/udp open|filtered ntp

Nmap done: 2 IP addresses (2 hosts up) scanned in 2.51 seconds
bash-4.2#

So it looks like port 123 is open, but filtered?
 
Old 05-01-2014, 11:36 AM   #33
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
Cripes!

Code:
grep UTC /etc/* 2>/dev/null
/etc/adjtime:UTC
/etc/hardwareclock:UTC
Dammit, I hate getting old and blind.

Sorry.
 
Old 05-01-2014, 11:45 AM   #34
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
On my (working) 14.1 system:
Code:
nmap -p123 -sU 0.ca.pool.ntp.org 1.ca.pool.ntp.org

Starting Nmap 6.40 ( http://nmap.org ) at 2014-05-01 11:43 EDT
Nmap scan report for 0.ca.pool.ntp.org (198.50.145.138)
Host is up (0.0038s latency).
Other addresses for 0.ca.pool.ntp.org (not scanned): 206.186.121.118 206.108.0.131 206.108.0.132
rDNS record for 198.50.145.138: srv4.hrtech.de
PORT    STATE         SERVICE
123/udp open|filtered ntp

Nmap scan report for 1.ca.pool.ntp.org (206.108.0.132)
Host is up (0.0034s latency).
Other addresses for 1.ca.pool.ntp.org (not scanned): 142.137.247.109 198.27.65.66 206.108.0.131
rDNS record for 206.108.0.132: ntp2.torix.ca
PORT    STATE         SERVICE
123/udp open|filtered ntp

Nmap done: 2 IP addresses (2 hosts up) scanned in 1.02 seconds
That's what it's supposed to be.
 
Old 05-01-2014, 11:53 AM   #35
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
I don't see where you set the clock? Did you do
Code:
ntpd -b -g -q
and then start the NTP daemon?

If you're using the ntp.conf file I posted, you can
Code:
cat /var/log/ntp.log
 1 May 11:26:17 ntpd[20243]: LOCAL(0) 8011 81 mobilize assoc 15879
 1 May 11:26:17 ntpd[20243]: 216.66.0.142 8011 81 mobilize assoc 15880
 1 May 11:26:17 ntpd[20243]: 184.105.182.7 8011 81 mobilize assoc 15881
 1 May 11:26:17 ntpd[20243]: 209.208.97.78 8011 81 mobilize assoc 15882
 1 May 11:26:17 ntpd[20243]: 0.0.0.0 c016 06 restart
 1 May 11:26:17 ntpd[20243]: 0.0.0.0 c012 02 freq_set kernel -19.244 PPM
 1 May 11:26:18 ntpd[20243]: LOCAL(0) 8024 84 reachable
 1 May 11:26:18 ntpd[20243]: LOCAL(0) 903a 8a sys_peer
 1 May 11:26:18 ntpd[20243]: ntpd: time slew +0.000000 s
 1 May 11:27:17 ntpd[20263]: LOCAL(0) 8011 81 mobilize assoc 8103
 1 May 11:27:17 ntpd[20263]: 142.54.185.82 8011 81 mobilize assoc 8104
 1 May 11:27:17 ntpd[20263]: 54.235.96.196 8011 81 mobilize assoc 8105
 1 May 11:27:17 ntpd[20263]: 173.208.234.242 8011 81 mobilize assoc 8106
 1 May 11:27:17 ntpd[20263]: 0.0.0.0 c016 06 restart
 1 May 11:27:17 ntpd[20263]: 0.0.0.0 c012 02 freq_set kernel -19.244 PPM
 1 May 11:27:18 ntpd[20263]: LOCAL(0) 8024 84 reachable
 1 May 11:27:18 ntpd[20263]: LOCAL(0) 903a 8a sys_peer
 1 May 11:27:18 ntpd[20263]: 0.0.0.0 c515 05 clock_sync
 1 May 11:27:20 ntpd[20263]: 142.54.185.82 8024 84 reachable
 1 May 11:27:21 ntpd[20263]: 54.235.96.196 8024 84 reachable
 1 May 11:27:21 ntpd[20263]: 173.208.234.242 8024 84 reachable
 1 May 11:30:37 ntpd[20263]: 173.208.234.242 903a 8a sys_peer
 1 May 11:31:40 ntpd[20263]: 54.235.96.196 943a 8a sys_peer
 1 May 11:32:48 ntpd[20263]: 173.208.234.242 941a 8a sys_peer
 1 May 11:39:02 ntpd[20263]: LOCAL(0) 8043 83 unreachable
The last line there, where LOCAL is unreachable, is when NTP synchronized with an external time service and
Code:
ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 127.127.1.0     .LOCL.          10 l 1313   64    0    0.000    0.000   0.000
*142.54.185.82   216.229.0.49     3 u  116  128  377  572.625    3.011  63.543
+54.235.96.196   66.228.35.252    3 u    9  128  377  646.226   10.317 109.588
+173.208.234.242 206.209.110.2    3 u  122  128  377  602.659    5.351  89.560
By the way, please enclose your logs and commands in code blocks, much easier to read.

Hope this helps some.
 
Old 05-01-2014, 01:37 PM   #36
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
Both these files were already in UTC
/etc/adjtime:UTC
/etc/hardwareclock:UTC




Never set clock before, but I did now:
# /etc/rc.d/rc.ntpd stop
Stopping NTP daemon...
bash-4.2# ntpd -b -g -q
ntpd: time slew +0.000000s
bash-4.2# /etc/rc.d/rc.ntpd start
Starting NTP daemon: /usr/sbin/ntpd -g
bash-4.2#

# cat /var/log/ntp.log
1 May 10:03:45 ntpd[1881]: LOCAL(0) 8011 81 mobilize assoc 56361
1 May 10:03:46 ntpd[1881]: 206.186.121.125 8011 81 mobilize assoc 56362
1 May 10:03:47 ntpd[1881]: 142.137.247.109 8011 81 mobilize assoc 56363
1 May 10:03:48 ntpd[1881]: 208.80.96.70 8011 81 mobilize assoc 56364
1 May 10:03:48 ntpd[1881]: 0.0.0.0 c016 06 restart
1 May 10:03:48 ntpd[1881]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 10:03:48 ntpd[1881]: 0.0.0.0 c011 01 freq_not_set
1 May 10:03:49 ntpd[1881]: LOCAL(0) 8024 84 reachable
1 May 10:03:49 ntpd[1881]: LOCAL(0) 903a 8a sys_peer
1 May 10:03:49 ntpd[1881]: ntpd: time slew +0.000000 s
1 May 10:04:38 ntpd[1894]: LOCAL(0) 8011 81 mobilize assoc 26992
1 May 10:04:38 ntpd[1894]: 206.186.121.125 8011 81 mobilize assoc 26993
1 May 10:04:38 ntpd[1894]: 142.137.247.109 8011 81 mobilize assoc 26994
1 May 10:04:38 ntpd[1894]: 208.80.96.70 8011 81 mobilize assoc 26995
1 May 10:04:38 ntpd[1894]: 0.0.0.0 c016 06 restart
1 May 10:04:38 ntpd[1894]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 10:04:38 ntpd[1894]: 0.0.0.0 c011 01 freq_not_set
1 May 10:04:39 ntpd[1894]: LOCAL(0) 8024 84 reachable
1 May 10:04:39 ntpd[1894]: LOCAL(0) 903a 8a sys_peer
1 May 10:04:39 ntpd[1894]: 0.0.0.0 c514 04 freq_mode
1 May 10:20:39 ntpd[1894]: 0.0.0.0 0512 02 freq_set kernel 0.000 PPM
1 May 10:20:39 ntpd[1894]: 0.0.0.0 0515 05 clock_sync
1 May 10:33:21 ntpd[1894]: ntpd exiting on signal 1
1 May 10:33:22 ntpd[2338]: LOCAL(0) 8011 81 mobilize assoc 50859
1 May 10:33:23 ntpd[2338]: 198.27.65.66 8011 81 mobilize assoc 50860
1 May 10:33:24 ntpd[2338]: 206.108.0.131 8011 81 mobilize assoc 50861
1 May 10:33:25 ntpd[2338]: 205.204.93.138 8011 81 mobilize assoc 50862
1 May 10:33:25 ntpd[2338]: 0.0.0.0 c016 06 restart
1 May 10:33:25 ntpd[2338]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 10:33:25 ntpd[2338]: 0.0.0.0 c011 01 freq_not_set
1 May 10:33:25 ntpd[2338]: LOCAL(0) 8024 84 reachable
1 May 10:33:25 ntpd[2338]: LOCAL(0) 903a 8a sys_peer
1 May 10:33:25 ntpd[2338]: 0.0.0.0 c514 04 freq_mode
1 May 10:49:01 ntpd[2338]: ntpd exiting on signal 15
1 May 10:50:09 ntpd[1209]: LOCAL(0) 8011 81 mobilize assoc 46459
1 May 10:50:10 ntpd[1209]: 67.215.197.149 8011 81 mobilize assoc 46460
1 May 10:50:10 ntpd[1209]: 24.87.64.125 8011 81 mobilize assoc 46461
1 May 10:50:11 ntpd[1209]: 72.38.129.202 8011 81 mobilize assoc 46462
1 May 10:50:11 ntpd[1209]: 0.0.0.0 c016 06 restart
1 May 10:50:11 ntpd[1209]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 10:50:11 ntpd[1209]: 0.0.0.0 c011 01 freq_not_set
1 May 10:50:12 ntpd[1209]: LOCAL(0) 8024 84 reachable
1 May 10:50:12 ntpd[1209]: LOCAL(0) 903a 8a sys_peer
1 May 10:50:12 ntpd[1209]: 0.0.0.0 c514 04 freq_mode
1 May 10:56:14 ntpd[1209]: ntpd exiting on signal 1
1 May 10:57:10 ntpd[1714]: LOCAL(0) 8011 81 mobilize assoc 40429
1 May 10:57:11 ntpd[1714]: 67.215.197.151 8011 81 mobilize assoc 40430
1 May 10:57:12 ntpd[1714]: 206.108.0.131 8011 81 mobilize assoc 40431
1 May 10:57:13 ntpd[1714]: 192.95.20.208 8011 81 mobilize assoc 40432
1 May 10:57:13 ntpd[1714]: 0.0.0.0 c016 06 restart
1 May 10:57:13 ntpd[1714]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 10:57:13 ntpd[1714]: LOCAL(0) 8024 84 reachable
1 May 10:57:13 ntpd[1714]: LOCAL(0) 903a 8a sys_peer
1 May 10:57:13 ntpd[1714]: 0.0.0.0 c515 05 clock_sync
1 May 13:30:22 ntpd[1714]: ntpd exiting on signal 1
1 May 13:30:34 ntpd[4436]: LOCAL(0) 8011 81 mobilize assoc 25462
1 May 13:30:36 ntpd[4436]: 208.80.96.70 8011 81 mobilize assoc 25463
1 May 13:30:37 ntpd[4436]: 199.85.124.148 8011 81 mobilize assoc 25464
1 May 13:30:37 ntpd[4436]: 199.182.221.110 8011 81 mobilize assoc 25465
1 May 13:30:37 ntpd[4436]: 0.0.0.0 c016 06 restart
1 May 13:30:37 ntpd[4436]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 13:30:38 ntpd[4436]: LOCAL(0) 8024 84 reachable
1 May 13:30:38 ntpd[4436]: LOCAL(0) 903a 8a sys_peer
1 May 13:30:38 ntpd[4436]: ntpd: time slew +0.000000 s
1 May 13:31:11 ntpd[4448]: LOCAL(0) 8011 81 mobilize assoc 40671
1 May 13:31:11 ntpd[4448]: 208.80.96.70 8011 81 mobilize assoc 40672
1 May 13:31:11 ntpd[4448]: 199.85.124.148 8011 81 mobilize assoc 40673
1 May 13:31:11 ntpd[4448]: 199.182.221.110 8011 81 mobilize assoc 40674
1 May 13:31:11 ntpd[4448]: 0.0.0.0 c016 06 restart
1 May 13:31:11 ntpd[4448]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 13:31:12 ntpd[4448]: LOCAL(0) 8024 84 reachable
1 May 13:31:12 ntpd[4448]: LOCAL(0) 903a 8a sys_peer
1 May 13:31:12 ntpd[4448]: 0.0.0.0 c515 05 clock_sync
bash-4.2#

So nothing changes.
Long time since I knew how to put stuff in code blocks, instructions must be here somewhere?

Last edited by WilliamS; 05-01-2014 at 01:40 PM.
 
Old 05-01-2014, 02:56 PM   #37
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
Code blocks are, on a new line a left bracket ([), the string code, and a right bracket (]) to start. To stop a code block, on a new line, a left bracket ([), a slash (/), the string code, and a right bracket (]). The string can be either code or CODE. It's similar to what "wrap [QUOTE] tags around select text," that yellow-page symbol at the top of the reply window. The tags, code or QUOTE, don't have to be on a new line, but it's a little easier to paste select text that way (for me, maybe not for you, do what you're comfortable with).

Looking at your log entries, it looks like you are getting synchronized to LOCAL (lines like these):
Code:
1 May 13:30:37 ntpd[4436]: 0.0.0.0 c016 06 restart
1 May 13:30:37 ntpd[4436]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 13:30:38 ntpd[4436]: LOCAL(0) 8024 84 reachable
1 May 13:30:38 ntpd[4436]: LOCAL(0) 903a 8a sys_peer
1 May 13:30:38 ntpd[4436]: ntpd: time slew +0.000000 s
1 May 13:31:11 ntpd[4448]: LOCAL(0) 8011 81 mobilize assoc 40671
1 May 13:31:11 ntpd[4448]: 208.80.96.70 8011 81 mobilize assoc 40672
1 May 13:31:11 ntpd[4448]: 199.85.124.148 8011 81 mobilize assoc 40673
1 May 13:31:11 ntpd[4448]: 199.182.221.110 8011 81 mobilize assoc 40674
1 May 13:31:11 ntpd[4448]: 0.0.0.0 c016 06 restart
1 May 13:31:11 ntpd[4448]: 0.0.0.0 c012 02 freq_set kernel 0.000 PPM
1 May 13:31:12 ntpd[4448]: LOCAL(0) 8024 84 reachable
1 May 13:31:12 ntpd[4448]: LOCAL(0) 903a 8a sys_peer
1 May 13:31:12 ntpd[4448]: 0.0.0.0 c515 05 clock_sync
It also looks like you reset the clock (with ntpd -b -g -q) each time you stopped it -- don't really need to do that every time.

Now, what you should be seeing is this:
Code:
1 May 11:27:17 ntpd[20263]: 0.0.0.0 c016 06 restart
 1 May 11:27:17 ntpd[20263]: 0.0.0.0 c012 02 freq_set kernel -19.244 PPM
 1 May 11:27:18 ntpd[20263]: LOCAL(0) 8024 84 reachable
 1 May 11:27:18 ntpd[20263]: LOCAL(0) 903a 8a sys_peer
 1 May 11:27:18 ntpd[20263]: 0.0.0.0 c515 05 clock_sync
 1 May 11:27:20 ntpd[20263]: 142.54.185.82 8024 84 reachable
 1 May 11:27:21 ntpd[20263]: 54.235.96.196 8024 84 reachable
 1 May 11:27:21 ntpd[20263]: 173.208.234.242 8024 84 reachable
 1 May 11:30:37 ntpd[20263]: 173.208.234.242 903a 8a sys_peer
 1 May 11:31:40 ntpd[20263]: 54.235.96.196 943a 8a sys_peer
 1 May 11:32:48 ntpd[20263]: 173.208.234.242 941a 8a sys_peer
 1 May 11:39:02 ntpd[20263]: LOCAL(0) 8043 83 unreachable
You're not seeing these lines in the log:
Code:
 1 May 11:27:18 ntpd[20263]: LOCAL(0) 903a 8a sys_peer
 1 May 11:27:18 ntpd[20263]: 0.0.0.0 c515 05 clock_sync
 1 May 11:27:20 ntpd[20263]: 142.54.185.82 8024 84 reachable
 1 May 11:27:21 ntpd[20263]: 54.235.96.196 8024 84 reachable
 1 May 11:27:21 ntpd[20263]: 173.208.234.242 8024 84 reachable
 1 May 11:30:37 ntpd[20263]: 173.208.234.242 903a 8a sys_peer
 1 May 11:31:40 ntpd[20263]: 54.235.96.196 943a 8a sys_peer
 1 May 11:32:48 ntpd[20263]: 173.208.234.242 941a 8a sys_peer
 1 May 11:39:02 ntpd[20263]: LOCAL(0) 8043 83 unreachable
Don't pay any attention to the addresses in the above, they're from my system log.

What does
Code:
ntpq -pn
show you? Do you see .LOCL. and three numeric addresses? Perhaps, leaving the NTP daemon running for now, do that and post the output, please.

What do these two commands show you:
Code:
date
hwclock -r
date shows the system clock time (the software clock), hwclock -r show you the hardware clock time. The output will look like this:'
Code:
date
Thu May  1 14:52:11 EDT 2014
hwclock -r
Thu 01 May 2014 02:52:42 PM EDT  -0.256338 seconds
Yeah, one's in 24-hour and the other is in 12-hour but don't worry about that -- are they the same time?
 
Old 05-01-2014, 04:03 PM   #38
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
Code:
# ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*127.127.1.0     .LOCL.          10 l   27   64    1    0.000    0.000   0.000
 206.108.0.132   .INIT.          16 u    -   64    0    0.000    0.000   0.000
 198.50.145.138  .INIT.          16 u    -   64    0    0.000    0.000   0.000
 199.85.124.148  .INIT.          16 u    -   64    0    0.000    0.000   0.000
Looks like a communication problem.

Code:
# date
Thu May  1 15:51:50 EDT 2014
Code:
# hwclock -r
Thu 01 May 2014 03:53:42 PM EDT  -0.203615 seconds


xfce weirdness - permissions mysteriously changed for /etc/rc.d/rc.ntpd so root was denied access. I did a chmod +x and installed shorewall; if I've been listening to audio file and it ends and I don't close the player .txt files have all shown as image files that must be opened with xine, gets nonsense. Trying to open them with kwrite results in nonsense.
There was nothing wrong with the installed setup of time or ntp or anything else, so I think the problem must be elsewhere, and know not what to look for.

Last edited by WilliamS; 05-01-2014 at 04:05 PM.
 
Old 05-01-2014, 06:06 PM   #39
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
It sure does look like a communications problem -- NTP doesn't seem to be able to reach those external time servers. Can you
Code:
ping -c 5 206.108.0.132
There is one other possibility; your hardware clock is too far off for NTP to sync to it. Recall that, when NTP is started, it reads the time from the hardware clock and uses that to set the system clock (and vice-versa on shutdown)? That "too far off" is 1,000 seconds (generally) but can be as little as 5- 6 or so minutes. When you set the clock with ntpd -b -g -q, you're setting the system (software) clock to the correct time and the hardware clock will overwrite that when the daemon starts (dang it).

So, here might be a good test:
  • Stop NTP
  • Set the system clock: ntpq -g -q
  • Check the system clock: date
  • Check the hardware clock: hwclock -r
What is the difference between the two?

And, let's see, Shorwall is a firewall? Do you have to explicitly open ports (like 123)?

All the files in /etc/rc.d are owned and group root.

/etc/rc.d/rc.ntpd is owned and group root and it is executable (as are some, not all, others).

Your might want to
Code:
su -
chown root.root /etc/rc.d/rc.ntpd
chmod 755 /etc/rc.d/rc.ntpd
I do not know anything about Shorewall and don't know why I would want to.

You may want to do the "secret fix" (read: kludge) for Xfce problems. Logged in as you, in your home directory,
Code:
rm -r .cache
Fixes a lot of Xfce weirdness (but don't do it all the time).

Last edited by tronayne; 05-01-2014 at 06:15 PM.
 
Old 05-01-2014, 07:21 PM   #40
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
Code:
# ping -c 5 206.108.0.132
PING 206.108.0.132 (206.108.0.132) 56(84) bytes of data.
64 bytes from 206.108.0.132: icmp_seq=1 ttl=246 time=1316 ms
64 bytes from 206.108.0.132: icmp_seq=2 ttl=246 time=657 ms
64 bytes from 206.108.0.132: icmp_seq=3 ttl=246 time=678 ms
64 bytes from 206.108.0.132: icmp_seq=4 ttl=246 time=668 ms
64 bytes from 206.108.0.132: icmp_seq=5 ttl=246 time=677 ms

--- 206.108.0.132 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3997ms
rtt min/avg/max/mdev = 657.957/799.651/1316.252/258.406 ms, pipe 2

Code:
# date
Thu May  1 19:07:02 EDT 2014
bash-4.2# hwclock -r
Thu 01 May 2014 07:07:06 PM EDT  -0.719191 seconds
so there is no significant difference between clocks.

I'm used to the look of ntp in gkrellm/eth0 when it is working right, and this looks like ntpd is sending a command that gets no reply from server(s), except for when ntpd is first started.
 
Old 05-02-2014, 07:51 AM   #41
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
So, when you ran date and hwclock it was 19:07, yet the time stamp on your post is 19:21, a 14 minute difference (which may be significant). NTP probably won't initialize with that much difference, and it may explain why your don't see any refid in the ntpq -pn display. Might want to do
  • date
  • hwclock -r
and post it immediately just to see.

Just for grins, how are you connected to your satellite interface box? I mean, you're using a wi-fi connection, is that provided by the interface or is there a box connected to the Ethernet port on the interface? If so, can you look at settings in the wi-fi gadget?

I'm asking because routers (and, possibly wi-fi) don't always pass every port and you have to enable the one's you want (I have to in my Linksys router). If the gadget (if there is one) is not passing port 123 UDP, that's going to be the problem.

The other potential problem is if your network connections are defaulting to IPv-6. But I don't know how to determine that (gotta do some looking-up).
 
Old 05-02-2014, 08:42 AM   #42
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
I can't see that ntp could know or care when I post results of shell commands?

No wifi here, just cable through a modem.
 
Old 05-02-2014, 09:55 AM   #43
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by mlslk31 View Post
Just curious, WilliamS, does CHU come in loud and clear on any of 3330, 7850, or 14670 kHz? You had some coordinates in your info, and they seemed rather close to the CHU transmitters in Ottawa...just didn't know if you were in CHU's skip zone. I use CHU here in Florida when WWV has propagation issues.
Regret late reply -- yes, I am too close to CHU transmitters to hear it clearly.
 
Old 05-03-2014, 11:25 AM   #44
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,146

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
Quote:
Originally Posted by WilliamS View Post
I can't see that ntp could know or care when I post results of shell commands?
Nothing to do with NTP, has to do with whether your hardware clock is close enough to the correct time for NTP to synchronize (recall that when the system starts the system time is initialized from the hardware clock). The only reason I questioned was the time difference from your running date and hwclock to the time-stamp on the post. Sorry if there was any confusion.

Something you may want to check is boot your system into the BIOS and check that the time is correct referenced to CHU, WWV or whatever time service. If I remember correctly those radio broadcasts are UTC and that's what your hardware clock should be set to. What the heck, can't hurt to check it just in case.
Quote:
Originally Posted by WilliamS View Post
No wifi here, just cable through a modem.
If you can get to the modem control panel and check to see if port 123 UDP is being passed or blocked. From all the ntpq displays it looks like that is the problem; you're not seeing the time transmission from the pool servers.

Do you have a IPTABLES or some other form of firewall running? Is there any settings having to do with port 123 UPD?
 
Old 05-03-2014, 12:02 PM   #45
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Original Poster
Rep: Reputation: 31
Never referenced time to WWV or CHU, just set it during installation of the OS and no problems.

I have no access to the modem control.

nmap scan of port 123 shows as it should be, same as before.
I found a macro for ntp in my firewall and enabled it to make sure that port is working; no difference in anything detected.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP client is not syncing to ntp server LittleMaster Linux - Newbie 6 04-05-2013 03:37 PM
[SOLVED] NTP configuration in client to synchronize with NTP server. antnish Linux - General 12 04-01-2013 02:49 PM
ntp drift file in /etc/ntp instead of /var/lib/ntp - suggestion for a patch in Slack niels.horn Slackware 16 05-07-2009 08:35 PM
ntp problem,,, Anmar Linux - Software 0 03-26-2004 11:35 AM
ntp problem ? virtaava Linux - Newbie 0 10-09-2001 06:27 AM


All times are GMT -5. The time now is 11:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration