-   Slackware (
-   -   ntfs problem with Slackware 14.0 (

SlackInstalled 10-18-2012 12:09 PM

ntfs problem with Slackware 14.0
I have a problem in Slackware 14.0 with acessing my ntfs partitionon on a dual boot system from the windows manager (either KdE or Xfce)
This partition is accessible from windows without any problems. chkdsk marks the partition as without errors
In Slackware 14.0 partition is mounted in my fstab
Accessing the partition and browsing directories and files is no problem from the console with no windows manager running.
However when starting the windows manager and browsing through the partition through a file manager the file manager locks and
then backing out of the windows manager to the console prevents me accessing the partition again. (System is giving boot sector error etc, but we all know that system messages are most of the time reporting an other problem then the real one)
I tested Slacko (the Puppy Linux variant based on Slackware 13) and in Slacko I have no problem at all when using the windows manager to access the ntfs partition. Since the partition is properly mounted an acessible in the console, I don't think it is udev related.
I am expecting that it is either a problem with dbus or with policykit. Since I have no experience with either I am hoping for an answer from anyone who has and can give me directions to find the problem.

/dev/random 10-18-2012 03:50 PM

Hi SlackInstalled,
Which ntfs driver are you using?
The stock kernel driver or the ntfs-3g driver?

SlackInstalled 10-18-2012 04:08 PM

ntfs driver
I started with using the ntfs-3g driver, but also tested Slackware 14.0 with the kernel ntfs driver.
Both drivers are giving me the same problem

beder 10-18-2012 06:46 PM

I'm sorry posted on the wrong thread

/dev/random 10-19-2012 09:30 AM

Try using the ntfs-3g driver and do a reboot, KDE and all these wonderful DE's use dbus, (if dbus is unaware of the change then it will still deny you access)

SlackInstalled 10-20-2012 04:39 AM

ntfs problem
Hi dev/random

As stated before, i tried both drivers, the ntfs-3g driver and the kernel ntfs driver and rebooted the system.
No result whatsoever.
By the way, I tested Slackware 13.1 and in 13.1 there is no problem at all.
Will today also test Slackware 13.37 in order to see if the regression occured there or that it only 14.0 related


SlackInstalled 10-20-2012 05:18 AM

ntfs problem

For anyone who whants to know :

I tested Slackware 13.37 and Slackware 13.37 has the same problem as Slackware 14.0
So it seems that my ntfs regression occured beginning with the 13.37 release
Have now to investigate what major differences there are between the 13.1 and 13.37 release


Alien Bob 10-20-2012 04:50 PM

During Slackware installation, you are giving a selection of choices in the way you are going to make your NTFS partition accessible.



Because users could go snooping through (or destroy, depending on
the settings) your Windows partition, you should choose how much access would you
like your non-root users to have to partition /xxxxxx.  The access level can
range from no access at all, to read-only for everyone, to read-write access
for every user on the machine.  A reasonable default (read-write for root only)
is chosen, but you may set this any way that you like.

You get the following choices, note that the driver which is going to be used is mentioned at the end. The mount options which are going to be added to "/etc/fstab" are shown at the beginning of the below lines.
You do not see that in the setup dialog while you are installing, but I left them in for informational purposes:

"fmask=177,dmask=077" "Root has read/write access, users have no access (ntfs-3g)"
"fmask=333,dmask=222" "Everyone has read only access (built-in kernel ntfs driver)"
"fmask=133,dmask=022" "Everyone has read access, but only root can write (ntfs-3g)"
"fmask=111,dmask=000" "All users can read/write to any file (ntfs-3g)"

Can you post the line in /etc/fstab which you had for that NTFS partition while your were experiencing these issues? I run Slackware 14 on this computer in the living room which has a Windows7 partition for the rest of the family and I can browse, read and write to the NTFS partition, even from a graphical filemanager like Dolphin (I run KDE) without problems.

Please give more details about your installation. What Desktop Environment are you using, do you have a full Slackware installation, are you booting in runlevel 3 or 4?


SlackInstalled 10-20-2012 05:52 PM

During installation I made the following choice

"fmask=111,dmask=000" "All users can read/write to any file (ntfs-3g)

This resulted in the following line in my fstab file

/dev/sdb1 /Data ntfs-3g fmask=111,dmask=000 1 0

I prefer the KDE desktop and that is what I currently are testing with
However I also tested with Xfce and had the same problem.
The problem occurs both with Dolphin and Konquerer
The installation was the full installation with no additional packages selected (eg cups etc)
For the time being I am only using runlevel 3, but to make sure had already tested also with runlevel 4.
With runlevel 4 I have the same problem

What is strange is that when I am using Dolphin in Slackware 13.1 (Where everything works normal), my ntfs partiton shows only up as /Data in the Dolphin window, while in 14.0 it shows up as both the /Data mount point and also as a disk drive in the left pane of Dolphin. (just as if Dolphin did not recognize that it was already mounted)


TommyC7 10-20-2012 06:32 PM

Does using ntfs-3g manually work successfully?


ntfs-3g /dev/WINDOWS_PARTITION /mnt/hd
Perhaps if it doesn't, it may give us some clues.

allend 10-20-2012 09:16 PM


The installation was the full installation with no additional packages selected (eg cups etc)
CUPS is part of the 'a' package series, as is the ntfs-3g package.
What is the output of 'ls /var/log/packages | grep ntfs'?
You should see 'ntfs-3g-2012.1.15-x86_64-2' on a 64bit system.

sse007 10-20-2012 10:13 PM

you have problem with file managers, what about from a terminal like xterm or konsole ? can you access /Data that way at all ? also when you do ls -l /Data, who is the owner of the directory ? It might not make a difference but if the owner is root:root , you can mount it with your uid and gid as owner to see if that make any difference.

SlackInstalled 10-21-2012 03:06 AM

Does using ntfs-3g manually work successfully?

No, it gives me the same problems


SlackInstalled 10-21-2012 03:08 AM

What is the output of 'ls /var/log/packages | grep ntfs'?

bash-4.2# ls -l /var/log/packages |grep ntfs
-rw-r--r-- 1 root root 3257 Oct 20 01:16 ntfs-3g-2012.1.15-i486-2


SlackInstalled 10-21-2012 03:09 AM

What about from a terminal like xterm or konsole ?

Trying to access the partition within Konsole gives the same problems


All times are GMT -5. The time now is 11:12 AM.