-   Slackware (
-   -   nss_ldap not working (getent passwd) (OT, closed) (

nokia3310 05-02-2013 05:06 PM

nss_ldap not working (getent passwd) (OT, closed)

Originally Posted by WindowBreaker (Post 2309506)
Output from:

cat /etc/ldap.conf | grep -v "^#" |grep -v "^$"

Output from:

cat /etc/openldap/ldap.conf | grep -v "^#" |grep -v "^$"

I did:

./configure --prefix=/etc --sysconfdir=/etc --localstatedir=/var
make DESTDIR=/tmp/package/nss_ldap install
cd /tmp/package/nss_ldap
mkdir install
cat << EOF > install/slack-desc
makepkg -l y -c n /tmp/nss_ldap-2.51-noarch-1pjg.tgz
installpkg /tmp/nss_ldap-2.51-noarch-1pjg.tgz

I have done the exact same procedure on both a desktop running kernel, and a laptop running kernel 2.4.31 . The 'getent passwd' command works perfectly on the desktop. The only problem is with the laptop. I thought maybe it was a problem related to the contents of my directory. So I recreated the laptop's directory using an LDIF file will all entries from the desktop, still not working. I've tried comparing everything I can between the two (config files mainly), and can't tell why the desktop works, and the laptop doesn't.

I had to compile/create a slackpack for OpenLDAP on the laptop, as the one built on a 2.6 kernel (desktop) wouldn't work due to the 2.4 kernel lacking the 'epoll' function. But that was done before I did anything else. And just in case, I also compiled nss_ldap on the laptop also.

I have said it before and i'll say it again..Linux is not a consistent OS..period

unSpawn 05-02-2013 07:21 PM

Frustrated you may be but that itself is not a valid reason for expressing it, let alone in a completely unrelated thread. Do not do that again.

All times are GMT -5. The time now is 05:51 PM.