LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Now that it starts, what do I do???? (https://www.linuxquestions.org/questions/slackware-14/now-that-it-starts-what-do-i-do-132916/)

Sociologo 01-08-2004 09:58 PM

Now that it starts, what do I do????
 
I have just installed Slackware 9.1 and it actually boots from LILO (this is after 8-10 trials). I am a complete Slacknewbie. What do I do now? It prompts me with "Dark....(i forget):#" and I enter "root" and "password". Then I don't know what to do? So, I try to be "cool" and I type "startx" (I saw this somewhere"), and I get black monitor syndrome. Nada! I tried evoking the 'man" only to get nothin that would help me.

I wanted to go to KDE or Gnome, both of which are installed. So I tried "kdeinit" (I deduced this somehow). Nothing. Well, I won't bore you. I just want to get to a desktop where I can begin to work with Slackware, which I have heard and read is excellent.

Please help this Slacknewbie.
Thanks.

Tinkster 01-08-2004 10:04 PM

How about
xf86config
?
Just make sure you know your Monitor specs,
what kind of keyboard and rodent you have, and
of course, some details about your praphics card :}


Cheers,
Tink





Cheers,
Tink

Sociologo 01-08-2004 10:13 PM

Thanks Tinkster:
I'm going to try that right now.

Astro 01-08-2004 10:20 PM

running /usr/X11R6/xfree86config should auto config your stuff for you...thats what I do on my laptop.

Tinkster 01-08-2004 10:36 PM

That's xfree86setup, mate :}

And I found it less reliable than the manual
configuration, but then that's just me ;)


Cheers,
Tink

Astro 01-08-2004 11:21 PM

eeeh close enough with a simple ls they would have found the right one. I find it works just fine for me and my roommates pc's

itsjustme 01-09-2004 02:00 AM

Quote:

Originally posted by Tinkster
...some details about your praphics card :}
Cheers,
Tink

Sociologo.. Once you tell us what praphics card you are using, we need to know what your /etc/X11/XF86Config phile looks like. :D

Also, when you installed, what were your options/selections for your video stuff?

I don't think you want to actually type 'kdeinit'.

If you can do root and password, you should then do 'adduser -m myname' and work from that account.

Whitehat 01-09-2004 02:09 AM

As everyoen else said:

Run xf86config to configure X with your monitor, vid card etc....

But also......Check out www.monitorworld.com to look up your monitor's horizontal and vertical sync rates. They have amost every monitor ever made :)

Peace,
Whitehat :)

Sociologo 01-09-2004 08:08 AM

Well. I used the xf86config command. I must have done this 20 times--each time, I think, writing over the previous file. I kept getting errors even when I knew I had entered the correct information for my monitor (right out of the manufacturer's specifications--Dell 1800FP) and the correct video adapter NVIDIA GeForce and its specfications. Once, video did come on, but the graphics were huge--like 256's--so big that there was just enough space for a few words on the screen. I managed to find the logoff button, get out, reboot, and tried to config again. Nothing ever happened after that.

Questions: Did I actually successfully overwrite the config file (Slack told me yes after I asked it to)? Is there a way to delete the current video setting from the file and try again on a clean slate? Should I reinstall Slack all over again? I'm finding out that Slack is not very friendly to those who have never made it's acquaintance before.

Your advice would be appreciated.
Thanks.:newbie:

pbhj 01-09-2004 09:58 AM

It appears that you're issue is with the default resolution used, look at the /etc/X11/xf86config file (it's a while since I did this, might not be the exact name) with your fave editor (I use nano, but it's not standard, try "pico /path/to/file/fileName").

You'll find a lot of lines relating to different resolutions, try commenting them out with some #'s. Then save the file and retry startx-ing (or startkde-ing or whatever).

Alternatively try ctrl-alt-[numpad+] and ctrl-alt-[numpad-] to switch between video modes whilst using X.

I also needed to use "xvditune" (type alt-f2 to get the 'run command' box when in X and type it in) to set the placement of the screen correctly (make sure the 'auto' option is on otherwise it doesn't update as you change the H or V position), then click "apply" or "show" and it outputs the modeline to /var/log/messages or /var/log/xf86* and you need to copy the modeline to the relevant place in your xf86config file.

HTH

Sociologo 01-09-2004 12:16 PM

Thanks folks for your suggestions. I managed to get on the web (I'm writing from Slackware right now). That is an accomplishment I think, thanks to your help.

Now I don't have sound. Tried alsamixer but I don't know whether I did the right thing. All the bars were "off", i moved the cursor with the arrow keys and hit "M" (don't ask me why), and the off was changed. I saved the whole thing with "alsactl store", but still no sound. By the way I did not get the Alsa Warning I was getting before. I also don't know how to mount my CD/DVD Rom to play CDs.

Your help will be appreciated.
Thanks again.

George666 01-09-2004 02:33 PM

Try alsaconf to configure your sound card , it should detect it.

btw the M in alsamixer is to mute/unmute a channel

Sociologo 01-09-2004 02:48 PM

Thanks. However, alsaconfig is not found.

Texicle 01-09-2004 03:46 PM

Quote:

Originally posted by Sociologo
Thanks. However, alsaconfig is not found.
that could be the problem:

alsaconf

not

alsaconfig.

:)


All times are GMT -5. The time now is 01:41 AM.