-   Slackware (
-   -   Novatel USB760 CDMA Modem on Slackware64-13.1 (

rgm1960 12-29-2010 06:01 PM

Novatel USB760 CDMA Modem on Slackware64-13.1
I am able to set up this modem on Ubuntu and Fedora but cannot get it to work on Slackware. I have tried many configurations, all with no success. Any suggestions would be appreciated. Thanks.

Ramurd 12-31-2010 04:58 AM

Have you tried google? Or searching these forums?

Since, when I did I came across this thread:

rgm1960 01-03-2011 01:48 PM

Yes, I searched Google and this forum before I posted my thread. That *is why* I posted here. This solution still does not work.

allend 01-03-2011 08:37 PM

My holiday project is trying to get a Huawei E160E modem working using pppd directly as I am having problems with kppp.
I have found this script suggested on the USB_Modeswitch site.
Try downloading the "All architects - Binary free version", extracting it and running it with ./sakis3g.
This gave me a connection.

rgm1960 01-04-2011 11:43 AM

Thanks allend. I will give this a try. :-)

allend 01-05-2011 07:46 AM

Just got this Huawei E160E working with pppd. Happy holidays, no more surfing in IE!
In case any Google hits get here.
As root, I run

/usr/sbin/pppd /dev/ttyUSB0 460800 modem crtscts defaultroute noipdefault usepeerdns ktune noauth lock nobsdcomp novj connect "/usr/sbin/chat -v -f /root/Desktop/chat2.txt"
where /root/Desktop/chat2.txt contains

# chat script for Huawei E160E HSDPA USB stick with Optus prepaid mobile internet
# Developed from sakis3g script
'' 'ATZ'
OK 'ATQ0 V1 E1'
OK 'AT&D2 &C1'
OK 'ATS0=0'
# "preconnect" is APN for Optus prepaid; "internet" is APN for Optus postpaid
OK 'AT+CGDCONT=1,"IP","preconnect"'
OK 'ATDT*99#'
Just need to remember to update /etc/resolv.conf with the contents of /etc/ppp/resolv.conf on initial connection and ensure that /etc/ppp/ip-pre-up is a symlink to a suitable firewall.

All times are GMT -5. The time now is 06:11 PM.