LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-22-2017, 10:46 AM   #1
khronosschoty
Member
 
Registered: Jul 2008
Distribution: Slackware
Posts: 471
Blog Entries: 2

Rep: Reputation: 291Reputation: 291Reputation: 291
Not everything has access to "HDA Intel PCH"


vlc fails to find it. dolphin-emu fails to use it. Can only have one audio stream going. I'm guessing I need some kind of config file to resolve this but I have no idea what.
 
Old 07-22-2017, 01:18 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 11,653

Rep: Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361Reputation: 1361
Guess that might be true. But nobody knows what you have, what you're using as a sound server, any efforts you made etc etc. Tell us all.
 
1 members found this post helpful.
Old 07-22-2017, 06:55 PM   #3
khronosschoty
Member
 
Registered: Jul 2008
Distribution: Slackware
Posts: 471

Original Poster
Blog Entries: 2

Rep: Reputation: 291Reputation: 291Reputation: 291
here is output from aplay -l

Quote:
root@darkstar:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC233 Analog [ALC233 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

here is the output from lsmod | grep snd


Quote:
root@darkstar:~# lsmod | grep snd
snd_seq_dummy 1826 0
snd_seq_oss 29158 0
snd_seq_midi_event 6848 1 snd_seq_oss
snd_seq 51789 5 snd_seq_midi_event,snd_seq_dummy,snd_seq_oss
snd_seq_device 4481 2 snd_seq,snd_seq_oss
snd_pcm_oss 37807 0
snd_mixer_oss 14746 3 snd_pcm_oss
snd_hda_codec_hdmi 36101 1
snd_hda_codec_realtek 73708 1
snd_hda_codec_generic 60661 1 snd_hda_codec_realtek
snd_hda_intel 29482 4
snd_hda_codec 109389 4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core 65732 5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep 6784 1 snd_hda_codec
snd_pcm 93110 5 snd_pcm_oss,snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_timer 22357 2 snd_seq,snd_pcm
snd 69819 16 snd_pcm_oss,snd_hda_intel,snd_hwdep,snd_mixer_oss,snd_seq,snd_hda_codec,snd_timer,snd_hda_codec_hdmi ,snd_hda_codec_generic,snd_seq_device,snd_seq_oss,snd_pcm
soundcore 6940 3 snd
I have in my /etc/profile export ALSA_CARD=PCH
but I have removed that line and tested and nothing. I also tried export ALSA_CARD=ALC233 because I'm not sure what should be there, I only have a foggy idea of how that works. I tried to black list snd_hda_intel but that just prevents all audio. I had this same issue on a dell I returned and I did "export ALSA_CARD=Generic" which resolved the issue. I'm almost certain the issue is of the same kind but not able to figure out how to resolve it using the same method. I am on Slackware64-current. I have pulse removed and would rather it stay removed. I've had this setup working on the dell and on a macbook pro in the past.
 
Old 07-22-2017, 10:13 PM   #4
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
Hi create .asoundrc since you are a slacker you can read
https://docs.slackware.com/howtos:ha...s_on_slackware

suggestion is

Quote:
pcm.!default {
type hw
card 0
device 0
}

ctl.!default {
type hw
card 0
device 0
}
you will noticed you need card 0 device 0
 
1 members found this post helpful.
Old 07-23-2017, 05:36 AM   #5
55020
Senior Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 1,307
Blog Entries: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by khronosschoty View Post
here is output from aplay -l
This is *exactly* the same as the lappy I'm using right now, and everything Just Works For Me™ out of the box with 14.2's pulseaudio-enabled setup. I would humbly suggest that whatever you've done to de-pulse your system has had no upside and a very big downside.
 
3 members found this post helpful.
Old 07-23-2017, 06:51 PM   #6
khronosschoty
Member
 
Registered: Jul 2008
Distribution: Slackware
Posts: 471

Original Poster
Blog Entries: 2

Rep: Reputation: 291Reputation: 291Reputation: 291
Quote:
Originally Posted by 55020 View Post
This is *exactly* the same as the lappy I'm using right now, and everything Just Works For Me™ out of the box with 14.2's pulseaudio-enabled setup. I would humbly suggest that whatever you've done to de-pulse your system has had no upside and a very big downside.
Reinstalling pulse does indeed resolve the sound issues; however, I would rather not have pulse on my system to be honest.
 
Old 07-23-2017, 07:01 PM   #7
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
then consider making the pulseaudio daemon not start, assuming it is in /etc/rc.d

Code:
sudo chmod 666 /etc/rc.d/pulseaudio
reboot and test if pulseaudio is running

I am not a slacker so feel free to correct
 
Old 07-23-2017, 07:11 PM   #8
khronosschoty
Member
 
Registered: Jul 2008
Distribution: Slackware
Posts: 471

Original Poster
Blog Entries: 2

Rep: Reputation: 291Reputation: 291Reputation: 291
Quote:
Originally Posted by aus9 View Post
then consider making the pulseaudio daemon not start, assuming it is in /etc/rc.d

Code:
sudo chmod 666 /etc/rc.d/pulseaudio
reboot and test if pulseaudio is running

I am not a slacker so feel free to correct
I had pulse completely removed in my system and working flawless; but this is a new computer, and on this computer its not working (without pulse). The issue has to be resolved via the method you suggested above (not the suggestion I'm quoting, but the one previous that one) or the one found here http://docs.slackware.com/howtos:har..._snd-hda-intel. In the example you gave above the bit about setting device 0 you noted might be enough of a hint for me to figure it out, i have to dig around. As for the case of the latter example, I am not sure yet how to proceed because the default example is not enough.

The above here I wrote is just my current guess.

Last edited by khronosschoty; 07-23-2017 at 07:20 PM.
 
Old 07-23-2017, 09:58 PM   #9
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
if you mean the contents of file for asoundrc in post 4 we need to be blunter?

the slack dox says either create a file that is designed to be system wide, mainly to stop you accidently deleting the dot asoundrc file
or
you have family members you don't want to copy the asoundrc file to.

is that clearer?

if not can you now post the contents of your file

Code:
cat .asoundrc
2) I made the card number and device number based your output at post 3 which was
"card 0: PCH [HDA Intel PCH], device 0: ALC233 Analog [ALC233 Analog]"

3) if your contents is exactly the same as what I suggested in 4, then we can change it to a more simple design

but to save rebooting can you do an extra report as I don't use slack

Code:
sudo su
/etc/rc.d/rc.alsa stop
/etc/rc.d/rc.alsa status
/etc/rc.d/rc.alsa start
if you get an error in the status...alsa still running then the option in making changes to any system wide or local user asound file would be
to log out and login.....if all else fails full reboot

Last edited by aus9; 07-23-2017 at 10:09 PM.
 
Old 07-23-2017, 10:07 PM   #10
khronosschoty
Member
 
Registered: Jul 2008
Distribution: Slackware
Posts: 471

Original Poster
Blog Entries: 2

Rep: Reputation: 291Reputation: 291Reputation: 291
Quote:
Originally Posted by aus9 View Post
if you mean the contents of file for asoundrc in post 4 we need to be blunter?

the slack dox says either create a file that is designed to be system wide, mainly to stop you accidently deleting the dot asoundrc file
or
you have family members you don't want to copy the asoundrc file to.

is that clearer?

if not can you now post the contents of your file

Code:
cat .asoundrc
2) I made the card number and device number based your output at post 3 which was
"card 0: PCH [HDA Intel PCH], device 0: ALC233 Analog [ALC233 Analog]"
I was referring to the suggestion you made in post #4, yes. I don't have a ".asoundrc" and I do not recall ever needing one; at the very least I've have not used one since 2010 (if I used one before that I do not recall or never noticed). I'll give making one an attempt. I did experiment with one when I was trying to fix issues with the dell I returned but failed to to make one that resulted in a fix. That is why I did not even bother to attempt this on the current machine I am on (the machine I am currently having trouble with a pure alsa setup). Since this has only one audio "card",however, it is the default device ( I imagine), that needs defined; hence, when I saw your suggestion I thought it might be worth investigating again.
 
Old 07-23-2017, 10:10 PM   #11
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
yeah I have editted my post while you posted...refresh the page...I won't edit my last reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Intel Core i7-5820K" vs "Intel Xeon E5-2603 V4" for a KVM hypervisor red king Linux - Hardware 7 07-28-2016 02:52 AM
[SOLVED] Slackware14.1/KDE 4.10.5 - No audio playback using HDA Intel PCH. jefsa Slackware 7 01-22-2015 03:23 PM
php "system"-call to access tty port, "error accessing" wedz Linux - Software 3 05-22-2012 07:34 PM
New laptop, no sound. Fedora Core 6, intel-hda-audio ("Azalia") BogusTrumper Linux - Hardware 3 04-17-2007 11:27 AM
"X-MS" cant open because "x-Multimedia System" cant access files at "smb&qu ponchy5 Linux - Networking 0 03-29-2004 11:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration