LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-21-2013, 03:01 PM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,923

Rep: Reputation: 45
Not a trivial question: How do I disable the screen saver (xfce 4.10)?


Slackware 14.0

Hi: I have three times disabled the screen saver, entering Applications Menu>Settings>Screensaver. But during the next DE (Xfce 4.10) session, strange things begin to happen mainly, I cannot move the windows because the top bar in the windows disappear (like the window manager malfunctions). Any workaround? Or is it a known bug? With 12.0 I experienced the same problem, but I solved it by modifying one of the script files. Now the screen saver is started another way.

Last edited by stf92; 01-21-2013 at 06:05 PM.
 
Old 01-22-2013, 12:37 AM   #2
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,001

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
maybe here: http://linuxlibrary.org/xfce-4-screensaver-settings/
 
Old 01-22-2013, 01:01 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,923

Original Poster
Rep: Reputation: 45
pan64, I think there is a previous issue here, I mean logically previous. When exiting the GUI, I get:
Code:
xscreensaver: 03:49:15: Can't open display: :0.0
xscreensaver: 03:49:15: initial effective uid/gid was semoi/shadow (1000/43)
xscreensaver: 03:49:15: running as semoi/semoi (1000/1000)

xscreensaver: 03:49:15: Errors at startup are usually authorization problems.
I read your link, and it's exactly what I've been doing to disable it. Now, as this happened from just after 14.0 install, it is no authorization problem, IMO.
 
Old 01-22-2013, 08:03 PM   #4
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,891

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Those "errors on exiting the GUI" are typical errors when shutting down X. Running processes that depend on X can no longer run, so they throw errors--I've seen messages like that on shutting down X ever since I started using Slackware [mumble] years ago. I've also seen them in Debian since I configured it to boot to the terminal.

I have an idea for testing. Try running xwmconfig from the command line and selecting KDE. Then test in KDE to see if you get similar problems. If you don't, that will isolate the situation to some interaction between xscreensaver and XFCE. If you do, it would seem that something's gone screwy with your xscreensaver.

Another test would be, as root, to create a new user (use the "adduser" script) and test as the new user. If the errors do not occur, that would indicate that something has gone screwy with your user's configuration.
 
Old 01-23-2013, 03:47 AM   #5
saulgoode
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 205

Rep: Reputation: 63
I agree that your question is not trivial; I gave up on xfce after failing to disable the screensaver.

The following link is over a year old, so it may not be relevant:

http://mynixworld.wordpress.com/2011...e-screensaver/
 
1 members found this post helpful.
Old 01-23-2013, 04:40 AM   #6
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,923

Original Poster
Rep: Reputation: 45
In 12.0, the screen saver was launched from /etc/xfce/xdg/xfce4/xinitrc (now /etc/xdg/xfce4/xinitrc). So I just commented out the line. But now GUI related stuff seems to have been shifted towards the Windows kind of thing. Where did we have to deal with unicode characters?!

Thanks for the link and do tell me what DE you use instead of Xfce.
 
Old 01-23-2013, 05:29 AM   #7
saulgoode
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 205

Rep: Reputation: 63
Quote:
Originally Posted by stf92 View Post
Thanks for the link and do tell me what DE you use instead of Xfce.
I have been using UDE, or rather its window manager, UWM, since there really isn't much of a desktop environment. Despite its lack of development -- a refreshing change from the constant flux of KDE, GNOME, and XFCE desktops -- there hasn't been any really need to update it (it is directly based on Xlib).

I was mainly using XFCE on my laptop because UWM makes extensive use of all three mouse buttons and the pad on my laptop doesn't have a middle button. I also was using XFCE on a "headless" server so that I can run X11 across my network.

If you decide to try UWM on Slackware, you should build it from the Subversion repo. The available source tarballs rely upon Texlive being installed.

Last edited by saulgoode; 01-23-2013 at 05:30 AM.
 
Old 01-23-2013, 06:02 AM   #8
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,923

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by saulgoode View Post
I have been using UDE, or rather its window manager, UWM, since there really isn't much of a desktop environment. Despite its lack of development -- a refreshing change from the constant flux of KDE, GNOME, and XFCE desktops -- there hasn't been any really need to update it (it is directly based on Xlib).
I think "constant flux" is an euphemism for "fastidious" (which I really think it is). Thanks for your references.

Last edited by stf92; 01-23-2013 at 04:03 PM.
 
Old 01-23-2013, 07:25 PM   #9
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,923

Original Poster
Rep: Reputation: 45
A partial solution: I turn off the x permission bits in /usr/bin/xscreensaver. The solution is not complete because it does not turn the beam off, but goes to low power state. However,

Code:
semoi@darkstar:/etc$ sudo grep -rl xscreensaver *
X11/app-defaults/XScreenSaver
xdg/autostart/xscreensaver.desktop
xdg/menus/xfce-settings-manager.menu
semoi@darkstar:/etc$
I can study each of these files.

Last edited by stf92; 01-23-2013 at 08:13 PM.
 
Old 01-24-2013, 02:06 PM   #10
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,112

Rep: Reputation: Disabled
Just to end the confusion I started XFCE 4.10 for the first time on my desktop machine (Slackware64-current, I usually run KDE).

I went to "Applications Menu > Settings > Screensaver" and disabled the screensaver, then from the "File" menu chose "Kill Daemon".

Then I went to "Applications Menu > Settings > Session and Startup" and un-checked "Screensaver (launch screensaver and locker program)" in the "Application Autostart" tab.

I waited and waited, and no screensaver kicked in (except the display power saver). I logged off, logged on, waited and waited, still no screensaver.
Problem solved? Was there a problem at all?

THe issues you have been describing during the past weeks stf92 are all so strange and weird that I strongly suspect that the real issue is in your $HOME profile. Do you share your homedirectory with other distros?

Eric
 
Old 01-24-2013, 02:23 PM   #11
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,923

Original Poster
Rep: Reputation: 45
No I'm not, Eric. But I do not have a ~/.xinitrc. Now, see how you had to do three settings. How is a poor Xfce user to guess that "Applications Menu > Settings > Screensaver: disable the screensaver" is not enough? Well, I had already solved the issue by unorthodox means: handled the situation to DPMS (xorg.conf) and screensaver daemon x bit disabled. But of course, I'll now follow your procedure instead. I do not think the problem is going to persist. If it does, I post again. Thanks a lot.

EDIT: Some else, though. When I selected not Disable screensaver but Blank screen, I got the same mess after the following session.It's good to have the blank screen selected because then extend the CRT phosphor life (I have one). So I'm still in the same problem. And every time the mess happened I entirely cleaned ~/ of all hidden files and dirs.

Last edited by stf92; 01-24-2013 at 02:57 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Who starts the screen saver in Xfce 4.10? stf92 Slackware 9 01-18-2013 04:54 PM
how to disable screen-saver angelo_maci Linux - Software 1 05-17-2010 01:03 PM
about disable screen saver andrias DamnSmallLinux 0 04-16-2008 09:22 AM
Cant disable screen saver.. madspikes Linux - General 1 04-13-2007 05:45 AM
disable screen saver? duaux Linux - General 1 09-05-2002 04:19 PM


All times are GMT -5. The time now is 06:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration