LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-20-2005, 07:26 PM   #1
JockVSJock
Senior Member
 
Registered: Jan 2004
Location: SATX
Distribution: RHEL/CentOS
Posts: 1,301
Blog Entries: 4

Rep: Reputation: 148Reputation: 148
Noatun automatically starts up?


Why does Noatun doing this? I played an mp3 with it and then went back to XMMS.

Is there anyway to stop Noatun from automatically starting with KDE?

thanks
 
Old 12-20-2005, 08:26 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.1
Posts: 3,482

Rep: Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545Reputation: 545
Quote:
Why does Noatun doing this? I played an mp3 with it and then went back to XMMS.
Is there anyway to stop Noatun from automatically starting with KDE?
I'm unsure what you mean by starting.

Do you mean noatun opens when you first start KDE? Or do you mean noatun opens when you double-click on an MP3 file?

For the former, look in your user's home directory, in .kde/Autostart and see if there is a noatun.desktop file located there. If so, then delete that file.

For the latter, you need to modify the file association for MP3 files. To do that:

1. Open the KDE Control Center.
2. Expand the KDE Components option.
3. Select the File Associations option.
4. In the Find filename pattern text box, type MP3.
5. In the Known Types list box, the audio file type tree should appear.
6. Expand the audio file type tree.
7. Click once on the x-mp3 file type.
8. At the right side of the Control Center you will see the Application Preference Order in which KDE will try to use various programs to play the MP3 file. The default is noatun.

To modify the default to XMMS,

1. Click once on XMMS.
2. Click repeatedly on the Move Up button until XMMS is at the top of the list.
3. Select the Apply button.
4. Exit the Control Center.

XMMS will now be your default MP3 player.

I hope this helps.
 
Old 12-21-2005, 08:00 AM   #3
JockVSJock
Senior Member
 
Registered: Jan 2004
Location: SATX
Distribution: RHEL/CentOS
Posts: 1,301

Original Poster
Blog Entries: 4

Rep: Reputation: 148Reputation: 148
Quote:
Originally Posted by Woodsman
I'm unsure what you mean by starting.

Do you mean noatun opens when you first start KDE? Or do you mean noatun opens when you double-click on an MP3 file?

For the former, look in your user's home directory, in .kde/Autostart and see if there is a noatun.desktop file located there. If so, then delete that file.
Thanks for the help.

But, I checked .kde/Autostart/ to see if noatun was there, and there wasn't. So I'm not sure why Noatun automatically startsup when I launch KDE.

thanks
 
Old 12-21-2005, 09:02 AM   #4
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Linux Mint 17.1
Posts: 1,424

Rep: Reputation: 138Reputation: 138
If you are using xmms do you need the kde-multimedia package?

I hate noatun so much that I removed the package, but this also gets rid of kaudiocreator (a good program), so I replaced that with grip (and all its dependancies).

Samac
 
Old 12-21-2005, 09:11 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,647

Rep: Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067Reputation: 6067
Noatun will not really exit when you close its window. It will remain running (invisibly) and keep an icon in the system tray. When you log out, KDE will remember that Noatun is still active, and next time you login, it will re-started by KDE.

So, after stopping Noatun, you should really stop it by right-clicking on it's icon in the system tray and selecting quit.

Eric
 
Old 12-21-2005, 05:05 PM   #6
JockVSJock
Senior Member
 
Registered: Jan 2004
Location: SATX
Distribution: RHEL/CentOS
Posts: 1,301

Original Poster
Blog Entries: 4

Rep: Reputation: 148Reputation: 148
Quote:
Originally Posted by Alien Bob
Noatun will not really exit when you close its window. It will remain running (invisibly) and keep an icon in the system tray. When you log out, KDE will remember that Noatun is still active, and next time you login, it will re-started by KDE.

So, after stopping Noatun, you should really stop it by right-clicking on it's icon in the system tray and selecting quit.

Eric
I don't have Noatun running from the system tray...the only way I can run it is from the K Menu, and if I right click on it I don't how I can stop it from starting when I start KDE...
 
Old 12-21-2005, 05:35 PM   #7
netcrawl
Member
 
Registered: Jan 2004
Location: British Columbia
Distribution: Slackware64-current
Posts: 151

Rep: Reputation: Disabled
You might try changing the settings in KDE Control Center-->KDE Components-->Session Manager-->On Login to 'Start with an empty session'
if it's not already, and try restarting KDE.

Hope that helps.
 
Old 12-21-2005, 10:47 PM   #8
JockVSJock
Senior Member
 
Registered: Jan 2004
Location: SATX
Distribution: RHEL/CentOS
Posts: 1,301

Original Poster
Blog Entries: 4

Rep: Reputation: 148Reputation: 148
Quote:
Originally Posted by netcrawl
You might try changing the settings in KDE Control Center-->KDE Components-->Session Manager-->On Login to 'Start with an empty session'
if it's not already, and try restarting KDE.

Hope that helps.
Spot on!

So Starting over with an empty session did the trick.

thanks
 
Old 12-22-2005, 05:55 AM   #9
richcoosa19
Member
 
Registered: Nov 2002
Location: Rome, GA, USA
Distribution: Slackware 10.1 and Gentoo 2005.1 from Stage 1
Posts: 84

Rep: Reputation: 15
Kudos netcrawl you took the words right out of my mouth. The other thing I was going to suggest is the next time you get into KDE get a konsole open and run "killall noatun". This would stop noatun and since it wasn't running when the system shutdown, it will not start back up on reboot. But the other worked better!
 
Old 12-22-2005, 05:45 PM   #10
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current !
Posts: 314

Rep: Reputation: 42
Angry noatun

I changed the name of the executable and made "noatun" a symlink pointing to kaboodle. i don't hate noatun, indeed i think it's nice. but i do hate the way it messes with me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X starts up automatically & other problems kloss Debian 8 12-09-2005 12:17 AM
knode starts automatically?? attila_66 Linux - Newbie 1 10-22-2005 04:50 PM
mozilla starts automatically bm1 Linux - Software 1 08-29-2004 06:10 AM
Run programs automatically when KDE starts koyi Linux - General 2 09-01-2003 06:34 AM
Noatun Starts at Boot Tutilupo Linux - Software 0 08-08-2003 10:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration