-   Slackware (
-   -   no usb keyboard or mouse (

Rita G. 08-08-2013 05:15 PM

no usb keyboard or mouse
slackware current x64 KDE

the installation iso would not 'see' my usb keyboard so i used a PS/2 keyboard.
after 'successful' installation, i am still unable to use usb keyboard or usb mouse.
is there any way to fix this so i can use usb keyboard & mouse?

dugan 08-08-2013 06:19 PM

I had this problem when I disabled "legacy USB support" in the BIOS. Reenabling it fixed it for me.

number22 08-08-2013 10:40 PM

if you still having trouble, add "i8042.noaux" and/or "i8042.nokbd" in append of lilo.conf.

if you can use lsusb to check usb of your keyboard and/or mouse after connection, if you don't see any of them, check if you have /etc/modprobe.d/usb-controller.conf file. The default slackware configuration:

# Make sure that ehci-hcd is always loaded before uhci-hci
# # or ohci-hcd to prevent a kernel warning:
install uhci-hcd /sbin/modprobe ehci-hcd ; /sbin/modprobe -i uhci-hcd
install ohci-hcd /sbin/modprobe ehci-hcd ; /sbin/modprobe -i ohci-hcd

Depending on your motherboard, try add following into your 10-local.rule in /etc/udev/rules.d

SUBSYSTEMS=="input", KERNEL=="input", ATTR{idVendor}=="xxxx", ATTR{idProduct}=="xxxx", DRIVER==""
SUBSYSTEMS=="usb", KERNEL=="input*", ATTR{idVendor}=="xxxx", ATTR{idProduct}=="xxxx", DRIVER=="usbhid"

idVendor "xxxx" is from lsusb after ID xxxx:xxxx; first part is for idVendor, second part is for idProduct. first line for usb keyboard, second line for usb mouse.

Rita G. 08-09-2013 05:10 PM

thank you(s) for replies.

@dugan: all usb options are enabled in BIOS. kbd & mouse work on win7 partition on same computer.

@number22: how do i "add "i8042.noaux" and/or "i8042.nokbd" in append of lilo.conf."?

WhiteWolf1776 08-09-2013 05:47 PM

I'm guessing logitech... and yea, their unifying usb is not working in 3.10... right now it may be due to usb 3 sockets, etc... some folks have had success with moving the dongle to a usb 2 socket.

I put another possible solution here:

It worked for me.

astrogeek 08-09-2013 05:53 PM

FWIW - I just bought one of those yesterday, plugged it into my -current (3.10.5 kernel) on a Phenom II machine and it worked out of the box. Mine is a K400 keyboard w/touchpad - not a K400r.

Additionally, it peacefully coexists with a separate USB keyboard and Logitech mouse on another USB receiver.

I see the above posts refer to USB 3, mine is USB 2.0, Nvidia MCP61. Still ope it is a helpful data point.

Rita G. 08-09-2013 06:28 PM

Thanks again for replies.

Yes...logitech keyboard & mouse.

@ WW1776 : I began your solution, but I cannot access internet! . . and network works perfectly on w7 partition!

WhiteWolf1776 08-09-2013 06:34 PM

If you can get to this site, on any pc...

there are dl links for tarballs of the system.

it's only a few hundred k-bytes. I'm thinking throw it on a thumb drive maybe?

Rita G. 08-09-2013 06:52 PM

i don't have the slightest idea what to do on that page. . . i think this is hopeless; maybe i'll wait a while until they fix these bugs. funny, all my other computers run slackware nicely; this motherboard (GA-990FXA-UD3) probably just doesn't like linux.

WhiteWolf1776 08-09-2013 06:53 PM

under Tag... looks for this:

v0.2 ltunify-0.2.tar.gz

click on the tar.gz.... download it...


tar -xvf ltunify-0.2.tar.gz
then follow the other bits on my post.

this would replace the 'git' command.

All times are GMT -5. The time now is 07:00 AM.