-   Slackware (
-   -   No USB Keyboard on 14.1 default installation (

Habitual 02-13-2014 12:19 PM

No USB Keyboard on 14.1 default installation
So, I have this extra sdb drive installed and I thought "why not" put 14.1 there?
So I did.

I did not choose to install a Boot Loader and maybe I should have.
I have a GigaByte UEFI "DualBIOS" which allows me to install using UEFI or Legacy mode just by selecting either on F12 when I boot.
I chose Legacy mode (eg: a non-"UEFI" booted DVD) and installed to the /dev/sdb drive I partitioned with cdfisk. During the install I chose ext4 as I usually do.

Install went fine. I chose NOT to install [e]LILO to anything, thinking "for now" I'll just dual boot off my working 14.0 lilo.conf.

I made an entry on sda1/etc/lilo.conf using:

  image = /boot/vmlinuz
  root = /dev/sdb1
  label = 14.1

, ran lilo and rebooted.
No keyboard action.

So reading up on possible issues at
I tried this entry in my lilo

image = /boot/vmlinuz-generic-3.10.17
also produced No keyboard action.

There is no numlock, CAPs lock or Scroll lock indicators On/Off action when they are pressed.
I tried 14.1 single during boot and no help there.

I'm now thinking I may need to make an initial ramdisk for the 14.1 environment.

Can anyone confirm this for me or provide some hint as to what I should try/do next?

Thank you,

allend 02-13-2014 06:33 PM


I made an entry on sda1/etc/lilo.conf using image = /boot/vmlinuz
That is pointing to the symlink to the kernel for your 14.0 install.

I would
1. Boot into Slackware 14.0
2. Create a /boot/sdb1 directory
3. Mount /dev/sdb1
4. Copy the vmlinuz-huge-3.10.17 kernel into the /boot/sdb1 directory.
5. Edit lilo.conf so that the 'image =' line points to the copied kernel image

image = /boot/sdb1/vmlinuz-huge-3.10.17
  root = /dev/sdb1
  label = 14.1

6. Run lilo

If you want to change to using the generic kernel, then you will need to add kernel modules for USB HID support to your initrd. Within Slackware 14.1, use the /usr/share/mkinitrd/ script to generate a suitable command.
e.g. 'mkinitrd -c -k 3.10.17 -f ext4 -r /dev/sdb1 -m usbhid:hid_generic:uhci-hcd:mbcache:jbd2:ext4 -u -o /boot/initrd.gz'

I would then copy the vmlinuz-generic-3.10.17 and generated initrd.gz into the /boot/sdb1 directory on /dev/sda1, update /etc/lilo.conf on /dev/sda1 accordingly, and then run lilo using the -r option.

Habitual 02-13-2014 06:42 PM

Thanks, I'll have a go of it tomorrow!

Keyboard works!

Thank you very much.

You rock!

All times are GMT -5. The time now is 11:55 PM.