LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-08-2013, 02:48 PM   #1
xj25vm
Member
 
Registered: Jun 2008
Posts: 372

Rep: Reputation: 37
No Trash or automount in Thunar under Fluxbox


After installing a fresh 14.1, I get no Trash or automount of usb drives in Thunar. I use Thunar with Fluxbox. This used to work perfectly on 13.37 (didn't try it with 14.0 I'm afraid). I found the following post, which suggests some modifications to ~/.xinitrc

http://www.linuxquestions.org/questi...es-4175418186/

However, as the post above suggests this issue was already fixed in 14.0, yet I don't seem to have any ~/.xinitrc at all, I'm wondering if the advice contained in the post above still applies. Was this supposed to be fixed in 14.1, or maybe the fix is different in 14.1?

Edit: Actually, I've discovered that editing ~/.xinitrc as per the above post doesn't seem to work in 14.1. Am I missing something else? My user is member of the following groups: disk, lp, dialout, audio, video, cdrom, plugdev, power, netdev, scanner, users. Should I add any other groups?

Last edited by xj25vm; 12-08-2013 at 02:54 PM.
 
Old 12-09-2013, 04:23 PM   #2
kk75
LQ Newbie
 
Registered: Dec 2013
Posts: 1

Rep: Reputation: Disabled
Hi.
About the trash i added in ~/.fluxbox/startup the entry:
/usr/libexec/gvfsd-trash &

I don't use automount, but check your /etc/fstab. If your device is listed in it, make sure that the option comment=x-gvfs-show is available. Otherwise Thunar don't show that device.

I hope this can help you.
 
Old 12-09-2013, 06:43 PM   #3
slackass
Member
 
Registered: Apr 2006
Location: SE Texas
Distribution: Slack64-14.2
Posts: 909

Rep: Reputation: 90
I have trash on thunar but can't empty it.
I use KDE so I use dolphin and it works perfect..
Pcmanfm works good also.
 
Old 12-10-2013, 03:40 AM   #4
xj25vm
Member
 
Registered: Jun 2008
Posts: 372

Original Poster
Rep: Reputation: 37
Quote:
About the trash i added in ~/.fluxbox/startup the entry:
/usr/libexec/gvfsd-trash &
Thanks kk75 - but that doesn't seem to do it on my box. Are you on a stock Slackware 14.1 install?

Quote:
I don't use automount, but check your /etc/fstab. If your device is listed in it, make sure that the option comment=x-gvfs-show is available. Otherwise Thunar don't show that device.
I don't think the above applies to my question. I wasn't asking about automount in general. Thunar can do its own volume management. At least it used to, in Slackware 13.37. I never had to add any entries in fstab.
 
Old 12-10-2013, 10:32 PM   #5
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware Current 64 bit KDE 5
Posts: 343

Rep: Reputation: 74
I tend to use dolphin with 14.1 (on my laptop) as I like the ability to split the screen and haven't noticed anything. I use thunar with 14.0 on my tower and haven't noticed anything either. I'll upgrade my tower in the next few days and see if I notice the same thing happening. I use fluxbox on both of my machines.
 
Old 12-11-2013, 11:18 PM   #6
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 248

Rep: Reputation: 24
Xfce (and Thunar) is used udusks/udisks2 to automount in conjunction with gvfs-mount. Also, I think you need to run at startup of your WM the xfce4-volumed plugin.
 
Old 12-12-2013, 05:31 AM   #7
xj25vm
Member
 
Registered: Jun 2008
Posts: 372

Original Poster
Rep: Reputation: 37
Thanks yars. I have started xfce4-volumed daemon and confirmed it is running. I have checked that I have udisks and udisks2 installed. I can see that gvfs is available when I run mount:

Code:
# mount
/dev/mapper/lukssda4 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/sda1 on /boot type ext4 (rw)
tmpfs on /dev/shm type tmpfs (rw)
gvfsd-fuse on /home/seb/.gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=seb)
Yet still no automount in Thunar.

Edit: I'm starting to wonder if I shouldn't investigate this further on the XFCE mailing lists. Maybe they can help with hints as to what Thunar needs in order to automount volumes.

Last edited by xj25vm; 12-12-2013 at 05:33 AM.
 
Old 12-12-2013, 07:01 AM   #8
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware64 14.2 and current, SlackwareARM current
Posts: 1,634

Rep: Reputation: 144Reputation: 144
Maybe take a look at the xinitrc file for xfce, it's in the xfwm4 package I think. Don't know if you might need the ck-launch-session line from there to make automount work.
 
Old 12-12-2013, 07:19 AM   #9
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 248

Rep: Reputation: 24
Please check out for needed libraries for gvfs, xfce4-volumed, udisks, maybe you does not have one or more of libraries?
Code:
ldd whatever
Also, have you any messages from these packages in ~/.xsession-errors or from Thunar when it is running via terminal emulator?
UPD: I think ck-launch-session is not a reason that automount won't work, I don't know as you.

Last edited by yars; 12-12-2013 at 07:40 AM.
 
Old 12-12-2013, 08:34 AM   #10
GazL
LQ Veteran
 
Registered: May 2008
Posts: 6,207

Rep: Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297Reputation: 4297
On my dwm setup, the first time thunar is started after login there is no "Wastebasket" in the Places side panel. if I exit and restart thunar then the second time it runs it manages to launch a gvfsd-trash daemon and there is then a Wastebasket.

Might be an idea to look around at some alternative file-managers that still work correctly as standalone programs. With each new xfce version, it seems that thunar is becoming increasingly tied to its parent desktop environment, or components thereof.

Haven't noticed any issues with volume mounting though.

Last edited by GazL; 12-12-2013 at 08:37 AM.
 
Old 11-01-2016, 10:47 AM   #11
xj25vm
Member
 
Registered: Jun 2008
Posts: 372

Original Poster
Rep: Reputation: 37
Finally solved!

Only 3 years later I've finally managed to find the reason for this! The following Fluxbox config file ~/.fluxbox/startup has changed at some point in time, and not only has it become a proper bash script (it didn't use to be), but has the following lines in it:

Code:
# Start DBUS session bus:
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
   eval $(dbus-launch --sh-syntax --exit-with-session)
fi
The lack of above was what was stopping automount and Trash from working properly in Thunar. Because I was copying over all my own settings when upgrading and overwriting any default files - I never had the new lines in my startup script. In case anybody else is in this same boat! :-)

Last edited by xj25vm; 11-01-2016 at 10:49 AM. Reason: spelling
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Delete directly without using/needing Trash in Xfces Thunar file manager with a Custom Action LXer Syndicated Linux News 0 03-13-2013 02:31 AM
Xfce's Thunar automount issue dunric Slackware 1 11-20-2012 06:01 PM
[SOLVED] Thunar 1.4.0 and Fluxbox on -current: no trash or automount usb devices andrew.46 Slackware 29 09-05-2012 03:59 AM
Trash can thunar Tripsun Linux - Desktop 1 03-08-2011 10:33 AM
How to automount usb flash drives in Thunar (openbox) iamthat Linux - Newbie 1 05-12-2010 01:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration