LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-12-2018, 05:55 AM   #16
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,063

Rep: Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719Reputation: 4719

Never seen this behaviour on my machines, but then I never run "init 3" from a terminal while logged into a graphical session. I always logout first from my graphical desktop. Then I do a Ctrl-Alt-F1 to switch to a console prompt. I login as root on the console and run "init 3" there.

Wali, does the above sequence work for you? Or do you see the same black console after switching with Ctrl-Alt-F1.

Final question, are you using my Plasma 5 packages from the "latest" repository or from the "testing" repository? The "testing" repository adds Wayland support but that is not yet stable. You should be using the "latest" repository.
 
Old 03-12-2018, 06:55 AM   #17
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,339

Rep: Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226
Quote:
Originally Posted by wael_h View Post
Reply to BW-userx

Thank you for thinking I am an idiot.
I find your question, and expatiation misleading.


Quote:
There are reasons I need to switch to run level 3, one of them being I have a slow old machine, to compile and build packages I have to kill X.

I find the "newbie" label very degrading and misleading ... I am no expert by any means, I have been using slackware since version 11, if you did not understand what I was saying that is your problem. I did not mention login manager or screen.

To all;

I am going to mark this as solved since this problem does NOT occur with pure slackware64 with kde from current installation tree. It only happens with kde5 plasma from alienbob; no offense is meant Mr.Eric, and thank you for all you do.

By the way: does anybody have this issue?

Thank you all.

Wali.
Had you have better explained what is going on other "no terminal when switching to run level 3", which is a none gui run level, therefore it is a terminal.

shows me that one does not know what a terminal is.

Running KDE with all of the bells and whistles is a ram eater, maybe you should run in run level 3 then use startx to get yourself back to your terminal if your system is that slow where you need to compile programs in just your terminal and not a terminal emulator, with your GUI taking up RAM running the rest of your Desktop, or run a lesser RAM HOG Desktop / Window Manager. Like Fluxbox, or WindowMaker, or other less RAM Hungary Window Managers. Slackware comes with
  1. fluxbox
  2. blackbox
  3. wmaker
  4. fvwm2
  5. twm
already installed. twm is the lesser of the all in eating up RAM in order to run. you can even install OpenBox and maybe use xfce4 panel in it, in fluxbox too. So Hopefully you will not have to be reboot or shifting back and forth between run level 3 and 4 in order to get something done.
 
Old 03-12-2018, 07:46 AM   #18
GazL
Senior Member
 
Registered: May 2008
Posts: 4,714
Blog Entries: 13

Rep: Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212Reputation: 2212
Quote:
Originally Posted by Alien Bob View Post
Never seen this behaviour on my machines, but then I never run "init 3" from a terminal while logged into a graphical session. I always logout first from my graphical desktop. Then I do a Ctrl-Alt-F1 to switch to a console prompt. I login as root on the console and run "init 3" there.
I've seen it in the past with the nouveau driver. Also, with my intel graphics and xf86-video-intel if I ctrl-alt-f1 and then telinit 3 the Xserver process hangs. if you then ctrl-alt-f7 back to it, it's just a blank screen that doesn't respond to any keypresses and you can't even ctrl-alt-f1 back to a working terminal,and you're stuck. If I use modesetting rather than xf86-video-intel there is no problem, so it's an issue specific to the intel driver. If I do a sleep 10; telinit 3 and then ctrl-alt-f7 back to X and wait, X exits cleanly, so it appears that X only exits cleanly if it's the currently active virtual console. It's all very odd.
 
Old 03-12-2018, 12:56 PM   #19
Olek
Member
 
Registered: Jul 2012
Location: Wroclaw Poland
Distribution: Slackware
Posts: 61

Rep: Reputation: 11
Oh yes, Intel. I use graphics from my Intel I3 CPU. When I use only LCD monitor connected thru DVI everything is ok. But when I connect additional HDMI cable to TV I have blank screen after wake up my computer from hibernate or sleep state.

Last edited by Olek; 03-12-2018 at 01:11 PM. Reason: typo
 
Old 03-12-2018, 02:15 PM   #20
wael_h
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 3
Hi all, and thank you for replying.

Again I did not mean to make a big deal about the "Newbie" thing, my apology.

Answering Eric: When logging out of X, then Ctrl-Alt-F1 and I login as root the result of "init 3" will work as long as I do NOT do Ctrl-Alt-F7. With Ctrl-Alt-F7 I lose all ttys (blank - no blinking cursor) and my keyboard is ineffective.

I am using Plasma 5 packages from latest, updated last night to:

Quote:
KDE Plasma Version: 5.12.3
KDE Framework Version: 5.44.0
QT Version: 5.9.4

Kernel Version: 4.14.21
I have Radeon graphic card - old one, I use kernel driver: Renderer ATI RV370
I use icewm version 1.4.2 from https://github.com/bbidulock/icewm/ last built package was on Feb 20th, 2018
I get the same behavior in all window managers namely: Plasma, xfce4 and icewm.

Framebuffer!!! I think mine IS missed up, I am sorry I did not explore this to start with, it very well COULD be the problem.

Thank you all,

Wali.
 
Old 03-12-2018, 02:57 PM   #21
wael_h
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 3
Hello,

I just changed my framebuffer setting in my lilo.conf file from:

vga = 790
to:
vga = normal

with the result still the same in regard to "init 3" and no output from shutdown scripts.

I need to quit thinking loud

Wali.
 
Old 03-12-2018, 05:38 PM   #22
wael_h
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 3
Hi everyone;

Solved, really solved. Somebody can make a song out of this.

I changed my graphic card to newer one - had to pull it out of my other machine.

I had bought AMD Radeon HD 6950 more than 2 years ago, installed it in the other machine at that time (the one the wife uses) both machines are Dell Precision Workstation 670. Anyway everything works okay. I can do "init 3" from graphical terminal with things working the way they should, I can see all output from shutdown scripts - just discovered a mistake I made in one script.

Thank you all for your help.

Wali.
 
Old 03-12-2018, 05:56 PM   #23
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,836

Rep: Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736Reputation: 1736
Now that is a real "Solved"! Congrats
 
Old 03-12-2018, 08:36 PM   #24
wael_h
Member
 
Registered: Mar 2009
Posts: 34

Original Poster
Rep: Reputation: 3
Mr. Eric Hameleers,

Thank you for your earlier reply. Just thought you might be interested to know the following:

I swapped video cards and both machines are working great now.

My other machine is running slackware64 version 14.2 with your last KDE Plasma for this version

Quote:
KDE Plasma Ver: 5.11.3
KDE Frameworks Ver: 5.40.0
QT Ver: 5.7.1

My kernel version 4.4.115
... now it has the card that gave problem on current. I do not know why but it just works fine in this machine.

best regards

Wali.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sound on Dell Latitude D620 won't work in run level 4 but it will in run level 3. Arcosanti Slackware 3 09-07-2015 11:52 AM
[SOLVED] can't enter run level 4 after updates with gslapt and can't - su; no terminal access slipstream5 Zenwalk 1 03-24-2012 01:44 AM
[SOLVED] get rid of terminal background at run level three jncross Linux - Newbie 5 01-04-2011 06:55 PM
How to open terminal automatically at run level 5 gardenair Linux - Newbie 6 06-26-2010 10:19 AM
run-level switching problem on FC4 ppuru Fedora 3 01-28-2006 07:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration