LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-11-2018, 05:07 PM   #1
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Rep: Reputation: 10
no terminal when switching run level to 3


Hi all,

I appreciate any help with this issue.

The problem is that I get no terminal(s) when I switch run level to 3, default run level is set to 4 in my inittab.
I use initrd, however I get same behavior with huge kernel.

I am on current with last update done March 2, kernel version is 4.14.21, here is "uname -a" output:

Quote:
wael@lazyant:~$ uname -a
Linux lazyant.local 4.14.21 #1 SMP Fri Feb 23 23:17:28 CST 2018 x86_64 Intel(R) Xeon(TM) CPU 3.20GHz GenuineIntel GNU/Linux
I can boot into run level 3 by passing "init 3" to kernel at lilo prompt.

Here is last few lines from my syslog file:

Quote:
root@lazyant:~# tail /var/log/syslog
Mar 11 13:57:32 lazyant kernel: [ 32.683685] CRAT table not found
Mar 11 13:57:32 lazyant kernel: [ 33.238981] kfd kfd: DID 5b63 is missing in supported_devices
Mar 11 13:57:32 lazyant kernel: [ 33.239030] kfd kfd: kgd2kfd_probe failed
Mar 11 14:08:20 lazyant console-kit-daemon[1057]: WARNING: Failed to let cgmanager know that it can remove the cgroup when it's empty, the error was: invalid request
Mar 11 14:59:59 lazyant pulseaudio[2326]: [pulseaudio] pid.c: Stale PID file, overwriting.
Mar 11 15:00:00 lazyant pulseaudio[2326]: [pulseaudio] sink.c: Default and alternate sample rates are the same.
Mar 11 15:00:00 lazyant pulseaudio[2326]: [alsa-sink-emu10k1] alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Mar 11 15:00:00 lazyant pulseaudio[2326]: [alsa-sink-emu10k1] alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_emu10k1'. Please report this issue to the ALSA developers.
Mar 11 15:00:00 lazyant pulseaudio[2326]: [alsa-sink-emu10k1] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Mar 11 15:00:00 lazyant pulseaudio[2326]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files
Any ideas? thank you in advance.

Call me Wali.
 
Old 03-11-2018, 05:55 PM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,491

Rep: Reputation: Disabled
Hi Wali,

Please post the last messages of /var/log/messages .
 
Old 03-11-2018, 06:11 PM   #3
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Original Poster
Rep: Reputation: 10
Thank you, here it is the bottom of my /var/log/messages:


Quote:
Mar 11 14:37:32 lazyant -- MARK --
Mar 11 14:57:32 lazyant -- MARK --
Mar 11 15:00:00 lazyant dbus-daemon[1493]: [session uid=1002 pid=1491] Activating service name='org.gnome.GConf' requested by ':1.31' (uid=1002 pid=2329 comm="/usr/libexec/pulse/gconf-helper ")
Mar 11 15:00:00 lazyant dbus-daemon[1493]: [session uid=1002 pid=1491] Successfully activated service 'org.gnome.GConf'
Mar 11 15:17:32 lazyant -- MARK --
Mar 11 15:37:32 lazyant -- MARK --
Mar 11 15:57:32 lazyant -- MARK --
Mar 11 15:59:35 lazyant init: Switching to runlevel: 3
Mar 11 15:59:43 lazyant acpid: client 1419[0:0] has disconnected
Mar 11 16:00:13 lazyant sshd[3078]: Failed password for root from 192.168.64.3 port 34386 ssh2
Mar 11 16:00:19 lazyant last message repeated 2 times
Mar 11 16:00:19 lazyant sshd[3078]: Connection closed by authenticating user root 192.168.64.3 port 34386 [preauth]
Mar 11 16:00:53 lazyant sshd[3081]: Accepted password for wael from 192.168.64.3 port 34388 ssh2
Mar 11 16:01:08 lazyant init: Switching to runlevel: 4
Mar 11 16:01:08 lazyant acpid: client connected from 3119[0:0]
Mar 11 16:01:08 lazyant acpid: 1 client rule loaded
Mar 11 16:01:25 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Activating service name='org.gtk.vfs.Daemon' requested by ':1.0' (uid=1002 pid=3196 comm="/usr/libexec/ROX-Filer/ROX-Filer -p PIN ")
Mar 11 16:01:25 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Successfully activated service 'org.gtk.vfs.Daemon'
Mar 11 16:01:30 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Activating service name='org.freedesktop.Notifications' requested by ':1.9' (uid=1002 pid=3222 comm="/opt/google/chrome/chrome ")
Mar 11 16:01:30 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Activating service name='org.a11y.Bus' requested by ':1.10' (uid=1002 pid=3382 comm="/usr/lib64/xfce4/notifyd/xfce4-notifyd ")
Mar 11 16:01:31 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Successfully activated service 'org.a11y.Bus'
Mar 11 16:01:31 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Activating service name='org.xfce.Xfconf' requested by ':1.10' (uid=1002 pid=3382 comm="/usr/lib64/xfce4/notifyd/xfce4-notifyd ")
Mar 11 16:01:31 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Successfully activated service 'org.xfce.Xfconf'
Mar 11 16:01:31 lazyant dbus-daemon[3192]: [session uid=1002 pid=3190] Successfully activated service 'org.freedesktop.Notifications'
root@lazyant:~#
I can add a lot more information! I use ssh from another machine to bring 'X' back, run level 4. I also can reboot the machine through ssh.
I have alienbob multilib and his plasma installed. I did say the wrong date for my last update! the correct date includes March 8th update.
I use slackpkg to update my system, kernel is in blacklist file, I do manual update for kernel when I do that.

I also want to mention that I tried to downgrade to sysvinit-scripts-2.1-noarch-4 from the current sysvinit-scripts-2.1-noarch-6 ... that did NOT help. I am back with latest package.

Thank again,
Wali.

Last edited by wael_h; 03-11-2018 at 07:12 PM.
 
Old 03-11-2018, 08:10 PM   #4
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Original Poster
Rep: Reputation: 10
This portion of /var/log/messages file is probably more clear than the previous one. This log is the result of the following 2 commands:

1) In a graphical terminal (xfce4-terminal) and as root

root@lazyant:~# init 3

The result I have no terminals ... blank screen, ENTER key does not help, Ctrl-Alt-F1 .. F6 nothing help also.

2) through ssh from another machine

root@lazyant:~# shutdown -r now



Quote:
Mar 11 17:41:49 lazyant -- MARK --
Mar 11 17:42:51 lazyant init: Switching to runlevel: 3
Mar 11 17:42:51 lazyant acpid: client 7380[0:0] has disconnected
Mar 11 17:42:51 lazyant acpid: client connected from 8064[0:0]
Mar 11 17:42:51 lazyant acpid: 1 client rule loaded
Mar 11 17:44:07 lazyant sshd[8080]: Accepted password for wael from 192.168.64.3 port 39322 ssh2
Mar 11 17:44:47 lazyant shutdown[8113]: shutting down for system reboot
Mar 11 17:44:47 lazyant init: Switching to runlevel: 6
Mar 11 17:44:48 lazyant sshd[1028]: Received signal 15; terminating.
Mar 11 17:44:48 lazyant root: /etc/rc.d/rc.inet1: /sbin/ip route del default
Mar 11 17:44:48 lazyant root: /etc/rc.d/rc.inet1: /sbin/ip link set dev eth0 down
Mar 11 17:44:48 lazyant root: /etc/rc.d/rc.inet1: /sbin/ip link set dev lo down
Mar 11 17:44:48 lazyant acpid: exiting
Mar 11 17:44:48 lazyant exiting on signal 15
Wali
 
Old 03-11-2018, 09:24 PM   #5
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Original Poster
Rep: Reputation: 10
kde Plasma is the Difference

Hi all,

More info. I have another current installation on the same machine but with kde from slackware64 tree, NO Kde Plasma.

This installation works just fine when switching run level. It is not up to date installation, kernel version is 4.14.15

I will bring it up to date and report on the issue. I think Kde Plasma is not ready for prime time yet.
Having said that, I should add and emphasis that I do appreciate ALL of you guys and what you do.

Please advise if I should mark this as solved, I am in the land of Confusion.

Wali.
 
Old 03-11-2018, 09:55 PM   #6
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,923

Rep: Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819
Why not try resetting inittab to default to runlevel 3 and use "startx" or a display manager/gui-login screen if only to get a clearer set of logs unencumbered by an X-related data? From the GUI Login you can easily drop back to "Console Login" and kill the DM if you wish to go back to X without rebooting if you use the DM method or just re-startx for that method. I'm thinking that possibly it is a permissions problem for User that may not exist for Root. It would be good to check out that possibility.
 
Old 03-11-2018, 10:05 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,639

Rep: Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336
are you sure you have your run levels correct?
Code:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
inittab 3 is default, 4 is gui login. If you're booting into a big black screen,then able to login that is your terminal. to start a gui desktop.

Code:
// to set which one you want
xwmconfig

//to start it afterwords.

startx
Code:
/etc/rc.d/rc.4
is where your login managers are, to tell your system which one you want to use. make sure it is installed first, or not, it is set up to run down the list until it gets a hit, or not.

Last edited by BW-userx; 03-11-2018 at 10:09 PM.
 
Old 03-11-2018, 10:33 PM   #8
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Original Poster
Rep: Reputation: 10
Thank you enorbet;

I do not have a problem getting into run level 3 except when in run level 4.

Of course I can change default run level BACK to 3 in my inittab, and system boots into level 3.

I also can pass "init 3" to kernel at lilo prompt, system boots into run level 3.

I have always been able to change run level with:
Quote:
init x
where x is run level number, THIS IS the correct and normal behavior.

Another issue I have is that I get no output from shutdown scripts ...

Those two issues are only in current with Alienbob Kde5 Plasma.

Thank you for looking.

Wali.
 
Old 03-11-2018, 10:45 PM   #9
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 / Slackware 14.2 current / Manjaro
Posts: 6,639

Rep: Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336Reputation: 1336
Quote:
Originally Posted by wael_h View Post
Thank you enorbet;

I do not have a problem getting into run level 3 except when in run level 4.

Of course I can change default run level BACK to 3 in my inittab, and system boots into level 3.

I also can pass "init 3" to kernel at lilo prompt, system boots into run level 3.

I have always been able to change run level with: where x is run level number, THIS IS the correct and normal behavior.

Another issue I have is that I get no output from shutdown scripts ...

Those two issues are only in current with Alienbob Kde5 Plasma.

Thank you for looking.

Wali.
so basically you're having issues with getting a login screen and Kde5 Plasma to work when you're in run level 4, then?

I'd go to run level 3 then login remove Kde5 Plasma, and whatever else that is attached to it that is Alienbob's then switch back to run level 4 reboot, and look for your . should be kde login manager. then select a desktop and if you hopefully get that far let us know, one way or the other.

you're in current, so things change and cannot be expected to always work due to that.

Last edited by BW-userx; 03-11-2018 at 10:52 PM.
 
Old 03-12-2018, 12:12 AM   #10
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Original Poster
Rep: Reputation: 10
Reply to BW-userx

Thank you for thinking I am an idiot.

There are reasons I need to switch to run level 3, one of them being I have a slow old machine, to compile and build packages I have to kill X.

I find the "newbie" label very degrading and misleading ... I am no expert by any means, I have been using slackware since version 11, if you did not understand what I was saying that is your problem. I did not mention login manager or screen.

To all;

I am going to mark this as solved since this problem does NOT occur with pure slackware64 with kde from current installation tree. It only happens with kde5 plasma from alienbob; no offense is meant Mr.Eric, and thank you for all you do.

By the way: does anybody have this issue?

Thank you all.

Wali.
 
Old 03-12-2018, 02:19 AM   #11
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys for decades while testing others to keep up
Posts: 1,923

Rep: Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819Reputation: 1819
Hello again wali, I'm sorry I couldn't help you solve this problematic behavior but since it seems you have given up out of frustration I thought it might be worth some comments.

I didn't assume you were a newbie or rank beginner with Slackware or with Linux or you wouldn't have (or possibly known how to) posted the helpful info as you did. I only assumed since you reported a specific problem that you were/are new to this specific issue as should be obvious we all are. Perhaps you might rethink what "newbie" means since although many use it as a pejorative it actually is not except to insecure individuals who find it necessary to bolster their egos by lording over others the simple fact that they know something someone else doesn't. What? are people expected to know everything a priori? LOL! Big deal! some person bothered to learn something someone else has yet to bother to learn. The way I see it if any person is not a newbie at something then they are stagnant, dead in the water and learning nothing new and what's worse, apparently by choice. That condition is in fact shameful whereas simply having yet to learn something is easily curable.

FWIW I didn't see anyone call you a "newbie" but then I do have a short ignore list so I don't see every post. That shouldn't be taken as an across-the-board slur against anyone since it could be entirely single issue related since the General sub forum handles some "sacred cows" that can get very emotional for some individuals. If someone did call you "newbie" it is likely wise to not take that to heart but that choice is, of course, yours as you see fit. Me, I just invoke "Nulles bastardos carborundum" and move on

Enough Philosophy. What I specifically assumed is that you chose to boot directly to runlevel 4 via a DM/Session Manager and then had difficulty getting a terminal when invoking "init 3" AFTER having already booted to "4". I realized that if you added "init 3" at the LILO prompt it works. I wasn't certain that if you issued "init 3" at LILO, then started X, and THEN later went back to init 3 if that worked or not. Hopefully you see the minor confusion. Without knowing if getting back to init 3 from init 4 is EVER possible it does seem a bug or some incompatibility that will likely be worked out assuming it happens to anyone in addition to you. If it is strictly on your machine I'd assume that, too, can be worlked out given sufficient testing that results in useful logs and I wish you Good Fortune.

Last edited by enorbet; 03-12-2018 at 02:21 AM.
 
Old 03-12-2018, 03:51 AM   #12
wael_h
Member
 
Registered: Mar 2009
Location: Phoenix, Arizona
Distribution: Slackware64
Posts: 41

Original Poster
Rep: Reputation: 10
It is not I gave up, I think this is one of many issues with kde5. It is beyond me to try to fix it, there is a whole team working on that.

The newbie thing was not directed at anybody. It is a label I still have next to my name as LQ member ... I can not remember when I joined this form, but it has been years. I do not ask questions when I can find the answer be it on this form or somewhere else.

Closer look, it listed Registered Mar 2009��

I am less than perfect and I say things sometimes I regret. I use free software, I don't have any right to complain.

Wali.

Last edited by wael_h; 03-12-2018 at 03:55 AM.
 
Old 03-12-2018, 04:17 AM   #13
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX
Posts: 2,157
Blog Entries: 5

Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
The designations on this site depend entirely on the number of posts (excluding those in the General Forum) that a person has made. Consequently someone who mainly uses google to solve problems may remain a "newbie" for a long time, even if the designation has become totally inappropriate.

I had a similar problem in Linux Forums back in the day when I used dial-up. Because I was paying for my time online, I used the forums only when in real need; I didn't browse. I remember complaining that I remained a "newbie" for so long. When I got broadband and could spend more time online, I made an effort to read other people's threads to see if there were questions I could answer. That was how I shucked off the newbie label.
 
Old 03-12-2018, 04:21 AM   #14
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1 on Lenovo Thinkpad W520
Posts: 8,491

Rep: Reputation: Disabled
Well,
  1. The possibly misleading "newbie" status is just a LQ set up only based on the number of posts written so far by the poster: it is in no way related to the poster's skills or knowledge. PS Hazel already responded while I was typing.
  2. As both KDE5 and multilib are maintained by Alien Bob, you could consider posting your issue on his blog if not already done.
  3. Reading again you original post I am not sure to understand what exactly you mean writing "I get no terminal(s) when I switch run level to 3". Do you just get a black screen with no prompt, and is the keyboard ineffective, like you can't switch to another tty with Alt+Fn from tty1 ?

Last edited by Didier Spaier; 03-12-2018 at 06:07 AM. Reason: Correction of the last item.
 
Old 03-12-2018, 04:53 AM   #15
GazL
Senior Member
 
Registered: May 2008
Posts: 4,754
Blog Entries: 14

Rep: Reputation: Disabled
My guess is that the kernel/X11 video driver isn't correctly restoring the virtual console when it is exiting (due to the init level change). This would explain both the missing tty login prompts and your lack of shutdown messages. They're all there, it's just that they're not being displayed on the framebuffer (or the framebuffer itself isn't being displayed). Short of trying different combinations of kernel versions/video drivers or driver versions I'm afraid I can't offer any advice however. To be fair to Plasma, it is probably just the trigger and not the root cause.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sound on Dell Latitude D620 won't work in run level 4 but it will in run level 3. Arcosanti Slackware 3 09-07-2015 11:52 AM
[SOLVED] can't enter run level 4 after updates with gslapt and can't - su; no terminal access slipstream5 Zenwalk 1 03-24-2012 01:44 AM
[SOLVED] get rid of terminal background at run level three jncross Linux - Newbie 5 01-04-2011 06:55 PM
How to open terminal automatically at run level 5 gardenair Linux - Newbie 6 06-26-2010 10:19 AM
run-level switching problem on FC4 ppuru Fedora 3 01-28-2006 07:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration