-   Slackware (
-   -   No screen after suspend in -current using XFCE (

Kreezii 06-17-2012 02:53 PM

No screen after suspend in -current using XFCE
Hi, until 14th of June update, suspend the computer worked perfectly in XFCE, but after that update when I suspend and try to wake up the computer again there is no screen and the keyboard doesn't respond but the lights are on.

I tried with a different user but the problem persist.

I suspect it's something related to the X11 update, is someone getting the same problem?

jv2112 06-23-2012 07:13 AM

Are you using slim ?


exec startxfce4

# exec ck-launch-session dbus-launch startxfce4

I am using Arch but I had a issue with shutdown option and I had to change my .xinitrc file to the uncommented line above and I was all set. Not the same issue but the timing is similiar and it involves similiar process.

Hope this helps. :)

Kreezii 06-27-2012 12:23 PM

Thank you jv2112, yes, I was using slim, but I had issues with kdm and KDE too.

Now It's solved, my problem was with Nvidia proprietary drivers, I was using a new branch of the driver the 302.17, I installed the 295.59 version and all works perfect.

I hope the jv2112 answer and mine help to someone having similar problems :).

ponce 06-27-2012 01:34 PM

just FYI, here (GT525M) the 302.17 drivers caused an hard freeze (had to reset) while web surfing, so switched to the long term ones too (seems they are also a little faster on this gpu).

All times are GMT -5. The time now is 05:51 PM.