-   Slackware (
-   -   No SCIM input in Terminal or in Emacs but working fine in Firefox / Thunderbird (

rlx 04-08-2014 12:41 PM

No SCIM input in Terminal or in Emacs but working fine in Firefox / Thunderbird

I moved to Slackware64 multilib last year and I still have this problem with SCIM. It must be some parameter I didn't setup right in the config and maybe someone can help me by pointing to some parameters to look for. :)

The problem is that SCIM no longer reacts to the 'C-;' command when the X focus is on an Emacs or Terminal window. This used to work fine before when I used Slackware32. However I still get Chinese input from Firefox as here 你好.

Here are the modules I installed,


Of course I have all the fonts installed. I can display Chinese text in both Emacs an on Xterm terminal windows.

When using Firefox the SCIM related windows work as expected. It is just that I can't activate SCIM from Emacs or Xterm terminals.

I use FVWM as a windows manager. I also used FVWM with Slackware32. So no change here.

I typically call emacs as follows,

LC_CTYPE=en_US.UTF-8 LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 XMODIFIERS=@im=SCIM GTK_IM_MODULE=scim-bridge exec /usr/bin/emacs

Now when I type C-; in Emacs I get the following message:

SCIM: file-error: ("make client process failed" "no such file or directory" :name "scim-bridge" :service "/tmp/scim-bridge-0.3.0.socket-1000@localhost:0.1" :buffer " *scim-bridge(:0.1)*" :family local :server nil :noquery t)

even if scim-bridge is in the path.

Thank's for any suggestion.

rlx 04-08-2014 03:24 PM

Solved the Emacs part
I updated to emacs-24.3-x86_64-3.txz and now SCIM works in Emacs.

I still have to solve that problem for xterm. I tried xterm-297-x86_64-1 and I still have no luck.

All times are GMT -5. The time now is 10:20 PM.