LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-24-2020, 08:36 PM   #1
slac
Member
 
Registered: May 2019
Posts: 80

Rep: Reputation: Disabled
Question No output audio devices after upgrading in slackware current for one user


It is been a few months since I upgraded my Slackware 14+Current installation, maybe 5 months, until then everything was working correctly.

Recently, I upgraded the system and now, I do not have any output devices working except for one, a dummy device.

Not error output was shown while or after upgrading. Also, no error output is shown when executing alsamixer or pavucontrol but the only audio device is dummy and it gives no audio with any application.

I have two users in my Slackware installation. I noticed that in one them I have the output audio devices working correctly and in the other one I do not. Both of those users are in three groups: [self group], users, wheel and both of them had audio working correctly before upgrading the system.

I found out that, by adding the user that has no audio output devices to the audio group, fixes the problem. Anyway, I was wondering why this does happen? Because the other user is not in the audio group yet the audio output devices are there.
 
Old 05-24-2020, 11:25 PM   #2
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,545

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
Quote:
Originally Posted by slac View Post
I found out that, by adding the user that has no audio output devices to the audio group, fixes the problem.
And $HOME/.config/pulse/ gets properly populated.

Last edited by abga; 05-24-2020 at 11:27 PM. Reason: forgot the . in front of config :)
 
Old 05-25-2020, 02:41 AM   #3
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,497
Blog Entries: 14

Rep: Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328Reputation: 3328
The CONSOLE_GROUPS setting in /etc/login.defs used to provide the 'audio' group to users even if they didn't have it as one of their supplementary groups. That setting no longer appears to be supported post PAMification.
 
2 members found this post helpful.
Old 05-25-2020, 12:08 PM   #4
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,545

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
I'm only running Slackware -current ARM and there could be some differences in the updates compared to the x86 version.
On an up to date system I still have:
Code:
# ls -al /etc/login.defs
-rw-r--r-- 1 root root 11947 Jan 31 17:56 /etc/login.defs
# grep CONSOLE_GROUPS /etc/login.defs
CONSOLE_GROUPS         floppy:audio:cdrom:video:lp:scanner
# cat /etc/slackware-version
Slackware 14.2+
Created a dummy user test and learned that it wasn't added to the audio group and it's not able to identify the ALSA audio adapter:
Code:
#groups test
test : users
test@pi2s1:~$ pulseaudio -D
test@pi2s1:~$ pactl list short sinks
0       auto_null       module-null-sink.c      s16le 2ch 44100Hz       SUSPENDED
 
Old 05-25-2020, 01:05 PM   #5
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,545

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
Personally, I'm always adding the users I create, manually, to the desired groups and never used the feature of the /usr/sbin/adduser script to do so.
Just checked the "unPAMified" Slackware 14.2 and learned that the only initial group that /usr/sbin/adduser is defining is users.
The /usr/sbin/adduser script has its own variable defining additional groups:
Code:
# grep AGID -m1 /usr/sbin/adduser
AGID="audio cdrom floppy input lp netdev plugdev power scanner video" # additional groups for desktop users
and doesn't seem to rely on /etc/login.defs for this.

In the /usr/sbin/adduser dialogue just press UP arrow key & Enter when you reach the Additional UNIX groups: stage:
Code:
Additional UNIX groups:
...
Press ENTER to continue without adding any additional groups
Or press the UP arrow key to add/select/edit additional groups
:
 
1 members found this post helpful.
Old 05-25-2020, 05:01 PM   #6
slac
Member
 
Registered: May 2019
Posts: 80

Original Poster
Rep: Reputation: Disabled
Exclamation

Though it is weird that out of the two users I have in the system, in only one of them, the audio only works if that user is added to the audio group, meanwhile the other user has audio normally without being in the audio group. Very odd behavior.

There is something important as well... I recently made a new Slackware installation (a totally fresh one) and I created a user with this command:

Code:
# useradd -m -U -G wheel -s /bin/bash tuser
... As you can see, the user is in only two groups: tuser, wheel. The audio works correctly without adding the user to the audio group.

I do not know what the system upgrades did to that user SPECIFICALLY and ONLY to that user but at least I know that the problem can be solved adding the user to the audio group, in case anybody else finds this problem. Though I do not know why that happened and I also do not know why/how it fixes the problem (adding the user to audio group, specifically for this case).

Last edited by slac; 05-25-2020 at 05:03 PM.
 
Old 05-25-2020, 05:36 PM   #7
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,545

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
I just tested this again on a Slackware ARM -current system and removing the user from the audio group resulted in no audio. I thought that once the $HOME/.config/pulse/ got populated the user doesn't need to belong to the audio group anymore, wrong...
Adding the user to the wheel group didn't help either.
Code:
test@pi2s1:~$ groups test
test : users lp floppy audio video cdrom input plugdev power netdev scanner
test@pi2s1:~$ pulseaudio -D
test@pi2s1:~$ pactl list short sinks
0       alsa_output.platform-soc_audio.stereo-fallback  module-alsa-card.c      s16le 2ch 44100Hz       IDLE
test@pi2s1:~$ pulseaudio -k
test@pi2s1:~$ exit
# removed user test from the audio group
# groups test
test : users lp floppy video cdrom input plugdev power netdev scanner
# su - test
test@pi2s1:~$ pulseaudio -D
test@pi2s1:~$ pactl list short sinks
0       auto_null       module-null-sink.c      s16le 2ch 44100Hz       IDLE
test@pi2s1:~$ exit
# added test to group wheel
# usermod -a -G wheel test
# groups test
test : users lp wheel floppy video cdrom input plugdev power netdev scanner
# su - test
test@pi2s1:~$ pulseaudio -D
test@pi2s1:~$ pactl list short sinks
0       auto_null       module-null-sink.c      s16le 2ch 44100Hz       IDLE
test@pi2s1:~$
The folks at Arch (they have good docs) state that the user that launches pulseaudio doesn't necessarily need to be part of the audio group. But they might use logind, which AFAIK is not available in Slackware.
https://wiki.archlinux.org/index.php...guration_files
Quote:
There is usually no need to add your user to the audio group, as PulseAudio uses udev and logind to give access dynamically to the currently "active" user. Exceptions would include running the machine headless so that there is no currently "active" user.
P.S. Just checked, I don't have any privileges defined for the wheel group in login.access & sudoers

Last edited by abga; 05-25-2020 at 06:08 PM. Reason: P.S.
 
Old 05-25-2020, 08:49 PM   #8
slac
Member
 
Registered: May 2019
Posts: 80

Original Poster
Rep: Reputation: Disabled
I think that it is just very likely that something gone wrong after the upgrade, ie: I found that my "passwd" command does not work:

Code:
[root@cm ~]# passwd
passwd: Module is unknown
passwd: password unchanged
Maybe some other things could be broken as well and that is what affects to such user specifically.
 
Old 05-25-2020, 10:03 PM   #9
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,545

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
@slac

That "Module is unknown" might be related to PAM. Unfortunately I'm only running -current on ARM and it lacks full PAM-ification (updates are due) and I cannot help trying to replicate your issue.
Make sure you have all the packages updated, and removed/added the ones that need to.
http://www.slackware.com/changelog/c...php?cpu=x86_64
If it still persists, try opening a new thread and focus only on this last reported issue.
 
1 members found this post helpful.
Old 05-25-2020, 11:25 PM   #10
slac
Member
 
Registered: May 2019
Posts: 80

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by abga View Post
@slac

That "Module is unknown" might be related to PAM. Unfortunately I'm only running -current on ARM and it lacks full PAM-ification (updates are due) and I cannot help trying to replicate your issue.
Make sure you have all the packages updated, and removed/added the ones that need to.
http://www.slackware.com/changelog/c...php?cpu=x86_64
If it still persists, try opening a new thread and focus only on this last reported issue.
In fact, these things happened after: installing-new, upgrade-all, clean-system operations so I know I am up-to-date.

Yes, you are right about PAM likely to be the problem. I guess some things broke because of the upgrade but I did not make an upgrade since half a year, that could have been the reason. It is all right, it is current (development version) after all. I will just re-install Slackware and that should make the "trick".

Thanks for the assistance, by the way.
 
Old 05-26-2020, 12:21 AM   #11
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,545

Rep: Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863Reputation: 863
I'm using Slackware since the 3.x versions and never upgraded any version, but always backed up my conf & stuff and installed the new version fresh. As for a stable to -current upgrade, never even considered such an attempt.
Not saying it shouldn't work, at least the docs and procedure for upgrading stable->stable are solid and tested.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
df command output shows partly dm-X devices and partly lvm mapper devices, shadow-fmx Linux - Newbie 29 10-29-2015 06:37 PM
Audio problem due to more than one sound devices (solved) slackware lenovo rasitabay Linux - Newbie 2 12-23-2013 09:41 PM
Gnome: Auto mounting external devices as first user logged in, not current user yitzle Linux - Software 4 04-01-2008 09:43 AM
Problem with X after upgrading to slackware-current (27 Aug 2006) crisostomo_enrico Slackware 8 08-30-2006 03:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration