LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-03-2011, 12:53 PM   #1
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Rep: Reputation: 15
No network - Intel Corporation 82567LM Gigabit


Just did a clean install on a Dell Latitude E6400 of Slackware 13.1 and, for the most part, all is working great. Got wicd installed and wireless came right up, nvidia drivers installed and video is fantastic, but for some reason my wired connection isn't happening. The device is detected, but I can't get an IP.

$ lspci

Code:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G98M [Quadro NVS 160M] (rev a1)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
03:01.2 SD Host controller: Ricoh Co Ltd R5C843 MMC Host Controller (rev 11)
0c:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
$ dmesg | grep eth0

Code:
0000:00:19.0: eth0: (PCI Express:2.5GB/s:Width x1) 00:26:b9:99:7a:a7
0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
0000:00:19.0: eth0: MAC: 7, PHY: 8, PBA No: 1004ff-0ff
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1500 to 576
0000:00:19.0: eth0: changing MTU from 576 to 1500
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1500 to 576
0000:00:19.0: eth0: changing MTU from 576 to 1500
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1500 to 576
0000:00:19.0: eth0: changing MTU from 576 to 1500
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1500 to 576
0000:00:19.0: eth0: changing MTU from 576 to 1500
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1500 to 1492
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1492 to 576
0000:00:19.0: eth0: changing MTU from 576 to 1492
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
Any ideas?
 
Old 03-03-2011, 01:42 PM   #2
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
Just a few quick additions. When I manually try to obtain a DHCP address I get this:

$ sudo dhcpcd eth0

Code:
dhcpcd: version 5.2.2 starting
dhcpcd: eth0: rebinding lease of 192.168.50.29
dhcpcd: eth0: acknowledged 192.168.50.29 from 192.168.50.1 `'
dhcpcd: eth0: checking for 192.168.50.29
dhcpcd: eth0: leased 192.168.50.29 for 86400 seconds
dhcpcd: eth0: MTU set to 576
dhcpcd: forking to background
$ ifconfig

Code:
eth0      Link encap:Ethernet  HWaddr 00:26:b9:**:**:**  
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:2007 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:227578 (222.2 KiB)  TX bytes:9891 (9.6 KiB)
          Memory:f6fe0000-f7000000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:37 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2432 (2.3 KiB)  TX bytes:2432 (2.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:24:d6:**:**:**  
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10686 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9132 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8018675 (7.6 MiB)  TX bytes:1049272 (1.0 MiB)
 
Old 03-03-2011, 03:12 PM   #3
TL_CLD
Member
 
Registered: Sep 2006
Posts: 366

Rep: Reputation: 45
I had a similar problem after upgrading the kernel to 2.6.36.4 on a Slackware 13.1 x86_64 install.

This guided me in the right direction: http://roy.marples.name/archives/dhc...2010/0218.html

The solution for me was to simply upgrade dhcpcd. After that everything worked.
 
1 members found this post helpful.
Old 03-03-2011, 03:15 PM   #4
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 7,173

Rep: Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224Reputation: 4224
looking at the dmesg logs, I would try this.
 
Old 03-03-2011, 03:15 PM   #5
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 224Reputation: 224Reputation: 224
What is the ethernet cable plugged into? A DSL Modem? The MTU being 1492 is usually what DSL modems want, for everything else it should be 1500.

Did you put some values in sysctl rc.local or inet1.conf to manipulate the settings? Quite strange that the nic is swapping values and options that way.
 
Old 03-03-2011, 03:27 PM   #6
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
Thanks all. I'm going through each of these posts and will write back in a bit after I see the results.

disturbed1 -- I did attempt to force my MTU to 1492 after some reading but only after I saw the weird stuff going in dmesg. I haven't messed much with the scripts other than disabling and enabling DHCP for eth0. I'm plugged into a switch so it appears that I followed bad advice or didn't read something carefully enough. At any rate, I'll set it back.

Interestingly enough, dhclient works great, but dhcpcd is what seems to be choking on my network.
 
Old 03-03-2011, 03:37 PM   #7
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 224Reputation: 224Reputation: 224
Keep the MTU at 1500. 1492 is usually only used in PPoE (DSL authentication). MTU of 576 is the common PPP (dial up) MTU. More on MTU if you're interested http://www.dslreports.com/faq/695

Follow TL_CLD's thread link if you upgraded the kernel. That same link was posted in other threads discussing dhcpcd errors with a newer than stock kernel. And have fixed the problems. IF you're running a stock Slackware install (either 13.1 or -current) there is no need to upgrade the dhcpcd package. They all work in sync.

dhcpcd was upgraded to 5.2.9 on Fri Dec 31 for current. In 13.1 dhcpcd is at 5.2.2 which does have problems with newer kernels.

If the issue is related to Ponce's link, I'd look into a firmware update for your router, or double check the settings. Something is screwy there. An MTU of 576 should not be pushed by a DHCP server.

Last edited by disturbed1; 03-03-2011 at 03:40 PM.
 
Old 03-03-2011, 03:42 PM   #8
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
Getting somewhere. One of the posts suggested editing dhcpcd.conf as follows:

/etc/dhcpcd.conf
Code:
change: nohook lookup-hostname
to: nohook hostname
Seemed harmless enough so I tried that, rebooted, and now it's online. I think I'll still update dhcpcd to 5.2.11. Couldn't find a package, but the source will do.

$ dmesg | grep eth0
Code:
0000:00:19.0: eth0: (PCI Express:2.5GB/s:Width x1) 00:26:b9:99:7a:a7
0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
0000:00:19.0: eth0: MAC: 7, PHY: 8, PBA No: 1004ff-0ff
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
0000:00:19.0: eth0: changing MTU from 1500 to 576
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
0000:00:19.0: eth0: 10/100 speed: disabling TSO
$ ifconfig
Code:
eth0      Link encap:Ethernet  HWaddr 00:26:b9:99:7a:a7  
          inet addr:192.168.50.29  Bcast:255.255.255.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:576  Metric:1
          RX packets:7211 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5957 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:3458993 (3.2 MiB)  TX bytes:691790 (675.5 KiB)
          Memory:f6fe0000-f7000000
 
Old 03-03-2011, 03:44 PM   #9
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by disturbed1 View Post
Keep the MTU at 1500. 1492 is usually only used in PPoE (DSL authentication). MTU of 576 is the common PPP (dial up) MTU. More on MTU if you're interested http://www.dslreports.com/faq/695

Follow TL_CLD's thread link if you upgraded the kernel. That same link was posted in other threads discussing dhcpcd errors with a newer than stock kernel. And have fixed the problems. IF you're running a stock Slackware install (either 13.1 or -current) there is no need to upgrade the dhcpcd package. They all work in sync.

dhcpcd was upgraded to 5.2.9 on Fri Dec 31 for current. In 13.1 dhcpcd is at 5.2.2 which does have problems with newer kernels.

If the issue is related to Ponce's link, I'd look into a firmware update for your router, or double check the settings. Something is screwy there. An MTU of 576 should not be pushed by a DHCP server.
Thanks for the info, I will read it.

I didn't upgrade the kernel and I'm running 13.1 which does have 5.2.2. Should I not attempt to compile 5.2.11 then and just look for a package of 5.2.9?
 
Old 03-03-2011, 03:48 PM   #10
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 224Reputation: 224Reputation: 224
You can use the dhcpcd SlackBuild from current -
http://slackware.osuosl.org/slackwar...urce/n/dhcpcd/

I wonder if dhcpcd would be patch worthy. Considering it is somewhat common place for users to upgrade their own kernel.

---edit---
Though if this fixes your problem, I do wonder what the root cause was

Last edited by disturbed1; 03-03-2011 at 03:49 PM.
 
Old 03-03-2011, 03:53 PM   #11
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
Dang. I upgraded to dhcpcd 5.2.9, modified dhcpcd.conf back to its original state, rebooted and no-go. Same issue. When I edited the conf again and rebooted, the output during bootup looks like the same, but the address is held and I'm effectively online.
 
Old 03-03-2011, 03:57 PM   #12
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
I just checked the router DHCP settings and it's set to a 1500 MTU as well. Things appear to be working, but my MTU in Slackware is dropping down to 576 still.

As a final note here, I checked a Windows box and it is setting itself to a 1500 MTU. For whatever it's worth...

Last edited by silmaril8n; 03-03-2011 at 04:00 PM.
 
Old 03-03-2011, 03:59 PM   #13
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 224Reputation: 224Reputation: 224
0000:00:19.0: eth0: changing MTU from 1500 to 576


That's still not right. Double check your router settings. Most have an MTU setting. Or just set a static IP as a work around.

---edit---
slow posting

Try the static IP, and forcing an MTU of 1500. Out of curiosity, which router do you have?

Last edited by disturbed1; 03-03-2011 at 04:00 PM.
 
Old 03-03-2011, 04:32 PM   #14
silmaril8n
Member
 
Registered: May 2004
Posts: 123

Original Poster
Rep: Reputation: 15
I made another change to the conf per ponce's post and I've now got DHCP working with the correct MTU. (changes in bold)

$ cat /etc/dhcpcd.conf
Code:
# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Inform the DHCP server of our hostname for DDNS.
hostname
# To share the DHCP lease across OSX and Windows a ClientID is needed.
# Enabling this may get a different lease than the kernel DHCP client.
# Some upstream DHCP servers may also require a ClientID, such as FRITZ!Box.
#clientid

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
#option interface_mtu
# A ServerID is required by RFC2131.
require dhcp_server_identifier

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
#nohook lookup-hostname
nohook hostname
The router is a Netgear FVS318v3. Maybe it's time to break out that Cisco ASA I've got sitting on the shelf!? So I guess this is resolved enough?
 
Old 03-03-2011, 04:49 PM   #15
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 224Reputation: 224Reputation: 224
It's a problem with your Netgear. Look for an upgraded firmware. Here's one of many topics on the issue http://www.dslreports.com/forum/r396...Netgear-FVS318

The latest firmware is 3.0_28 http://kb.netgear.com/app/products/model/a_id/2423
Version 3.0_24 reportedly fixed the dhcp issues.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Intel 82574L Gigabit network card - issues and resolution unkie888 Linux - Hardware 4 04-13-2012 01:21 AM
wlan issue, Intel Corporation PRO/Wireless 3945ABG Network Connection min_sin Linux - Newbie 5 10-16-2008 04:53 AM
WiFi prolem with Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05) __spc__ Linux - Hardware 8 10-11-2008 09:51 AM
Problem with Intel Corporation PRO/Wireless 3945ABG Network jack_peter Linux - Hardware 5 08-18-2008 03:42 PM
Intel Corporation PRO/Wireless 2915ABG Network Connection not working? hermouche Fedora 4 09-19-2007 11:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration