LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-13-2018, 11:53 AM   #16
a4z
Senior Member
 
Registered: Feb 2009
Posts: 1,727

Rep: Reputation: 740Reputation: 740Reputation: 740Reputation: 740Reputation: 740Reputation: 740Reputation: 740

Quote:
Originally Posted by rpedrica View Post
@a4z - correct. But is it actually needed?
your build looked for it, did not find it, and reported the error you showed us.
so everything is principally fine :-)

when you have binaries around that are looking for the not longer existing lib, since the newer package is different to the previous package, they need to be rebuild and you need to tell them how they find what they need.
 
Old 01-13-2018, 02:19 PM   #17
gmgf
Senior Member
 
Registered: Jun 2012
Location: Bergerac, France
Distribution: Slackware
Posts: 1,685

Rep: Reputation: 656Reputation: 656Reputation: 656Reputation: 656Reputation: 656Reputation: 656
Another possibility, is, maybe that you have a corrupted lib package installed, but it's difficult to detect that, you can try to reinstall the entire section /l

download all /l packages, enter in root directory where you have downloaded all packages with the console or an xterm and make the command:
http://slackware.osuosl.org/slackwar...slackware64/l/

upgradepkg --reinstall --install-new *.txz,

it's radical method, but without risk
 
Old 01-23-2018, 01:41 PM   #18
srl295
LQ Newbie
 
Registered: Jan 2018
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by rpedrica View Post
I'm trying to rebuild handbrake on -current (updated as of today) but it's complaining there is no longer a libicule library available. I've checked the -current package (icu4c-60.2-x86_64-1) and there is no lib there. I regen'd the package from the slack source and still the same.

The slackware 14.2 package (56) has this lib ...

Any ideas?

Regards, Robby
libicule code was removed from ICU4C as of version 58. The code had been deprecated for some time. Use Harfbuzz instead if you need layout, more at the ICU4C site. Hope this helps.
 
Old 01-10-2019, 02:00 PM   #19
Johncc330
Member
 
Registered: Mar 2007
Posts: 45

Rep: Reputation: 16
I just hit the same problem. I have a couple of programs which use
gtkglext, and that library seems to pull in libicule.

Case in point: gEDA doesn't run anymore. I had to recompile gtkglext
to remove the libicule dependency.

Last edited by Johncc330; 01-10-2019 at 03:46 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Today's -current icu4c upgrade broke ktown's sddm dugan Slackware 36 12-09-2017 05:50 AM
icu4c package upgrade in -current mpv breakage & fix 1337_powerslacker Slackware 4 12-08-2017 10:39 AM
Xalan 1.11 + Xerces 3.1.1 + Icu4c not compile jotapdiez Slackware 8 01-08-2016 08:13 AM
libicule.so.51 pack is missing and I can't open google chrome anymore MattFly Slackware 2 05-30-2015 04:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration