-   Slackware (
-   -   No kipi Plugins in Digikam or Gwenview (

bogzab 07-11-2011 05:02 PM

No kipi Plugins in Digikam or Gwenview
pkgtool tells me that I have Digikam 1.9 and kipi plugins 1.9 both installed. However when I run digikam no kipi plugins are detected. The tab in the configure Digikam menu for kipi plugin config is empty. Gwenview also shows no plugins.

A few weeks ago these plugins were there and even working. I was experimenting with various "export-to-web-services" plugins. What has happened to these useful extensions?

Anybody ?


willysr 07-11-2011 07:38 PM

you can try to use pkgtool --reinstall /path/to/kipi-plugins-file.txz

bogzab 07-12-2011 02:04 AM

Tried re-installing both digikam and kipi-plugins, but I still have the same outcome - no kipi-plugins available.

The digikam splash screen provides a few progress messages among which is "loading kipi plugins", but nothing seems to result from this.

One clue might be this output which comes from running gwenview at the command line:


gwenview(14654)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "KIPI/Plugin" not
This suggests that kipi-plugins should have registered itself as a KDE4 service (presumably during installation of kipi-plugins). There may be something in my KDE4 setup which is preventing this. I will try on a KDE list.

willysr 07-12-2011 03:25 AM

How do you build it?
I would suggest to rebuilt it

most of the time, you upgraded KDE, but forgot to rebuilt digikam/kipi plugins against the newest version of KDE

All times are GMT -5. The time now is 02:12 PM.