-   Slackware (
-   -   No kernel modules found for Linux (

pejobe 06-08-2010 11:20 AM

No kernel modules found for Linux
After changing to generic-smp kernel I can not boot. I get the following message:
No kernel modules found for Linux
mount: mounting /dev/sda1 on /mnt failed: No such device
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
You can try to fix it. Type 'exit' when things are done.

/bin/sh: can't access tty: job control turned off

Well, I might have forgotten to install the smp modules but I don't get it cause I ran huge-smp before and read on Pat Volkerdings release notes that generic-smp was preferred. I did what it said in README.mkinitrd and typed reboot.
Now I really need help on this subject.

hello.freeman 06-08-2010 11:42 AM

Why don't you try to install the smp modules ? The generic kernel need it.

hakan56 06-08-2010 12:16 PM

I think you already have them installed, I dont think you can make a initrd.gz otherwise but check..

titus:~ $ ls /lib/modules
titus:~ $ ls -al /etc/rc.d/rc.modules
lrwxrwxrwx 1 root root 23 2010-05-31 15:42 /etc/rc.d/rc.modules -> rc.modules-

Maybe you didn't get all what's needed for your initrd, look here on Alien-BOB's site...
..try his script..""


pejobe 06-08-2010 12:59 PM

Solved it. Thanks for the answers. You are right.

I had both and installed.
-smp was forgotten the first time in the line below.

mkinitrd -c -k -m ext4 -f ext4 -r /dev/sda1
This post was helpful after I had booted from the DVD:

All times are GMT -5. The time now is 01:57 PM.