Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 08-11-2003, 02:53 AM   #1
LQ Newbie
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
no init found

I just installed slackware on a new box and when I boot, I use the installation cd and at boot: prompt I just use 'bare.i root=/dev/hda3 noinitrd ro and when the kernel tries to load init i get the error: No init found. Try passing init= to kernel.

of course I tried passing init=/bin/bash but that gave me the same error...i'm now thinking that /etc/fstab is misconfigured, but when I get to a command line with the installation CD I can't seem to mount /dev/hda3 =/

thanks in advance
Old 08-11-2003, 03:19 AM   #2
Senior Member
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Why are you using the installation CD to try to boot the live box?

IIRC you want to use the "mount" image on the installation disk for this kind of thing. So it would be mount root=/dev/hda3 noinitrd ro init=/bin/bash.

HTH, if you do get it started I would suggest you start using LILO or grub to boot your system so you don't need to keep using the CD and passing it boot parameters every time.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic No init found. Try passing init..... Adrian Baker Mandriva 2 02-28-2005 11:47 AM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-18-2004 11:10 PM
error: No init found. Try passing the init= option to the Kernel neylitalo Linux - Laptop and Netbook 3 01-22-2004 09:34 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 10:18 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 03:38 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:15 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration