LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-23-2006, 05:24 PM   #1
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 245

Rep: Reputation: 31
no gui in slackware


i installed slackware 11 and install went well but i have no gui just command prompt. can anyone help.
 
Old 11-23-2006, 05:28 PM   #2
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,435

Rep: Reputation: 275Reputation: 275Reputation: 275
Quote:
Originally Posted by thebiggiantmouse
i installed slackware 11 and install went well but i have no gui just command prompt. can anyone help.
type startx

PS: it's not a good idea to do this as root.

First creat a regular user:
*Log in as root
*type adduser
*answer the questions asked (mostly the username and password)
*type exit
*log in as your normal user and give its password
*type startx to start X (your GUI)

Last edited by jens; 11-23-2006 at 05:33 PM.
 
Old 11-23-2006, 05:40 PM   #3
hitest
Guru
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware
Posts: 5,954

Rep: Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180Reputation: 2180
Did you run xorgconfig to set-up x windows? Or xorgsetup? You will need to set-up x windows before you type startx.
 
Old 11-23-2006, 05:55 PM   #4
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,299

Rep: Reputation: 89
You may also want to head off another simple problem by running alsaconf as well.
 
Old 11-23-2006, 05:59 PM   #5
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 245

Original Poster
Rep: Reputation: 31
thanx for the replies. i will do your suggestions and get back to you guys
 
Old 11-23-2006, 06:33 PM   #6
vtel57
Member
 
Registered: Jul 2006
Location: VPN Tunnel, USA
Distribution: Slackware64
Posts: 945

Rep: Reputation: 122Reputation: 122
Hey Mouse,

Unlike Fedora or other distros, Slack initializes in run level 3 (no GUI). You login with your user account (not root) at the prompt and then type in the command "startx" at the prompt. Your X interface will initialize at this point.

Luck!
 
Old 11-23-2006, 07:12 PM   #7
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 245

Original Poster
Rep: Reputation: 31
ok i got an error message when i tried to configure xorg
fatal error no screens found
 
Old 11-23-2006, 07:26 PM   #8
vtel57
Member
 
Registered: Jul 2006
Location: VPN Tunnel, USA
Distribution: Slackware64
Posts: 945

Rep: Reputation: 122Reputation: 122
How did you install Slack? From d-loaded iso disks? If so, did you opt for the complete install or did you do a selective install. It's possible that you didn't install X at the time of your Slack install.
 
Old 11-23-2006, 07:48 PM   #9
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,435

Rep: Reputation: 275Reputation: 275Reputation: 275
What tool did you use to configure X?
The easiest one is xorgsetup.
Just type xorgsetup and stick with the defaults. This should work on most systems.
 
Old 11-23-2006, 08:51 PM   #10
thebiggiantmouse
Member
 
Registered: May 2006
Location: Da Bronx
Distribution: Arch Linux, Sackware, Gentoo
Posts: 245

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by jens
What tool did you use to configure X?
The easiest one is xorgsetup.
Just type xorgsetup and stick with the defaults. This should work on most systems.
thanx that seems to have done it.
but my screen res is low how can i change that
 
Old 11-23-2006, 10:05 PM   #11
charle97
Member
 
Registered: Nov 2006
Location: hawaii, usa
Distribution: slackware 14
Posts: 80

Rep: Reputation: 16
Quote:
Originally Posted by thebiggiantmouse
my screen res is low how can i change that
you'll need to edit your xorg.conf file. if you have access to another distro install that has your desired res working, you can use that distro's xorg.conf to give you some clues on what you need to edit.
 
Old 11-23-2006, 11:08 PM   #12
vtel57
Member
 
Registered: Jul 2006
Location: VPN Tunnel, USA
Distribution: Slackware64
Posts: 945

Rep: Reputation: 122Reputation: 122
To add to what charle97 says... you might also have to install 3rd party drivers. I could not get my normal resolution and screen refresh rate in Fedora without installing Nvidia drivers.

Luck!
 
Old 11-24-2006, 02:10 AM   #13
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
I am facing a weird problem. In my xorg.conf all resolution lists are:
"1152x863" "1280x1024" "1024x768"

But the xserver never uses 1152x864 (which is 1st priority in xorg.conf) but always uses 1280x1024. Now isn't 1280x1024 a larger resolution than 1152x864? Shouldn't a comp that is able to 1280x1024 be able to do 1152x864?

I have onboard 128 MB Intel Graphics which are correctly installed as in cwwilson's guide. glxgears works after startx
 
Old 11-24-2006, 02:12 AM   #14
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 294

Rep: Reputation: 39
Hello thebiggiantmouse,

That was also my problem when i was a slackware noob. I assume you do a full install
Or at least, you have X and or KDE.
First you need to get your X configured, use "xorgconfig".

Log in as root, then run "xorgconfig"

*****************************************************************
OW! By the way, i haven't tried slackware 11 yet, and i heard
"xorgconfig" and xorg is for gnome, and slackware 11 has no gnome
I read from other post, the command is "xf86config"
JUST TRY IT!
********************************************************************

You need to read carefully on the menu, and if you don't have an idea, try guessing
You will be asked for you mouse, screen, etc, just try to figure out, anyway, you
can always reconfigure it.

When you're done, run "startx"

If it runs successfully, then you're OK, but if not, keep retrying, you know
It's a hardware thing, and poeple has different hardware. KEEP retrying until you
SUCCEED!

If you succeed, setup the default window manager, i forgot the command,
is it "xwmconfig", anyway, it sounds like that.

If you want to log in automatically to X Window system, edit your default
runlevel and set to 4
Edit /ect/inittab using joe or any text editor

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

Change it to:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

After all the changes, and when you reboot, you will have a graphical login.

What if when you reboot, x doesn't start?
You need to use a bootable Linux CD, and boot with it, mount your newly installed linux, and restore what you've done in /etc/inittab

BEWARE!! DO IT AT YOUR OWN RISK!

I'm not a slackware geek, but i have successfully installed slackware on many
computers with different hardwares, what i did was KEEP ON TRYING. anyway, don't be afraid, slackware won't destroy your PC.

Hope it helps you!

Last edited by dc_eros; 11-24-2006 at 02:29 AM.
 
Old 11-24-2006, 03:28 AM   #15
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,740

Rep: Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304Reputation: 6304
Quote:
Originally Posted by dc_eros
Log in as root, then run "xorgconfig"

*****************************************************************
OW! By the way, i haven't tried slackware 11 yet, and i heard
"xorgconfig" and xorg is for gnome, and slackware 11 has no gnome
I read from other post, the command is "xf86config"
JUST TRY IT!
********************************************************************
Forget about xf86config please. That was the configurator for XFree86 which was removed from Slackware long time ago. It has nothing to do with Gnome at all. The "xorgconfig" program is the correct one to use for X.ORG which is the X version of Slackware.
By the way, Slackware has a preconfigured X that uses the VESA driver, which means that on most modern PC's you can simply start X with the "startx" command without having to run "xorgconfig" first!
Of course if you want to have the correct driver for your graphics card (to get hardware acceleration for instance) you need to re-configure your X using the "xorgconfig" command. The VESA driver is very generic, and works on virtuall all video cards, but it is not very fast.

Quote:
After all the changes, and when you reboot, you will have a graphical login.

What if when you reboot, x doesn't start?
You need to use a bootable Linux CD, and boot with it, mount your newly installed linux, and restore what you've done in /etc/inittab
Before setting your default runlevel to "4", you might want to check if that actually works before you edit /etc/inittab... if you edit that file and find out that your computer won't boot into X at all, you need more knowledge to fix the /etc/inittab file. Instead, try this first:
Being logged-on as root, run
Code:
init 4
This will change the computer's runlevel from 3 to 4 on the fly. And then see whether the graphical login manager starts. If that goes OK, you can edit your inittab file and reboot the PC.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 11 no GUI rotty Slackware 21 10-19-2006 04:18 AM
Does Slackware have a GUI? zahadumy Slackware 27 11-25-2005 11:54 PM
Slackware 10.0 won't go to GUI garbo73 Slackware 17 11-02-2004 11:20 AM
GUI for Slackware btexpress Slackware 10 05-17-2004 12:30 AM
slackware gui? emory7825 Linux - Newbie 3 11-26-2001 04:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration