-   Slackware (
-   -   No Cyrillic symbols in KDE and Gnome Slackware 10 (

plm 07-26-2004 05:45 AM

No Cyrillic symbols in KDE and Gnome Slackware 10

I have a problem. I can't see cyrillic text in any application! In KDE 3.2.3 cyrillic symbols appear like boxes. In GNOME 2.6 a cyrillic symbol appears as two rectangles one upon another with numbers inside them?! What should I do to see cyrillic texts and symbols!? Please help guys.

linmix 07-26-2004 02:25 PM

Install the correct font and if necessary tell your apps where to find it.

plm 07-29-2004 05:24 AM

Thanks, but which is the correct font? :( would the fonts from winxp work?

stelmed 07-29-2004 12:51 PM

Why don't you try the cyrillic font packet from the x folder of the slackware distribution?

plm 07-31-2004 07:37 AM

I did, I installed them when I installed slackware, I tried reinstalling them but still nothing happened :(

suslik 07-31-2004 03:52 PM

Use forume search more often.

There were a shitload of posts about this issue. Bellow is one of them.



1) write in /etc/rc.d/rc.font
setfont -v Cyr_a8x16
mapscrn koi2alt
for i in 1 2 3 4 5 6; do
echo -ne "\033(K" > /dev/tty$i
loadkeys ru-ms

2) write in /etc/profile.d/
export LANG=ru_RU.KOI8-R

3) edit (find this three lines) /usr/share/locale/locale.alias
russian ru_RU.KOI8-R
ru ru_RU.KOI8-R
ru_RU ru_RU.KOI8-R

4) edit /etc/X11/xorg.con
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic/
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

plm 07-31-2004 05:22 PM

Thanks I'll try it. I did search for similar threads in the forum but I didn't find something like this. Hope it works.

plm 07-31-2004 05:27 PM

But will the KOI8-R encoding work? In my country windows-1251 is a standard, and iso8859-5 is almost a standard too, but i've never seen KOI8-R, anyway, who cares if it works. :)

plm 07-31-2004 05:59 PM

Well, unfortunately this didn't help

abxbx 08-02-2004 09:43 PM

You need the following packages:



That's it, I think.

plm 08-03-2004 05:02 PM

Could you give me a link to these packages? I found the first one, but it is a archiving utility I think, for extracting windows .cab files. Why do I need it? About the other package I didn't find anything?!

suslik 08-03-2004 07:39 PM

plm, what user are you running as? root? some other? Slack is not the best cyrillic platform - strange things happen.
I had cyrillic show up as squares with numbers in them in KDE and pretty much everywhere while I ran as root (setting up, tweaking period) Then, I created a normal user and for that user, cyrillic works no problem.

Cyrillic support has been such a painful issue on many linux distros. I am hesitant to even start digging what actually happen. But... some wounds are made to be reopen...

1. Can you please post "Module" and "Files" section of your /etv/X11/xorg.conf
2. Tell me if you use default/root. Did you try cyrillic as new/normal user?

abxbx 08-04-2004 11:27 AM

Install this pkg before you install webfonts:


This should be all you have to do. I did the default Slack 10 install (by just installing everything) I did no modifications to my kernel, and it worked for me.

suslik 08-04-2004 01:16 PM


Originally posted by abxbx
Install this pkg before you install webfonts:

This should be all you have to do. I did the default Slack 10 install (by just installing everything) I did no modifications to my kernel, and it worked for me.

Slack10 installs freetype 2.1.7 as part of X. It is invoked in the modules section of xorg.conf. If you install 2.1.4 from link above - you'll be downgrading.

Just do a "locate freetype" - assuming you have done "updatedb" before. Among other things you'll see

I am certain it is a settings issue. The webfonts wouldn't hurt though.

Also, plz, post xorg.conf sections I requested above so we can check them and go further.

zsejk 08-04-2004 02:09 PM

Hey suslik,

Just thought I'd let you know I have the same issues, both as root and user, and that that solution posted above does indeed not work. Note that I didn't install the KDEI packages, so maybe plm didn't either and that's the problem. Or would that be unimportant?



Section "Module"

# This loads the DBE extension module.

    Load        "dbe"  # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"  # don't initialise the DGA extension

# This loads the font modules
    Load        "type1"
    Load        "freetype"
    Load        "speedo"

# This loads the GLX module
    Load      "glx"



Section "Files"

# The location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

    RgbPath    "/usr/X11R6/lib/X11/rgb"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
# If you don't have a floating point coprocessor and emacs, Mosaic or other
# programs take long to start up, try moving the Type1 and Speedo directory
# to the end of this list (or comment them out).

    FontPath  "/usr/X11R6/lib/X11/fonts/local/"
    FontPath  "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath  "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath  "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath  "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath  "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath  "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath  "/usr/X11R6/lib/X11/fonts/cyrillic/"

# ModulePath can be used to set a search path for the X server modules.
# The default path is shown here.

#    ModulePath "/usr/X11R6/lib/modules"


(just posting those in case plm's are the same; save him some posting time :) )

All times are GMT -5. The time now is 08:27 AM.