LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-23-2013, 09:03 AM   #1
ryanpcmcquen
Member
 
Registered: Apr 2013
Distribution: DistroWanderer
Posts: 381

Rep: Reputation: Disabled
No audio recorded in ffmpeg


Hello all.

I am feeding the following to ffmpeg:
Code:
ffmpeg -f x11grab -r 30 -s 1366x768 -i :0 -f alsa -ac 2 -i hw:1,0 -vcodec libx264 -crf 0 -preset ultrafast -acodec libvorbis -ab 192k ryVideo1.mkv
The video is working very well! However, despite my efforts, I have been unable to record any audio. I have also tried 'plughw:1,0'. My guess is that maybe I am recording the desktop audio instead of the audio from my built-in microphone.

My laptop is an HP dv6-6135dx. Here is the spec page:
http://h10025.www1.hp.com/ewfrf/wc/d...roduct=5118737

I have checked all 'alsamixer' settings, and have put them at a variety of levels. Here is some pertinent output:

Code:
{root@slack64}:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
{root@slack64}:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Generic_1 [HD-Audio Generic], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
I also put the following '.asoundrc' into the home and root folder:
Code:
pcm.!default {
  type hw
  card 1
}

ctl.!default {
  type hw
  card 1
}
Help! I'd really like to make some videos (with audio)!

;-)

Last edited by ryanpcmcquen; 09-23-2013 at 02:21 PM. Reason: Formatting.
 
Old 09-23-2013, 11:09 AM   #2
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Pittsburgh, PA
Distribution: Slackware
Posts: 270

Rep: Reputation: 87
Taking a bit of a shot in the dark, but there should be a device named 'CAPTURE' somewhere in alsamixer, or kmix, etc. On mine it's the second one from alsamixer on the f4 set. To enable it, you have to press space.

Not sure what else it could be really.
 
1 members found this post helpful.
Old 09-23-2013, 02:08 PM   #3
ryanpcmcquen
Member
 
Registered: Apr 2013
Distribution: DistroWanderer
Posts: 381

Original Poster
Rep: Reputation: Disabled
Talking

Quote:
Originally Posted by WhiteWolf1776 View Post
Taking a bit of a shot in the dark, but there should be a device named 'CAPTURE' somewhere in alsamixer, or kmix, etc. On mine it's the second one from alsamixer on the f4 set. To enable it, you have to press space.

Not sure what else it could be really.
You, sir, are a genius! Can't believe I missed that!


Thank you, thank you, thank you!
 
Old 09-23-2013, 07:42 PM   #4
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current, Manjaro 18.0.4 (development)
Posts: 720
Blog Entries: 1

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Quote:
Originally Posted by ryanpcmcquen View Post
You, sir, are a genius! Can't believe I missed that!


Thank you, thank you, thank you!
Sometimes it's the simple things that we as geniuses miss. *wink*
 
Old 09-07-2018, 07:31 AM   #5
abhijitnathwani
LQ Newbie
 
Registered: Sep 2018
Posts: 1

Rep: Reputation: Disabled
Hi @ryanpcmcquen
I am facing the same issue and didn't quite understand the solution. Can you please help me out how you got this working?

Thanks,
Abhijit
 
Old 09-07-2018, 10:21 AM   #6
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,951

Rep: Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647Reputation: 3647
Quote:
Originally Posted by abhijitnathwani View Post
Hi @ryanpcmcquen
I am facing the same issue and didn't quite understand the solution. Can you please help me out how you got this working?

Thanks,
Abhijit
This solution was for an older version of Slackware and might not apply to a newer version. Can you open up a new topic with your symptoms and what you've tried to do to fix it? Then we can try and help out with your current version of Slackware.
 
  


Reply

Tags
alsa, audio, capture, ffmpeg, record


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FFmpeg - Replace Audio With Audio From Another Video golmschenk Linux - Software 1 10-17-2012 02:10 PM
No audio perceived/recorded from around/ambient. Benny7440 Linux - Laptop and Netbook 12 06-26-2011 02:21 PM
Directing audio into ffmpeg Aylesworth Linux - General 2 07-13-2006 08:12 PM
ffmpeg problems - no audio Veteq Linux - Software 2 08-14-2005 10:04 PM
Recorded audio sounds horrible, but the untouched line-in sounds ok? justin218 Linux - Newbie 1 10-14-2003 05:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration