LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   no audio inputs available in Chrome (https://www.linuxquestions.org/questions/slackware-14/no-audio-inputs-available-in-chrome-4175672147/)

dimm0k 03-28-2020 04:00 PM

no audio inputs available in Chrome
 
running the latest bleeding edge version of Slackware-current and am unable to get my logitech webcam's microphone working under Google Chrome. the video with the webcam itself is fine and displays properly in Google Hangouts and I can hear the other party, but they can't hear me. I've allowed Chrome access to the microphone for Google Hangouts, but even then in the settings for Google Hangouts I do not see any devices selected or available for the microphone. what's weird is that the speaker is also not available as shown in the settings, but it's definitely available.

I've tried this in FireFox and while the settings do show available devices and are properly selected, the microphone and video do not work at all. any suggestions?

aus9 03-29-2020 04:02 AM

I do not use hangouts...but it may be a bit like old skype which I have used.
skype needed the first detected device to be the default device, not any other.
In alsa terms that means it must show up as card 0

post the output to
Code:

aplay -l
Leaping ahead...assuming you see hdmi then analog.....I suggest you need analog first.....and I assume both are intel kernel modules
snd_hda_intel
If you find your cards exactly as predicted....create a root powered module config to reverse the cards and turn off hdmi as a bonus.

Code:

sudo echo 'options snd-hda-intel enable=0,1' > /etc/modprobe.d/sound.conf
full reboot
repeat aplay -l should show index as swapped.

now run
Code:

alsamixer -c0 -Vall
use the right arrow key to navigate to either your front or rear mic

Depending on your alsamixer version....againt your mic...it will show as muted with MM in which case press m key to unmute
then raise volumes....or raise volumes in pulseaudio volume control

Depending on your alsamixer version...to activate if pressing m fails....you press the space bar and the image should show active with luck

good luck

dimm0k 03-29-2020 11:14 AM

Quote:

Originally Posted by aus9 (Post 6105539)
post the output to
Code:

aplay -l

Code:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: v15 [AudioQuest DragonFly Black v1.5], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: HD3 [Audioengine HD3], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

so the interesting thing is, the mic is only part of my USB webcam, which shows up in AlsaMixer v 1.2.2 as "HD Webcam C615", but it's not showing up in "aplay -l" at all. one thing I didn't mention is that in pavucontrol I do see the webcam in the list of "Input Devices" and the volume meter does seem to be monitor input from the mic.

aus9 03-31-2020 08:09 PM

Hi

usb webcam already has card 0 or did you do something? ahh what is that usb device if its not a cam?

if its not showing up post the output to, but it would be helpful to remove any usb sound mixer that you do not to test at the moment please

Code:

lsusb
Below is only if its a cam
anyhow as its card 0 take a screenshot of

Code:

alsamixer -c0 -Vall
upload it ingur.com and post the link please

I will show mine
https://imgur.com/c8Ijbqk

see how the numbers are showing up in red?

Depending on your version of alsa.....that control is activated by press the space bar for me,
but if that does not work try press the m key on your kb

Leaping ahead....if you see your levels are too low, raise them to around 80%

Some devices go distorted if at 100% but you can test that yourself with webcam recording software like
guvcview, cheese etc

dimm0k 04-06-2020 10:41 AM

very odd, but I'm going to chalk this up to Chrome misbehaving... I updated to the latest version of Chrome and now I'm able to access the mic in Chrome's preferences and in whatever app (Google Hangouts, FB Messenger) I use!


All times are GMT -5. The time now is 12:28 AM.