LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-18-2017, 10:48 PM   #1
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,113

Rep: Reputation: 101Reputation: 101
No audio


I'm back with more troubles on my new rig. I have Slackware64 14.2, KDE, ASRock 970M Pro3 M.B. I have plugged in an analog speaker to my green-jack in the back. No audio. This is apparently a common problem as I've found a lot of postings on the Internet, but nothing seems to solve my problem. This LQ post http://www.linuxquestions.org/questi...io-4175586056/, and after a lengthy series of responses he solved his problem, but neglected to post the solution.

I've followed the recommendations at https://docs.slackware.com/howtos:ha...s_on_slackware, but still nothing. The speaker is new and I've verified it works.

I've got 2 video cards with HDMI, but in System Settings > Multimedia > Audio and Video Settings, I've selected "Built-in Audio Analog Stereo as default". Testing it produces no sound.

running `alsmixer 0` and selecting "0 HDA ATI SB" shows sound-bars, but no sound.

`aplay -D plughw:0,0 somewavefile.wav` produces no sound.

The user is a member of the following groups: lp floppy audio video cdrom pulse messagebus plugdev power netdev scanner

Help
Code:
lspci -vvvvv
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
        Subsystem: ASRock Incorporation SBx00 Azalia (Intel HDA)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at fc100000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
Code:
# lsmod | grep snd
snd_hda_codec_hdmi     39395  8
snd_hda_codec_realtek    73238  1
snd_hda_codec_generic    61189  1 snd_hda_codec_realtek
snd_hda_intel          29531  9
snd_hda_codec         108205  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           52370  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep               6656  1 snd_hda_codec
snd_pcm                92738  5 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_timer              22109  1 snd_pcm
snd                    69051  24 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore               6876  1 snd
Code:
 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Last edited by mfoley; 08-18-2017 at 10:53 PM.
 
Old 08-18-2017, 11:44 PM   #2
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,415

Rep: Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359
Have you opened up pavucontrol and verified that the correct playback device is selected?
 
Old 08-19-2017, 12:19 AM   #3
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,113

Original Poster
Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by bassmadrigal View Post
Have you opened up pavucontrol and verified that the correct playback device is selected?
I tried that, but as the normal user I could not run it. su'ing to root wouldn't open a window. However, after your comment I logged in as root and ran it and I did get a window.

It shows 2 output devices, both GF108 HD Audio, port(s) HDMI/DisplayPort (unplugged). These are obviously the 2 video cards with HDMI. I've selected "Show All Output Devices", but the built-in analog device is not shown. Yet in my OP the system appears to recognize it and the KDE system settings shows it as a listed device.

Now what?
 
Old 08-19-2017, 12:48 AM   #4
Gordie
Member
 
Registered: Aug 2007
Distribution: Slackware, Puppy
Posts: 297

Rep: Reputation: 87
Simply open a terminal.

Code:
su
password
pavucontrol
It works here
 
Old 08-19-2017, 01:12 AM   #5
slackartist
Member
 
Registered: Oct 2015
Location: Where the buffalo's roam
Distribution: Slackware Current Multilib
Posts: 126
Blog Entries: 13

Rep: Reputation: 21
your aplay shows you have analog so set our asoundrc file to direct pulse? or alsa or something so the sound goes on that usually after i reboot (or something)

something like this

Code:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 0
so just with an editor in xterm or run level 3 should do it.
 
Old 08-19-2017, 01:56 AM   #6
elcore
Member
 
Registered: Sep 2014
Distribution: Slackware
Posts: 368

Rep: Reputation: Disabled
Quote:
Originally Posted by mfoley View Post
I've selected "Built-in Audio Analog Stereo as default". Testing it produces no sound.
It's not going to work by default because /etc/asound.conf points "hw0" to pulseaudio and not hardware analog output.
KDE phonon calls it "hw0" but system wide configuration apparently has a different idea on what "hw0" really is.
Source: I've removed libpulse and gtk3 from my system long ago.
 
Old 08-19-2017, 04:43 AM   #7
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,415

Rep: Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359
Quote:
Originally Posted by mfoley View Post
I tried that, but as the normal user I could not run it. su'ing to root wouldn't open a window. However, after your comment I logged in as root and ran it and I did get a window.
That is not normal. A normal user should be able to run it without requiring root access. I know you said it earlier, but you're sure that the normal user is assigned to the audio group? Do you have rc.alsa or rc.pulse exectuable (they shouldn't be)?
 
1 members found this post helpful.
Old 08-19-2017, 07:31 AM   #8
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 774

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Hello,

Quote:
Originally Posted by bassmadrigal View Post
That is not normal. A normal user should be able to run it without requiring root access. I know you said it earlier, but you're sure that the normal user is assigned to the audio group? Do you have rc.alsa or rc.pulse exectuable (they shouldn't be)?
With Pulseaudio, there must be no users in group "audio", otherwise, this can lead to issue especially when using fast user switching. See here and there.

--
SeB

Last edited by phenixia2003; 08-19-2017 at 07:53 AM.
 
Old 08-19-2017, 11:24 AM   #9
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,113

Original Poster
Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by bassmadrigal View Post
That is not normal. A normal user should be able to run it without requiring root access. I know you said it earlier, but you're sure that the normal user is assigned to the audio group? Do you have rc.alsa or rc.pulse exectuable (they shouldn't be)?
You are right, I can run as a normal user. I must have misstyped it more than once. I now am able to run pavucontrol.
Quote:
Originally Posted by slackartist View Post
your aplay shows you have analog so set our asoundrc file to direct pulse? or alsa or something so the sound goes on that usually after i reboot (or something)

something like this

Code:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 0
My /etc/asound.conf is now:
Code:
# ALSA system-wide config file
# By default, redirect to PulseAudio:
#pcm.default pulse
#ctl.default pulse

defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0
The only difference between the above and what I had is that I commented out the 2 pcm... lines 3 and 4.
Quote:
Originally Posted by elcore View Post
It's not going to work by default because /etc/asound.conf points "hw0" to pulseaudio and not hardware analog output.
KDE phonon calls it "hw0" but system wide configuration apparently has a different idea on what "hw0" really is.
Source: I've removed libpulse and gtk3 from my system long ago.
Are you suggesting I remove /user/lib64/libpulse* from my system?
Quote:
Originally Posted by phenixia2003 View Post
Hello,

With Pulseaudio, there must be no users in group "audio", otherwise, this can lead to issue especially when using fast user switching. See here and there.
I've removed my user from the audio group. root and pulse are still in that group.

After commenting the pcm... lines in /etc/asound.conf and removing my user from the audio group and rebooting, still no audio.

pavucontrol > playback > Applications, shows me playing a youtube video on "Built-in Audio Analog Stereo", and there is a soundbar showing volume rising and falling.

pavucontrol > Configuration, shows the two GF108 HDMI cards, and the Built-in Audio.

pavucontrol > Output Devices, still only shows the two GF108 HDMI cards (unplugged). The Built-in Audio is not listed.

Last edited by mfoley; 08-19-2017 at 11:46 AM.
 
Old 08-19-2017, 11:58 AM   #10
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 774

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Hello,

Quote:
Originally Posted by mfoley View Post
pavucontrol > Configuration, shows the two GF108 HDMI cards, and the Built-in Audio.
What is the selected profile for Built-in Audio ?

Have you tried to select another ?

--
SeB
 
Old 08-19-2017, 12:44 PM   #11
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,415

Rep: Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359Reputation: 2359
Quote:
Originally Posted by phenixia2003 View Post
With Pulseaudio, there must be no users in group "audio", otherwise, this can lead to issue especially when using fast user switching. See here and there.
This may be something to bring up in the Requests for -current thread, because with both 14.2 and -current, users are automatically added to the audio group if you press "UP" during the additional groups portion of the adduser script.

Luckily, I don't need to support fast-user switching, but if it is broke, then Pat and team should probably be informed.
 
2 members found this post helpful.
Old 08-19-2017, 01:11 PM   #12
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,113

Original Poster
Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by phenixia2003 View Post
Hello,
What is the selected profile for Built-in Audio ?

Have you tried to select another ?
What/where do I find "selected profile"?
Quote:
Originally Posted by bassmadrigal View Post
This may be something to bring up in the Requests for -current thread, because with both 14.2 and -current, users are automatically added to the audio group if you press "UP" during the additional groups portion of the adduser script.

Luckily, I don't need to support fast-user switching, but if it is broke, then Pat and team should probably be informed.
I'm not using fast-user switching either. Should I or should I not have my user in the audio group? I did have to add the user to the audio group on a different 14.2 system with a ASUSTeK M4N68T-M-V2 motherboard to get sound from an external speaker, but that system is not running KDE.

As root I tried:
Code:
# mplayer /usr/lib64/libreoffice-5.3.4.2/share/gallery/sounds/roll.wav
MPlayer 1.2.1-5.3.0 (C) 2000-2016 MPlayer Team

Playing /usr/lib64/libreoffice-5.3.4.2/share/gallery/sounds/roll.wav.
libavformat version 56.40.101 (internal)
Audio only file format detected.
Load subtitles in /usr/lib64/libreoffice-5.3.4.2/share/gallery/sounds/
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 1 ch, s16le, 352.8 kbit/100.00% (ratio: 44100->44100)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   5.2 (05.1) of 5.0 (05.0)  0.3% 


Exiting... (End of file)
No error, no sound.

Last edited by mfoley; 08-19-2017 at 01:16 PM.
 
Old 08-19-2017, 01:33 PM   #13
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 774

Rep: Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588Reputation: 588
Hello,

Quote:
Originally Posted by mfoley View Post
What/where do I find "selected profile"?
In pavucontrol > Configuration, just under Built-in Audio, see the attached screenshot below :
Click image for larger version

Name:	pavucontrol.jpg
Views:	23
Size:	46.3 KB
ID:	25735
--
SeB
 
1 members found this post helpful.
Old 08-19-2017, 03:31 PM   #14
mfoley
Senior Member
 
Registered: Oct 2008
Posts: 1,113

Original Poster
Rep: Reputation: 101Reputation: 101
My pavucontrol > Configuration, under Built-in Audio has: Analog Stereo Duplex (unplugged), Analog Stereo Output (unplugged), Analog Stereo Input (unplugged), and Off. The first, Analog Stereo Duplex (unplugged), is selected.

Last edited by mfoley; 08-19-2017 at 03:35 PM.
 
Old 08-19-2017, 09:35 PM   #15
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.2 Slackware 14.2, Slackware{32,64}-current
Posts: 785
Blog Entries: 3

Rep: Reputation: 275Reputation: 275Reputation: 275
Well, that means no speaker is plugged into the Built-in Audio jack. Go back to the original asound.conf, try running 'aplay -L' (capital ell) to get the alsa channels, then use 'speaker-test' with the channel name and not the hardware designation (which is a moving target now). Take a close look at the speaker jacks on the sound card/mobo and make sure you are plugged into the correct jack. These days, the jacks can be front, rear, center, Line Out, etc... I would NOT trust the colors since they also might be autosensing (in Windows) and ALSA could be picking different defaults. Also, you will definitely need to be in 'audio' group for some tasks.
Code:
speaker-test -Dplug:pulse -c2 -twav
or
speaker-test -Dplug:front -c2 -twav
or
speaker-test -Dplug:surround40 -c4 -twav
to get something like:
Code:
$ speaker-test -Dplug:surround40 -c4 -twav

speaker-test 1.1.1

Playback device is plug:surround40
Stream parameters are 48000Hz, S16_LE, 4 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 32 to 262144
Period size range from 16 to 131072
Using max buffer size 262144
Periods = 4
was set period_size = 65536
was set buffer_size = 262144
 0 - Front Left
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
Time per period = 9.580560
 0 - Front Left
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
Time per period = 9.568857
If pavucontrol shows 'unplugged' you will need to fix that. Alsa still runs the audio and it is simply not seeing your speakers. Or PA is goofed this happens when I 'vncserver -kill :1' so try:
Code:
$ pulseaudio --kill 
$ pulseaudio --start.
 
1 members found this post helpful.
  


Reply

Tags
sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How To Enable Beats Audio Subwoofer Audio On a HP Laptop In Ubuntu/Linux LXer Syndicated Linux News 0 12-05-2015 09:33 AM
can no longer change audio settings, missing gstreamer plugin or no audio device dsollen Linux - General 3 11-16-2009 09:40 AM
[SOLVED] Onboard Audio (hda_intel) for Mic Input and Soundcard (ca0106) for Audio Output? snowdonkey Linux - General 1 07-11-2009 04:17 PM
smplayer: video+audio stutters with pulseaudio, audio files play fine GamerX Linux - Desktop 1 02-06-2009 09:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration